aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ecl/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2008-09-05 04:07:50 +0800
committerpav <pav@FreeBSD.org>2008-09-05 04:07:50 +0800
commite7d168334baa6d2f1b23cccb25cdcd985b6222a0 (patch)
tree433061317bcf09d37d87495674aae5670b5b901f /lang/ecl/Makefile
parent58a91d550ec3712bbfa4cc5a884854d8fd633ad4 (diff)
downloadfreebsd-ports-graphics-e7d168334baa6d2f1b23cccb25cdcd985b6222a0.tar.gz
freebsd-ports-graphics-e7d168334baa6d2f1b23cccb25cdcd985b6222a0.tar.zst
freebsd-ports-graphics-e7d168334baa6d2f1b23cccb25cdcd985b6222a0.zip
- Update to 0.9l
PR: ports/126920 Submitted by: fulvio ciriaco <oivulf@gmail.com>
Diffstat (limited to 'lang/ecl/Makefile')
-rw-r--r--lang/ecl/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/lang/ecl/Makefile b/lang/ecl/Makefile
index add909ebb45..a137372f482 100644
--- a/lang/ecl/Makefile
+++ b/lang/ecl/Makefile
@@ -6,23 +6,23 @@
#
PORTNAME= ecl
-PORTVERSION= 0.9g
-PORTREVISION= 2
+PORTVERSION= 0.9l
CATEGORIES= lang lisp
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ecls
+EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= An ANSI Common Lisp implementation
-LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4
+LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4 gc.1:${PORTSDIR}/devel/boehm-gc
USE_GMAKE= yes
USE_PERL5_BUILD=yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-system-gmp --with-cmuformat=yes --enable-boehm=included
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CPPFLAGS= -I${LOCALBASE}/include
+CONFIGURE_ARGS= --with-system-gmp --enable-boehm=system
+CONFIGURE_ENV= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+CFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
OPTIONS= ASDF "Enable ASDF building facility" on \
@@ -31,9 +31,6 @@ OPTIONS= ASDF "Enable ASDF building facility" on \
SOCKETS "Enable socket interface" on \
THREADS "Enable threading support" off
-MAN1= ecl.1
-INFO= ecl ecldev
-
USE_LDCONFIG= yes
LDCONFIG_DIRS= %%PREFIX%%/lib/ecl
@@ -62,7 +59,7 @@ PLIST_SUB+= CLOS_STREAMS="@comment "
.if defined(WITH_CLX)
USE_XORG= x11
CONFIGURE_ARGS+=--with-clx=yes
-INFO+= clx
+#INFO+= clx
PLIST_SUB+= CLX=""
.else
CONFIGURE_ARGS+=--with-clx=no