aboutsummaryrefslogtreecommitdiffstats
path: root/lang/erlang
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2010-01-28 20:27:01 +0800
committerolgeni <olgeni@FreeBSD.org>2010-01-28 20:27:01 +0800
commite7409bcdcdca313e18d1e05c9760779f2f0d8fd5 (patch)
treea1a822be8f0d4b4f48eed57418e472a5021259b7 /lang/erlang
parent7432b4f76b106245616db29515945e2a86dbc644 (diff)
downloadfreebsd-ports-graphics-e7409bcdcdca313e18d1e05c9760779f2f0d8fd5.tar.gz
freebsd-ports-graphics-e7409bcdcdca313e18d1e05c9760779f2f0d8fd5.tar.zst
freebsd-ports-graphics-e7409bcdcdca313e18d1e05c9760779f2f0d8fd5.zip
Add OPTIONS support.
Obtained from: Jim Wagner <jwagner graffadmin com>
Diffstat (limited to 'lang/erlang')
-rw-r--r--lang/erlang/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/lang/erlang/Makefile b/lang/erlang/Makefile
index 1f75e8ac22e..c439d059f6f 100644
--- a/lang/erlang/Makefile
+++ b/lang/erlang/Makefile
@@ -29,6 +29,14 @@ CONFLICTS?= erlang-lite-r[0-9]*
SUB_FILES= pkg-message
SUB_LIST= TOOLS_VSN=${TOOLS_VSN}
+OPTIONS= JAVA "Enable Java applications" on \
+ X11 "Enable X11 support" on \
+ WX "Enable WX Extensions" on \
+ ODBC "Enable ODBC" on \
+ SMP "Enable SMP" on
+
+.include <bsd.port.pre.mk>
+
# The Java applications that are part of the Erlang distribution are
# not strictly necessary - it is included for completeness sake. A
# problem with the Erlang build procedure is that it only checks if
@@ -52,7 +60,7 @@ USE_TK_RUN= yes
USE_WX= 2.8+
WX_COMPS= wx contrib
WX_UNICODE= yes
-CONFIGURE_ARGS+= --with-wx-config=${WX_CONFIG}
+CONFIGURE_ARGS+=--with-wx-config=${WX_CONFIG}
.endif
.endif
@@ -64,8 +72,6 @@ ONLY_FOR_ARCHS= i386 amd64 sparc64
REINPLACE_ARGS= -i
MAKE_JOBS_UNSAFE= yes
-.include <bsd.port.pre.mk>
-
.if !defined(WITHOUT_ODBC)
DRIVER_MANAGER?= iodbc
.if ${DRIVER_MANAGER} == "unixodbc"
@@ -84,7 +90,11 @@ ERLANG_PLIST= ${WRKDIR}/pkg-plist
# enabling --enable-smp-support crashes the OS when
# net_kernel:start([node_name, shortnames]) invoked repeatedly
-CONFIGURE_ARGS+= --enable-threads --enable-dynamic-ssl-lib --enable-sctp --enable-smp-support
+.if !defined(WITHOUT_SMP)
+CONFIGURE_ARGS+=--enable-threads --enable-dynamic-ssl-lib --enable-sctp --enable-smp-support
+.else
+CONFIGURE_ARGS+=--enable-threads --enable-dynamic-ssl-lib --enable-sctp
+.endif
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib