aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gauche/files
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-09-10 02:47:42 +0800
committerknu <knu@FreeBSD.org>2002-09-10 02:47:42 +0800
commita702d4f445eb7d06ed958c82bb67f711b2559662 (patch)
tree608231700809c0b6c2acc0d248887c43692927af /lang/gauche/files
parent67b07544c337de571c4fc9a323bf8083c16da3a5 (diff)
downloadfreebsd-ports-graphics-a702d4f445eb7d06ed958c82bb67f711b2559662.tar.gz
freebsd-ports-graphics-a702d4f445eb7d06ed958c82bb67f711b2559662.tar.zst
freebsd-ports-graphics-a702d4f445eb7d06ed958c82bb67f711b2559662.zip
Add gauche, a scheme script interpreter with multibyte character
handling.
Diffstat (limited to 'lang/gauche/files')
-rw-r--r--lang/gauche/files/patch-doc-Makefile.in63
-rw-r--r--lang/gauche/files/patch-doc-gauche-refe.texi13
-rw-r--r--lang/gauche/files/patch-doc-gauche-refj.texi13
3 files changed, 89 insertions, 0 deletions
diff --git a/lang/gauche/files/patch-doc-Makefile.in b/lang/gauche/files/patch-doc-Makefile.in
new file mode 100644
index 00000000000..1086a1715b1
--- /dev/null
+++ b/lang/gauche/files/patch-doc-Makefile.in
@@ -0,0 +1,63 @@
+--- doc/Makefile.in.orig Fri Jul 19 14:47:53 2002
++++ doc/Makefile.in Mon Sep 9 23:36:04 2002
+@@ -11,8 +11,8 @@
+ # make mandir=wherever
+ prefix = @prefix@
+ datadir = @datadir@
+-mandir = $(datadir)/man/man1
+-infodir = $(datadir)/info
++mandir = $(prefix)/man/man1
++infodir = $(prefix)/info
+
+ all: info
+
+@@ -22,8 +22,8 @@
+ $(INSTALL) -m 444 $$m $(mandir)/; \
+ done
+ if test ! -d $(infodir); then $(INSTALL) -d $(infodir); fi
+- if test -f gauche-refe.info.gz -o -f gauche-refj.info.gz; then \
+- for info in *.info*; do \
++ if test -f gauche-refe.info -o -f gauche-refj.info; then \
++ for info in *.info; do \
+ $(INSTALL) -m 444 $$info $(infodir)/; \
+ done; \
+ fi
+@@ -48,7 +48,7 @@
+
+ pdf : gauche-refe.pdf
+
+-info : gauche-refe.info.gz gauche-refj.info.gz
++info : gauche-refe.info gauche-refj.info
+
+ gauche-refe.html : gauche-refe.texi
+ texi2html -number gauche-refe.texi
+@@ -65,11 +65,9 @@
+ gauche-refe.texi : gauche-ref.texi extract
+ gosh ./extract -en -o gauche-refe.texi gauche-ref.texi
+
+-gauche-refe.info.gz : gauche-refe.texi
+- if test X$(MAKEINFO) != X -a X$(GZIP) != X; then \
+- $(MAKEINFO) --no-warn gauche-refe.texi; \
+- rm -rf gauche-refe.info*.gz; \
+- $(GZIP) gauche-refe.info gauche-refe.info-[0-9]*; \
++gauche-refe.info : gauche-refe.texi
++ if test X$(MAKEINFO) != X; then \
++ $(MAKEINFO) --no-split --no-warn gauche-refe.texi; \
+ fi
+
+ gauche-refj.html : gauche-refj.texi
+@@ -87,11 +85,9 @@
+ gauche-refj.texi : gauche-ref.texi extract
+ gosh ./extract -jp -o gauche-refj.texi gauche-ref.texi
+
+-gauche-refj.info.gz : gauche-refj.texi
+- if test X$(MAKEINFO) != X -a X$(GZIP) != X; then \
+- $(MAKEINFO) --no-warn gauche-refj.texi; \
+- rm -rf gauche-refj.info*.gz; \
+- $(GZIP) gauche-refj.info gauche-refj.info-[0-9]*; \
++gauche-refj.info : gauche-refj.texi
++ if test X$(MAKEINFO) != X; then \
++ $(MAKEINFO) --no-split --no-warn gauche-refj.texi; \
+ fi
+
+ clean:
diff --git a/lang/gauche/files/patch-doc-gauche-refe.texi b/lang/gauche/files/patch-doc-gauche-refe.texi
new file mode 100644
index 00000000000..071be8553da
--- /dev/null
+++ b/lang/gauche/files/patch-doc-gauche-refe.texi
@@ -0,0 +1,13 @@
+--- doc/gauche-refe.texi.orig Tue Sep 3 09:36:37 2002
++++ doc/gauche-refe.texi Tue Sep 10 01:08:58 2002
+@@ -8,2 +8,10 @@
+
++@ifinfo
++@format
++START-INFO-DIR-ENTRY
++* Gauche-en: (gauche-refe). The Gauche Reference Manual [en]
++END-INFO-DIR-ENTRY
++@end format
++@end ifinfo
++
+ @c module and class index
diff --git a/lang/gauche/files/patch-doc-gauche-refj.texi b/lang/gauche/files/patch-doc-gauche-refj.texi
new file mode 100644
index 00000000000..494d7a5ff7d
--- /dev/null
+++ b/lang/gauche/files/patch-doc-gauche-refj.texi
@@ -0,0 +1,13 @@
+--- doc/gauche-refj.texi.orig Tue Sep 3 09:36:47 2002
++++ doc/gauche-refj.texi Tue Sep 10 01:08:59 2002
+@@ -8,2 +8,10 @@
+
++@ifinfo
++@format
++START-INFO-DIR-ENTRY
++* Gauche-ja: (gauche-refj). The Gauche Reference Manual [ja]
++END-INFO-DIR-ENTRY
++@end format
++@end ifinfo
++
+ @c module and class index