aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc-aux
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-03-22 20:31:11 +0800
committermarino <marino@FreeBSD.org>2014-03-22 20:31:11 +0800
commit78ea302b9207d99648208c40d73f77dbcefef19e (patch)
tree06d18da49c0063d65a17c8e3cde18233f76a8923 /lang/gcc-aux
parent8352dfa84495fc2b9343f7a5016ba204eed2b794 (diff)
downloadfreebsd-ports-graphics-78ea302b9207d99648208c40d73f77dbcefef19e.tar.gz
freebsd-ports-graphics-78ea302b9207d99648208c40d73f77dbcefef19e.tar.zst
freebsd-ports-graphics-78ea302b9207d99648208c40d73f77dbcefef19e.zip
lang/gcc-aux: Fix parallel jobs build (GCC bug)
The cause for the build errors are due to a GCC makefile bug. C++ is now required to build gnattools, but libstdc++ was not listed as a dependency. The fix for this bug will be posted to GCC's bugzilla shortly. While here, bump gcc-aux to the latest snapshot (16 March). Now gcc-aux passes Redports 8x. Reported by: pkg-fallout
Diffstat (limited to 'lang/gcc-aux')
-rw-r--r--lang/gcc-aux/Makefile.version2
-rw-r--r--lang/gcc-aux/distinfo4
-rw-r--r--lang/gcc-aux/files/diff-ada16
-rw-r--r--lang/gcc-aux/files/diff-core14
-rw-r--r--lang/gcc-aux/files/diff-fortran2
-rw-r--r--lang/gcc-aux/files/patch-Makefile.def10
-rw-r--r--lang/gcc-aux/files/patch-Makefile.in10
7 files changed, 39 insertions, 19 deletions
diff --git a/lang/gcc-aux/Makefile.version b/lang/gcc-aux/Makefile.version
index 7d39576be07..fe93ffd8267 100644
--- a/lang/gcc-aux/Makefile.version
+++ b/lang/gcc-aux/Makefile.version
@@ -3,7 +3,7 @@
GCC_BRANCH= 4.9
GCC_POINT= 0
GCC_VERSION= ${GCC_BRANCH}.${GCC_POINT}
-SNAPSHOT= 20140302
+SNAPSHOT= 20140316
IDENTIFICATION= gcc-${GCC_BRANCH}-${SNAPSHOT}
MS_SUBDIR= snapshots/${GCC_BRANCH}-${SNAPSHOT}
diff --git a/lang/gcc-aux/distinfo b/lang/gcc-aux/distinfo
index 15f4f21035e..4a1f9b64cbe 100644
--- a/lang/gcc-aux/distinfo
+++ b/lang/gcc-aux/distinfo
@@ -1,5 +1,5 @@
-SHA256 (gcc-4.9-20140302.tar.bz2) = 78838c2e96460326f2d39855afeae4f1473ac4280bdf513c239841bced24d149
-SIZE (gcc-4.9-20140302.tar.bz2) = 85100991
+SHA256 (gcc-4.9-20140316.tar.bz2) = b1c62b70f98c551ce74ad8c6a5e7342fe9c899116f98aae2b9ca142a478a712c
+SIZE (gcc-4.9-20140316.tar.bz2) = 85573522
SHA256 (ada-bootstrap.i386.dragonfly.36A.tar.bz2) = 6b1a6ff0fe0e3bf13c667db2fef177b811329cd998400a1303969a86911cb1c8
SIZE (ada-bootstrap.i386.dragonfly.36A.tar.bz2) = 39357314
SHA256 (ada-bootstrap.i386.freebsd.84.tar.bz2) = b410336cb0e71c8a29dd5f831a17b4b7282e7d590f452475a94c6a625cfc8846
diff --git a/lang/gcc-aux/files/diff-ada b/lang/gcc-aux/files/diff-ada
index 6ca2b99dbc0..b3c301897cb 100644
--- a/lang/gcc-aux/files/diff-ada
+++ b/lang/gcc-aux/files/diff-ada
@@ -8136,7 +8136,7 @@
TARGET_ADA_SRCS =
--- gcc/ada/gcc-interface/Makefile.in.orig
+++ gcc/ada/gcc-interface/Makefile.in
-@@ -1043,9 +1043,11 @@
+@@ -1044,9 +1044,11 @@
ifeq ($(strip $(filter-out arm% linux-androideabi,$(target_cpu) $(target_os))),)
LIBGNAT_TARGET_PAIRS = \
a-intnam.ads<a-intnam-linux.ads \
@@ -8148,7 +8148,7 @@
s-osinte.adb<s-osinte-android.adb \
s-osinte.ads<s-osinte-android.ads \
s-osprim.adb<s-osprim-posix.adb \
-@@ -1055,10 +1057,6 @@
+@@ -1056,10 +1058,6 @@
system.ads<system-linux-armel.ads \
$(DUMMY_SOCKETS_TARGET_PAIRS)
@@ -8159,7 +8159,7 @@
GNATRTL_SOCKETS_OBJS =
EXTRA_GNATRTL_TASKING_OBJS=s-linux.o
EH_MECHANISM=
-@@ -1071,6 +1069,7 @@
+@@ -1072,6 +1070,7 @@
ifeq ($(strip $(filter-out sparc% sun solaris%,$(target_cpu) $(target_vendor) $(target_os))),)
LIBGNAT_TARGET_PAIRS_COMMON = \
a-intnam.ads<a-intnam-solaris.ads \
@@ -8167,7 +8167,7 @@
s-inmaop.adb<s-inmaop-posix.adb \
s-intman.adb<s-intman-solaris.adb \
s-mudido.adb<s-mudido-affinity.adb \
-@@ -1113,6 +1112,8 @@
+@@ -1114,6 +1113,8 @@
TOOLS_TARGET_PAIRS=mlib-tgt-specific.adb<mlib-tgt-specific-solaris.adb
EH_MECHANISM=-gcc
@@ -8176,7 +8176,7 @@
THREADSLIB = -lposix4 -lthread
MISCLIB = -lposix4 -lnsl -lsocket
SO_OPTS = -Wl,-h,
-@@ -1324,12 +1325,17 @@
+@@ -1325,12 +1326,17 @@
# x86 FreeBSD
ifeq ($(strip $(filter-out %86 freebsd%,$(target_cpu) $(target_os))),)
LIBGNAT_TARGET_PAIRS = \
@@ -8196,7 +8196,7 @@
s-taprop.adb<s-taprop-posix.adb \
s-taspri.ads<s-taspri-posix.ads \
s-tpopsp.adb<s-tpopsp-posix.adb \
-@@ -1337,11 +1343,12 @@
+@@ -1338,11 +1344,12 @@
$(X86_TARGET_PAIRS) \
system.ads<system-freebsd-x86.ads
@@ -8211,7 +8211,7 @@
EH_MECHANISM=-gcc
THREADSLIB= -lpthread
-@@ -1353,12 +1360,17 @@
+@@ -1354,12 +1361,17 @@
# x86-64 FreeBSD
ifeq ($(strip $(filter-out %86_64 freebsd%,$(target_cpu) $(target_os))),)
LIBGNAT_TARGET_PAIRS = \
@@ -8231,7 +8231,7 @@
s-taprop.adb<s-taprop-posix.adb \
s-taspri.ads<s-taspri-posix.ads \
s-tpopsp.adb<s-tpopsp-posix.adb \
-@@ -1366,11 +1378,240 @@
+@@ -1367,11 +1379,240 @@
$(X86_64_TARGET_PAIRS) \
system.ads<system-freebsd-x86_64.ads
diff --git a/lang/gcc-aux/files/diff-core b/lang/gcc-aux/files/diff-core
index 0cb5aafeb99..bedb57ffed9 100644
--- a/lang/gcc-aux/files/diff-core
+++ b/lang/gcc-aux/files/diff-core
@@ -1331,7 +1331,7 @@
;;
i[34567]86-*-openbsd2.*|i[34567]86-*openbsd3.[0123])
tm_file="i386/i386.h i386/unix.h i386/bsd.h i386/gas.h i386/gstabs.h openbsd-oldgas.h openbsd.h i386/openbsd.h"
-@@ -4106,6 +4137,8 @@
+@@ -4109,6 +4140,8 @@
;;
i[34567]86-*-mingw* | x86_64-*-mingw*)
;;
@@ -1342,7 +1342,7 @@
ia64*-*-linux*)
--- gcc/configure.orig
+++ gcc/configure
-@@ -27347,6 +27347,20 @@
+@@ -27421,6 +27421,20 @@
gcc_cv_target_dl_iterate_phdr=no
fi
;;
@@ -1414,7 +1414,7 @@
insn-preds.c: s-preds; @true
tm-preds.h: s-preds-h; @true
tm-constrs.h: s-constrs-h; @true
-@@ -3207,6 +3218,9 @@
+@@ -3208,6 +3219,9 @@
-rm -f $(DESTDIR)$(bindir)/$(target_noncanonical)-gcc-$(version)$(exeext)
-( cd $(DESTDIR)$(bindir) && \
$(LN) $(GCC_INSTALL_NAME)$(exeext) $(target_noncanonical)-gcc-$(version)$(exeext) )
@@ -1438,7 +1438,7 @@
*-*-freebsd*)
# This is the generic ELF configuration of FreeBSD. Later
# machine-specific sections may refine and add to this
-@@ -235,7 +240,8 @@
+@@ -238,7 +243,8 @@
extra_parts="crtbegin.o crtbeginS.o crtend.o crtendS.o"
;;
*-*-netbsd*)
@@ -1448,7 +1448,7 @@
# NetBSD 1.7 and later are set up to use GCC's crtstuff for
# ELF configurations. We will clear extra_parts in the
# a.out configurations.
-@@ -299,7 +305,10 @@
+@@ -302,7 +308,10 @@
esac
case ${host} in
@@ -1460,7 +1460,7 @@
enable_execute_stack=enable-execute-stack-mprotect.c
;;
i[34567]86-*-mingw* | x86_64-*-mingw*)
-@@ -542,16 +551,29 @@
+@@ -545,16 +554,29 @@
x86_64-*-elf*)
tmake_file="$tmake_file i386/t-crtstuff t-crtstuff-pic t-libgcc-pic"
;;
@@ -1490,7 +1490,7 @@
;;
i[34567]86-*-openbsd2.*|i[34567]86-*openbsd3.[0123])
;;
-@@ -1256,6 +1278,7 @@
+@@ -1259,6 +1281,7 @@
i[34567]86-*-solaris2* | x86_64-*-solaris2.1[0-9]* | \
i[34567]86-*-cygwin* | x86_64-*-cygwin* | \
i[34567]86-*-mingw* | x86_64-*-mingw* | \
diff --git a/lang/gcc-aux/files/diff-fortran b/lang/gcc-aux/files/diff-fortran
index f3b59e2f9e4..6781da1ae8e 100644
--- a/lang/gcc-aux/files/diff-fortran
+++ b/lang/gcc-aux/files/diff-fortran
@@ -1,6 +1,6 @@
--- gcc/fortran/f95-lang.c.orig
+++ gcc/fortran/f95-lang.c
-@@ -715,10 +715,17 @@
+@@ -718,10 +718,17 @@
gfc_define_builtin ("__builtin_cabsl", func_clongdouble_longdouble,
BUILT_IN_CABSL, "cabsl", ATTR_CONST_NOTHROW_LEAF_LIST);
diff --git a/lang/gcc-aux/files/patch-Makefile.def b/lang/gcc-aux/files/patch-Makefile.def
new file mode 100644
index 00000000000..37e60a4ec7c
--- /dev/null
+++ b/lang/gcc-aux/files/patch-Makefile.def
@@ -0,0 +1,10 @@
+--- Makefile.def.orig 2013-10-29 13:37:47.000000000 -0500
++++ Makefile.def
+@@ -336,6 +336,7 @@ dependencies = { module=all-libcpp; on=a
+ dependencies = { module=all-fixincludes; on=all-libiberty; };
+
+ dependencies = { module=all-gnattools; on=all-target-libada; };
++dependencies = { module=all-gnattools; on=all-target-libstdc++-v3; };
+
+ dependencies = { module=all-lto-plugin; on=all-libiberty; };
+
diff --git a/lang/gcc-aux/files/patch-Makefile.in b/lang/gcc-aux/files/patch-Makefile.in
new file mode 100644
index 00000000000..1773cd8d65a
--- /dev/null
+++ b/lang/gcc-aux/files/patch-Makefile.in
@@ -0,0 +1,10 @@
+--- Makefile.in.orig 2014-03-07 07:58:27.000000000 -0500
++++ Makefile.in
+@@ -46730,6 +46730,7 @@ all-stageprofile-libcpp: maybe-all-stage
+ all-stagefeedback-libcpp: maybe-all-stagefeedback-intl
+ all-fixincludes: maybe-all-libiberty
+ all-gnattools: maybe-all-target-libada
++all-gnattools: maybe-all-target-libstdc++-v3
+ all-lto-plugin: maybe-all-libiberty
+
+ all-stage1-lto-plugin: maybe-all-stage1-libiberty