aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc34/Makefile
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2005-07-06 05:20:42 +0800
committergerald <gerald@FreeBSD.org>2005-07-06 05:20:42 +0800
commit70826a4300c2c043ca683bfb2ad3d8424ee55cd8 (patch)
tree01c9e33ff725b1519c3fecd6ac28e8af8e6b856a /lang/gcc34/Makefile
parent22400d79561cff23b1a4d998a3efcb018c33b30d (diff)
downloadfreebsd-ports-graphics-70826a4300c2c043ca683bfb2ad3d8424ee55cd8.tar.gz
freebsd-ports-graphics-70826a4300c2c043ca683bfb2ad3d8424ee55cd8.tar.zst
freebsd-ports-graphics-70826a4300c2c043ca683bfb2ad3d8424ee55cd8.zip
Update to the 20050628 snapshot of GCC 3.4.5.
Directly install libraries into a port-specific location instead of moving them there after the original installation. This is simpler and also avoids the problem where the port would overwrite/remove an existing copy of libiberty.a, which boils down to a true conflict.
Diffstat (limited to 'lang/gcc34/Makefile')
-rw-r--r--lang/gcc34/Makefile11
1 files changed, 3 insertions, 8 deletions
diff --git a/lang/gcc34/Makefile b/lang/gcc34/Makefile
index 7f6dfe79294..675844e166f 100644
--- a/lang/gcc34/Makefile
+++ b/lang/gcc34/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gcc
PORTVERSION= 3.4.5
-PORTREVISION= 20050607
+PORTREVISION= 20050628
CATEGORIES= lang
VERSIONSTRING= 3.4-${PORTREVISION}
MASTER_SITES= ${MASTER_SITE_GCC}
@@ -56,13 +56,13 @@ CONFIGURE_ARGS= --disable-nls \
--with-system-zlib \
--with-libiconv-prefix=${LOCALBASE} \
--program-suffix=${SUFFIX} \
+ --libdir=${TARGLIB} \
--with-gxx-include-dir=${TARGLIB}/include/c++/
MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
.if defined(WANT_SHAREDLIBS)
CONFIGURE_ARGS+= --enable-shared
INSTALLS_SHLIB= yes
LDCONFIG_DIRS= %%PREFIX%%/lib ${TARGLIB}
-EXTRA_LIBS= libgcc_s
.else
CONFIGURE_ARGS+= --disable-shared
.if ${OSVERSION} < 500000 && ${ARCH} == alpha
@@ -116,12 +116,7 @@ post-install:
.endfor
${MV} -f ${PREFIX}/bin/g77${SUFFIX} ${PREFIX}/bin/g77-${SUFFIX}
-${MV} -f ${PREFIX}/man/man1/g77${SUFFIX}.1 ${PREFIX}/man/man1/g77-${SUFFIX}.1
- # These libraries are moved from PREFIX/lib to avoid conflicts with
- # the stock compiler.
-.for f in libstdc++ libsupc++ libg2c libfrtbegin libobjc ${EXTRA_LIBS}
- ${MV} -f ${PREFIX}/lib/${f}.* ${TARGLIB}
-.endfor
- ${RM} -f ${PREFIX}/lib/libiberty.a ${TARGLIB}/*.la
+ ${RM} -f ${TARGLIB}/*.la
${RM} -f ${PREFIX}/man/man7/fsf-funding.7 \
${PREFIX}/man/man7/gfdl.7 ${PREFIX}/man/man7/gpl.7
# Add target libraries and include files to packaging list.