aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc46/Makefile
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-03-27 04:36:04 +0800
committermarino <marino@FreeBSD.org>2015-03-27 04:36:04 +0800
commit88acd559ad0ba888d6fab9c44be84f247566d490 (patch)
tree699e63834cca5b95087b6d57383fe37b6abdd52f /lang/gcc46/Makefile
parentde70ced02fc321a5f6b441b90865d4a204a12f7e (diff)
downloadfreebsd-ports-graphics-88acd559ad0ba888d6fab9c44be84f247566d490.tar.gz
freebsd-ports-graphics-88acd559ad0ba888d6fab9c44be84f247566d490.tar.zst
freebsd-ports-graphics-88acd559ad0ba888d6fab9c44be84f247566d490.zip
lang/gcc(46,47,48,49,5): Use OPTIONS_EXCLUDE_DragonFly to block JAVA
The JAVA frontend doesn't build on DragonFly on any release. The new OPTIONS_EXCLUDE_${OPSYS} feature is a nice way to avoid the use of Makefile.DragonFly (most are in dports, but one is in lang/gcc5). The recent addition of CXXFLAGS to lang/gcc5 prevents Makefile.DragonFly on lang/gcc5 from being removed outright. There are a couple of options available to allow its removal, but I'll need to discuss with Gerald. Approved by: DragonFly blanket
Diffstat (limited to 'lang/gcc46/Makefile')
-rw-r--r--lang/gcc46/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/lang/gcc46/Makefile b/lang/gcc46/Makefile
index a4e4ee6fdb5..5fb7be0b73c 100644
--- a/lang/gcc46/Makefile
+++ b/lang/gcc46/Makefile
@@ -48,6 +48,7 @@ OPTIONS_DEFINE_i386= JAVA
OPTIONS_DEFINE_amd64= JAVA
OPTIONS_DEFAULT_i386= JAVA
OPTIONS_DEFAULT_amd64= JAVA
+OPTIONS_EXCLUDE_DragonFly= JAVA
BOOTSTRAP_DESC= Build using a full bootstrap
.include <bsd.port.pre.mk>