aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gcc5/Makefile
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2015-04-28 07:42:09 +0800
committergerald <gerald@FreeBSD.org>2015-04-28 07:42:09 +0800
commit952d71696a89c0c8dcc4996bdeca5ced9d51b6a7 (patch)
tree6ca2c9ccc41eb62ad1626c3ddd745b13fb55c009 /lang/gcc5/Makefile
parentc61fa3728f3058aaaddaa24bbd576125c8a2dd0a (diff)
downloadfreebsd-ports-graphics-952d71696a89c0c8dcc4996bdeca5ced9d51b6a7.tar.gz
freebsd-ports-graphics-952d71696a89c0c8dcc4996bdeca5ced9d51b6a7.tar.zst
freebsd-ports-graphics-952d71696a89c0c8dcc4996bdeca5ced9d51b6a7.zip
Update to the 5.1 release, the first release of the GCC 5 series.
The default mode for C is now -std=gnu11 instead of -std=gnu89. New warning options -Wc90-c99-compat and -Wc99-c11-compat may prove useful on that front. The C++ front end now has full C++14 language support including C++14 variable templates, C++14 aggregates with non-static data member initializers, C++14 extended constexpr, and more. The Standard C++ Library (libstdc++) has full C++11 support and experimental full C++14 support. It uses a new ABI by default. There have been significant improvements to inter-procedural optimizations and link-time optimization such as One Definition Rule based merging of C++ types as well as register allocation. OpenMP 4.0 specification offloading features are now supported by the C, C++, and Fortran compilers. Cilk Plus, an extension to the C and C++ languages to support data and task parallelism, has been added as well. New warning options -Wswitch-bool, -Wlogical-not-parentheses, -Wbool-compare and -Wsizeof-array-argument may prove useful as may new preprocessor directives __has_include, __has_include_next, and __has_attribute. GCC can now be built as a shared library for embedding in other processes (such as interpreters), suitable for Just-In-Time compilation to machine code. This provides a C API and a C++ wrapper API. Many code generation improvements for AArch64, ARM, support for AVX-512{BW,DQ,VL,IFMA,VBMI} and Intel MPX on x86-64, and generally improvements on many targets. The Local Register Allocator (LRA) now contains a rematerialization subpass and is able to reuse the PIC hard register on x86/x86-64 to improve performance of position independent code. https://gcc.gnu.org/gcc-5/changes.html has a more extensive set of changes and https://gcc.gnu.org/gcc-5/porting_to.html has a solid overview of issue you may encountering porting to this new version.
Diffstat (limited to 'lang/gcc5/Makefile')
-rw-r--r--lang/gcc5/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/lang/gcc5/Makefile b/lang/gcc5/Makefile
index 9442651e4d3..4e0a19d30ea 100644
--- a/lang/gcc5/Makefile
+++ b/lang/gcc5/Makefile
@@ -2,10 +2,10 @@
# $FreeBSD$
PORTNAME= gcc
-PORTVERSION= 5.0.1.s20150421
+PORTVERSION= 5.1.0
CATEGORIES= lang java
MASTER_SITES= ${MASTER_SITE_GCC}
-MASTER_SITE_SUBDIR= snapshots/${DISTVERSION}
+MASTER_SITE_SUBDIR= releases/${DISTVERSION}
PKGNAMESUFFIX= ${SUFFIX}
MAINTAINER= gerald@FreeBSD.org
@@ -111,10 +111,11 @@ INFO= gcc${SUFFIX}/cpp \
gcc${SUFFIX}/gccint \
gcc${SUFFIX}/gfortran \
gcc${SUFFIX}/libgomp
-.if ${ARCH} == "i386" || ${ARCH} == "amd64"
+# Release tarballs (as opposed to snapshots) always carry this.
+#.if ${ARCH} == "i386" || ${ARCH} == "amd64"
INFO+= gcc${SUFFIX}/libquadmath \
gcc${SUFFIX}/libitm
-.endif
+#.endif
SUB_FILES= pkg-message
SUB_LIST+= TARGLIB=${TARGLIB}