aboutsummaryrefslogtreecommitdiffstats
path: root/lang/gnomebasic/Makefile
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2000-06-29 00:09:15 +0800
committerade <ade@FreeBSD.org>2000-06-29 00:09:15 +0800
commit3ce02ada07d313b006813219003810549a2d753a (patch)
tree5945a408d0f4a18382e3a9eaeb68c130ac98d029 /lang/gnomebasic/Makefile
parent69e25842c7ba1f30e449b51152e8e3cd8b66d62e (diff)
downloadfreebsd-ports-graphics-3ce02ada07d313b006813219003810549a2d753a.tar.gz
freebsd-ports-graphics-3ce02ada07d313b006813219003810549a2d753a.tar.zst
freebsd-ports-graphics-3ce02ada07d313b006813219003810549a2d753a.zip
Gnome Basic is an embryonic attempt to provide VB compatible functionality
for the GNOME project, particularly with respect to office (VBA) compatibility.
Diffstat (limited to 'lang/gnomebasic/Makefile')
-rw-r--r--lang/gnomebasic/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/lang/gnomebasic/Makefile b/lang/gnomebasic/Makefile
new file mode 100644
index 00000000000..ff48bc2877e
--- /dev/null
+++ b/lang/gnomebasic/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: gnomebasic
+# Date created: 28th June 2000
+# Whom: Ade Lovett <ade@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnomebasic
+PORTVERSION= 0.0.12
+CATEGORIES= lang gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= unstable/sources/gb
+DISTNAME= gb-${PORTVERSION}
+
+MAINTAINER= ade@FreeBSD.org
+
+LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs
+
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ GLIB_CONFIG="${GLIB_CONFIG}" \
+ GTK_CONFIG="${GTK_CONFIG}" \
+ LIBS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>