aboutsummaryrefslogtreecommitdiffstats
path: root/lang/klone
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2007-06-19 04:14:41 +0800
committerdanfe <danfe@FreeBSD.org>2007-06-19 04:14:41 +0800
commit6db84901d691be253fb0a61a177b92a9821a5b8d (patch)
tree4edecf1ecb020f45f0640fd10d69f032b5b8d7e1 /lang/klone
parentdd153a386a3c3e4f8f1841547e017801513d7adc (diff)
downloadfreebsd-ports-graphics-6db84901d691be253fb0a61a177b92a9821a5b8d.tar.gz
freebsd-ports-graphics-6db84901d691be253fb0a61a177b92a9821a5b8d.tar.zst
freebsd-ports-graphics-6db84901d691be253fb0a61a177b92a9821a5b8d.zip
Fix the build with GCC 4.2 and thus unbreak.
Reported by: pointyhat (logs)
Diffstat (limited to 'lang/klone')
-rw-r--r--lang/klone/Makefile4
-rw-r--r--lang/klone/files/patch-gcc426
2 files changed, 26 insertions, 4 deletions
diff --git a/lang/klone/Makefile b/lang/klone/Makefile
index 6e0575f0e0a..bf3d7bdf684 100644
--- a/lang/klone/Makefile
+++ b/lang/klone/Makefile
@@ -23,10 +23,6 @@ WRKSRC= ${WRKDIR}/Klone
BROKEN= Does not compile on sparc64
.endif
-.if ${OSVERSION} >= 700042
-BROKEN= Broken with gcc 4.2
-.endif
-
do-configure:
@${SED} -e 's:%%PREFIX%%:${PREFIX}:' \
-e 's:%%CC%%:${CC}:' \
diff --git a/lang/klone/files/patch-gcc4 b/lang/klone/files/patch-gcc4
new file mode 100644
index 00000000000..00756e147e6
--- /dev/null
+++ b/lang/klone/files/patch-gcc4
@@ -0,0 +1,26 @@
+--- KloneLight/KlLib.h.orig Fri Feb 16 21:47:53 2001
++++ KloneLight/KlLib.h Tue Jun 19 03:03:49 2007
+@@ -375,8 +375,8 @@
+ type[5] = (KlMethod) (((Card32) type[5]) | trait); \
+ KlDeclareTrait(type,trait)
+ #else
+-#define KlDeclareTrait(type,trait) ((Card32) type[4]) |= trait
+-#define KlDeclareIsTrait(type,trait) ((Card32) type[5]) |= trait; \
++#define KlDeclareTrait(type,trait) (type[4] = (Card32) type[4] | trait)
++#define KlDeclareIsTrait(type,trait) (type[5] = (Card32) type[5] | trait); \
+ KlDeclareTrait(type,trait)
+ #endif
+
+--- klone.h.orig Fri Feb 16 21:47:49 2001
++++ klone.h Tue Jun 19 03:07:31 2007
+@@ -503,8 +503,8 @@
+ type[5] = (KlMethod) (((Card32) type[5]) | trait); \
+ KlDeclareTrait(type,trait)
+ #else
+-#define KlDeclareTrait(type,trait) ((Card32) type[4]) |= trait
+-#define KlDeclareIsTrait(type,trait) ((Card32) type[5]) |= trait; \
++#define KlDeclareTrait(type,trait) (type[4] = (Card32) type[4] | trait)
++#define KlDeclareIsTrait(type,trait) (type[5] = (Card32) type[5] | trait); \
+ KlDeclareTrait(type,trait)
+ #endif
+
class='insertions'>+47 * Update to 0.9.2 which really fixes the segfault trying to thumbnail a filemarcus2008-08-172-4/+4 * - Update to 1.19.2miwi2008-08-132-6/+4 * Upgrade to 2.16.5dougb2008-08-022-5/+12 * Update shared-mime-info to 0.51, and remove conflicts with x11-fm/nautilus.marcus2008-07-262-16/+1 * - Remove duplicates from MAKE_ENV after inclusion of CC and CXX in default MA...pav2008-07-252-2/+1 * - Fix coredumps on startupmiwi2008-07-201-5/+11 * - Update to 2.6.2rafan2008-07-193-11/+14 * - Update to 1.19.1miwi2008-07-182-4/+4 * - Update to 0.11.57miwi2008-07-183-18/+16 * Update to 2.22.5.1.marcus2008-07-132-4/+4 * Update to 0.9.1 which fixes a crash if a PBI doesn't contain a custommarcus2008-07-052-5/+5 * Update to 2.22.4.mezz2008-07-012-5/+4 * - This port has been BROKEN for more than 6 months. It will be removed unlesspav2008-06-191-0/+2 * - Runtime problems need IGNORE not BROKEN tagpav2008-06-191-1/+1 * - Update to version 1.19lwhsu2008-06-152-5/+4 * Add pbi-thumbnailer, a tool which generates icon thumbnails for PC-BSDmarcus2008-06-095-0/+33 * Bump portrevision due to upgrade of devel/gettext.edwin2008-06-0628-16/+28 * - Update to 1.18miwi2008-06-063-27/+650 * Update to 2.16.3.wxs2008-05-312-6/+13 * - Respect NOPORTDOCS and NOPORTEXAMPLES knobs as reported by itetcu@.itetcu2008-05-312-7/+30 * Update to 2.22.3.mezz2008-05-293-5/+7 * - Update to 0.4.1miwi2008-05-254-35/+4 * Upgrade to version 2.8.olgeni2008-05-243-99/+99 * - Lib updated fox16.araujo2008-05-211-1/+1 * - Update to 0.8.2lme2008-05-192-10/+8 * - Downgrade to 1.2.4 because 1.2.5 have some problems and doesn't build fine ...araujo2008-04-292-4/+6 * - Update to 1.2.5.araujo2008-04-282-5/+4 * - Update to 1.9.0beech2008-04-246-12/+42 * - Fix build after xorg cleanupmiwi2008-04-211-2/+2 * - Update to 1.9.5miwi2008-04-206-96/+26 * - Remove unneeded dependency from gtk12/gtk20 [1]miwi2008-04-2015-38/+32 * - Move from versioned tcl/tk CATEGORIES to simple tcl and tk categoriespav2008-04-093-3/+3 * - Re-add patch that fixes build on FreeBSD 5pav2008-04-081-0/+11 * Readd tracker (if you want the gnome bits you must install sysutils/tracker-g...ahze2008-04-081-6/+7 * * Update to 2.22.2marcus2008-04-082-12/+11 * Add missing files to pkg-plist.olgeni2008-04-072-1/+4 * - IGNORE on FreeBSD 5.xpav2008-04-071-1/+5 * Split tracker into gnome and non-gnome portsahze2008-04-061-2/+5 * - Update to 0.4pav2008-04-057-31/+58 * An extremly fast and lightweight file manager which features tabbed browsingpav2008-04-045-0/+117 * Update to 2.22.1.marcus2008-03-292-5/+4 * -Fix the build on FreeBSD 6.x and below.mezz2008-03-271-2/+1 * - Add missing dependensmiwi2008-03-261-1/+2 * - Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORGmiwi2008-03-265-8/+3 * - Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORGmiwi2008-03-251-1/+0 * - Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORGmiwi2008-03-251-1/+0 * - Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORGmiwi2008-03-242-2/+0 * The FreeBSD GNOME team is proud to annunce the release of GNOME 2.22.0 formarcus2008-03-247-20/+55 * - Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORGmiwi2008-03-242-3/+2 * - Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORGmiwi2008-03-234-7/+5 * - Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORGmiwi2008-03-221-2/+1 * - Remove USE_GETOPT_LONG which is a no-op since March 2007pav2008-03-202-2/+0 * - Lib updated Fox16.araujo2008-03-191-0/+1 * - Update MASTER_SITESmiwi2008-03-151-2/+1 * - Chase devel/sdl12 shlib version bumpmiwi2008-03-131-1/+1 * - Update enlightenment-devel and EFL libraries to the latest snapshotstas2008-03-124-14/+13 * - Remove useless dependency on XLIBgahr2008-03-111-2/+1 * 2007-10-28 x11-wm/wmDeskGuide: Version branch long since retiredmiwi2008-02-286-269/+0 * My reference e-mail address as a ports maintainer is now gahr@FreeBSD.org.gahr2008-02-221-1/+1 * update xfce4 to 4.4.2oliver2008-02-135-52/+117 * - Update to 2.5.araujo2008-01-263-9/+9 * - Update to 1.04miwi2008-01-213-1467/+2055 * Upgrade to version 2.7.1.olgeni2008-01-132-4/+4 * - Add patch to prevent a crashed when allocate dynamic memory. [1]araujo2008-01-062-3/+18 * Add missing directories to pkg-plist.olgeni2007-12-201-0/+2 * - Mark BROKEN on respective OSVERSION/ARCHS.araujo2007-12-191-1/+7 * - Update to 0.8.1lme2007-12-172-7/+7 * Add missing libglade2 to USE_GNOME.olgeni2007-12-151-1/+1 * - Update to 2.16.1miwi2007-12-153-5/+10 * Upgrade to version 2.7.olgeni2007-12-124-34/+78 * - Fix build with gcc 4.2miwi2007-12-115-7/+164 * - Mark BROKEN on amd64-7pav2007-12-111-0/+4 * - Mark BROKEN on FreeBSD 7.0pav2007-12-111-1/+7 * - Fix build with gcc 4.2miwi2007-12-117-20/+98 * Return to pool: hopefully they will have a chance of being updatedshaun2007-10-281-1/+1 * - Fix a typo in bsd.sites.mk along with all the places it affectedsat2007-10-261-1/+1 * Presenting GNOME 2.20.1 and all related works for FreeBSD. The officialmarcus2007-10-2513-358/+352 * Remove deprecated port (due to the upstream unmaintan anymore).chinsan2007-10-215-73/+0 * - update to 0.8lme2007-10-063-7/+7 * Remove always-false/true conditions based on OSVERSION 500000edwin2007-10-044-30/+6 * - Fix the port after removal of pkg-messagepav2007-09-221-1/+1 * - Mark DEPRECATED for unmaintained upstream.chinsan2007-09-181-0/+3 * Remove no longer needed pkg-message. muCommander is released under GPLv3 now.lme2007-09-082-5/+0 * - Fixed pkg-plist to use correct dirrmtry.araujo2007-08-251-2/+4 * - Update to 1.2.4.araujo2007-08-174-41/+16 * - Remove USE_X_PREFIX (implies USE_XLIB)mm2007-08-161-2/+4 * - Fix build on FreeBSD 5.Xmiwi2007-08-062-0/+12 * 2007-07-31 x11-fm/endeavour: Development ceased, this port should be updated ...miwi2007-08-019-144/+0 * Update to 2.4arved2007-07-313-22/+14 * Update to 1.80.0arved2007-07-308-44/+130 * - Mark broken: fails to compile on 5.X and below.chinsan2007-07-291-1/+7 * - Update to 0.3.5pav2007-07-296-46/+9 * - Chase increase of audio/libvorbis shlib version.miwi2007-07-281-2/+2 * - Set --mandir and --infodir in CONFIGURE_ARGS if the configure scriptrafan2007-07-232-3/+2 * Set removal date at teh end of the month.itetcu2007-07-161-0/+1 * - Update to 2.3pav2007-07-164-48/+44 * Change e-mail address of my ports to my FreeBSD.org one.lme2007-07-131-1/+1 * Unbreak.demon2007-07-051-2/+7 * -Update to 2.18.3.mezz2007-07-043-8/+13 * Upgrade to version 2.6.1.olgeni2007-07-012-4/+4 * muCommander is a lightweight, cross-platform file manager featuringmiwi2007-06-306-0/+73 * - Change my mail address to araujo@.araujo2007-06-301-1/+1 * - Add backup MASTER_SITESmiwi2007-06-071-2/+1 * Add missing files.olgeni2007-06-061-0/+3 * - Fix build with gcc 4.2miwi2007-06-054-2/+28 * - Fix build on FreeBSD 5.X [1]miwi2007-06-041-6/+3 * Port Update: x11-fm/twanderedwin2007-06-032-5/+4 * Add missing files.olgeni2007-06-011-0/+2 * Upgrade to version 0.30.olgeni2007-05-292-5/+4 * Upgrade to version 2.6.olgeni2007-05-292-5/+4 * - Update to 0.3.4miwi2007-05-286-36/+90 * - Chase libexif updatepav2007-05-273-6/+6 * BROKEN with gcc 4.2kris2007-05-272-2/+14 * - Chase libexif updatepav2007-05-253-5/+5 * BROKEN: Does not buildkris2007-05-251-0/+2 * - Welcome X.org 7.2 \o/.flz2007-05-2049-112/+43 * - Fix buildlwhsu2007-04-27