aboutsummaryrefslogtreecommitdiffstats
path: root/lang/mdk/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-07-25 20:08:43 +0800
committermiwi <miwi@FreeBSD.org>2006-07-25 20:08:43 +0800
commit81aaeb1194e816b68efd0a972a8a0032333a05c4 (patch)
treefa176e5e7577633ccc561f84b969dcd0f6ca3e05 /lang/mdk/Makefile
parentfd951d8ce829649191ee52dd91d07b7a79b95861 (diff)
downloadfreebsd-ports-graphics-81aaeb1194e816b68efd0a972a8a0032333a05c4.tar.gz
freebsd-ports-graphics-81aaeb1194e816b68efd0a972a8a0032333a05c4.tar.zst
freebsd-ports-graphics-81aaeb1194e816b68efd0a972a8a0032333a05c4.zip
- Update to 1.2.1
- Pass maintainership to submitter - BROKEN: Does not build on 4.X PR: ports/100727 Submitted by: Stanislav Sedov <ssedov(at)mbsd.msk.ru> Approved by: krion (mentor)
Diffstat (limited to 'lang/mdk/Makefile')
-rw-r--r--lang/mdk/Makefile22
1 files changed, 13 insertions, 9 deletions
diff --git a/lang/mdk/Makefile b/lang/mdk/Makefile
index dc066cc9607..d6aac8b50ad 100644
--- a/lang/mdk/Makefile
+++ b/lang/mdk/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= mdk
-PORTVERSION= 1.2
-PORTREVISION= 2
+PORTVERSION= 1.2.1
CATEGORIES= lang gnome
MASTER_SITES= ${MASTER_SITE_GNU:S/$/:gnu/} \
${MASTER_SITE_SOURCEFORGE:S/$/:sf/}
@@ -17,20 +16,25 @@ MASTER_SITE_SUBDIR= ${PORTNAME}/v${PORTVERSION}/:gnu \
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:gnu \
${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:sf
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ssedov@mbsd.msk.ru
COMMENT= A set of utilities for developing programs using MIX and MIXAL
-LIB_DEPENDS= guile.15:${PORTSDIR}/lang/guile
+LIB_DEPENDS= guile.15:${PORTSDIR}/lang/guile \
+ readline.5:${PORTSDIR}/devel/readline
USE_X_PREFIX= yes
-USE_GNOME= gnometarget intlhack libglade2
+USE_GNOME= gnometarget libglade2
USE_GETOPT_LONG= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS= --disable-nls
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
INFO= mdk
-CPPFLAGS= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
+.include <bsd.port.pre.mk>
-.include <bsd.port.mk>
+.if ${OSVERSION} < 500000
+BROKEN= Does not compile on 4.x
+.endif
+
+.include <bsd.port.post.mk>