aboutsummaryrefslogtreecommitdiffstats
path: root/lang/moscow_ml
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2003-06-15 21:33:28 +0800
committerarved <arved@FreeBSD.org>2003-06-15 21:33:28 +0800
commitcc63c767ef2285dc75a7568510052d3f99ec5308 (patch)
tree8628818cb2929c14c74b14fb0c38e57d601ded4a /lang/moscow_ml
parentb2447ece1b6b8569e2c1eabb1c402910aa0cbaf6 (diff)
downloadfreebsd-ports-graphics-cc63c767ef2285dc75a7568510052d3f99ec5308.tar.gz
freebsd-ports-graphics-cc63c767ef2285dc75a7568510052d3f99ec5308.tar.zst
freebsd-ports-graphics-cc63c767ef2285dc75a7568510052d3f99ec5308.zip
Unbreak on 5.x.
Set CFLAGS and LDFLAGS to use libgmp from LOCALBASE. PR: 48678 Reported by: Matthias Buelow <mkb@informatik.uni-wuerzburg.de>
Diffstat (limited to 'lang/moscow_ml')
-rw-r--r--lang/moscow_ml/Makefile8
-rw-r--r--lang/moscow_ml/files/patch-dynlibs::intinf::Makefile4
2 files changed, 7 insertions, 5 deletions
diff --git a/lang/moscow_ml/Makefile b/lang/moscow_ml/Makefile
index 6aee1acd247..85c6e6e69b7 100644
--- a/lang/moscow_ml/Makefile
+++ b/lang/moscow_ml/Makefile
@@ -24,12 +24,14 @@ ALL_TARGET= world MOSMLHOME=$(MOSMLHOME)
INSTALL_TARGET= install MOSMLHOME=$(MOSMLHOME)
WRKSRC= ${WRKDIR}/mosml/src
USE_PERL5= yes
+USE_REINPLACE= yes
+MAKE_ENV= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile"
-.endif
+post-patch:
+ ${FIND} ${WRKSRC} -name Makefile | ${XARGS} \
+ ${REINPLACE_CMD} -e "s,-O2,${CFLAGS} -I${LOCALBASE}/include,"
post-install:
${SED} -e 's|^MOSMLHOME=.*|MOSMLHOME=${MOSMLHOME}|' \
diff --git a/lang/moscow_ml/files/patch-dynlibs::intinf::Makefile b/lang/moscow_ml/files/patch-dynlibs::intinf::Makefile
index 2302c529bd1..541ecaafcae 100644
--- a/lang/moscow_ml/files/patch-dynlibs::intinf::Makefile
+++ b/lang/moscow_ml/files/patch-dynlibs::intinf::Makefile
@@ -1,5 +1,5 @@
--- dynlibs/intinf/Makefile.orig Wed Feb 16 16:36:57 2000
-+++ dynlibs/intinf/Makefile Fri Apr 12 02:21:26 2002
++++ dynlibs/intinf/Makefile Sun Jun 15 15:15:38 2003
@@ -10,10 +10,11 @@
include ../../Makefile.inc
@@ -26,7 +26,7 @@
libmgmp.so: intinf.o
- $(DYNLD) -o libmgmp.so intinf.o ${GMPDIR}/libgmp.a
-+ $(DYNLD) -o libmgmp.so intinf.o -lgmp
++ $(DYNLD) ${LDFLAGS} -o libmgmp.so intinf.o -lgmp
test:
mosml testintinf.sml