aboutsummaryrefslogtreecommitdiffstats
path: root/lang/munger
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-05-12 14:05:03 +0800
committerbapt <bapt@FreeBSD.org>2013-05-12 14:05:03 +0800
commit5cdd435b52ee9c3569a74925bf6839c9fae9143b (patch)
treef04b4da09af88440a84fa754093dfc6c176a91c1 /lang/munger
parentf1a65685968e16bcfbd626772d7b1599f4566096 (diff)
downloadfreebsd-ports-graphics-5cdd435b52ee9c3569a74925bf6839c9fae9143b.tar.gz
freebsd-ports-graphics-5cdd435b52ee9c3569a74925bf6839c9fae9143b.tar.zst
freebsd-ports-graphics-5cdd435b52ee9c3569a74925bf6839c9fae9143b.zip
Convert to new options framework
Diffstat (limited to 'lang/munger')
-rw-r--r--lang/munger/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/lang/munger/Makefile b/lang/munger/Makefile
index ee7c7b53247..5a0b4ea4835 100644
--- a/lang/munger/Makefile
+++ b/lang/munger/Makefile
@@ -16,13 +16,14 @@ DATADIR= ${PREFIX}/share/${PORTNAME}-${PORTVERSION}
MAN1= munger.1
MANCOMPRESSED= yes
-OPTIONS= SQL "include SQLite interface" on
+OPTIONS_DEFINE= SQLITE
+OPTIONS_DEFAULT= SQLITE
USE_LDCONFIG= yes
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_SQL)
+.if ${PORT_OPTIONS:MSQLITE}
USE_SQLITE= 3
MAKE_ARGS+= -DWITH_SQL
.endif
@@ -31,4 +32,4 @@ MAKE_ARGS+= -DWITH_SQL
BROKEN= Does not link on sparc64
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>