aboutsummaryrefslogtreecommitdiffstats
path: root/lang/nml/Makefile
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-07-19 19:04:13 +0800
committermat <mat@FreeBSD.org>2016-07-19 19:04:13 +0800
commit363acdd313a37f491e4b2d6b9a807df489cfc5d9 (patch)
treebe6eebf3e77ddf9fcf383081091d8b8b336dd71c /lang/nml/Makefile
parent64a47229a8791073130cac02039b944cc8102750 (diff)
downloadfreebsd-ports-graphics-363acdd313a37f491e4b2d6b9a807df489cfc5d9.tar.gz
freebsd-ports-graphics-363acdd313a37f491e4b2d6b9a807df489cfc5d9.tar.zst
freebsd-ports-graphics-363acdd313a37f491e4b2d6b9a807df489cfc5d9.zip
When there is a do-install target, do not use a post-install target, do
everything at once. Sometime, rename post-install into a options helper target. I did not fix ports that were such a mess that I could not figure out what they really wanted to do. I also did not change ports that had some version of an auto-plist code in post-install, for the same reason. With hat: portmgr Sponsored by: Absolight
Diffstat (limited to 'lang/nml/Makefile')
-rw-r--r--lang/nml/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/lang/nml/Makefile b/lang/nml/Makefile
index dabac5cf9e2..2eac2069544 100644
--- a/lang/nml/Makefile
+++ b/lang/nml/Makefile
@@ -35,10 +35,6 @@ post-patch:
do-install:
${DO_MAKE_BUILD} -C ${WRKSRC} PREFIX="${STAGEDIR}${PREFIX}" ${INSTALL_TARGET}
@${REINPLACE_CMD} -i '' -e 's|${STAGEDIR}||' ${STAGEDIR}${PREFIX}/lib/nml/ld.conf
-
-post-install:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/Changes ${WRKSRC}/LICENSE ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
@${MKDIR} ${STAGEDIR}${DATADIR}/contrib/emacs
@${MKDIR} ${STAGEDIR}${DATADIR}/contrib/vim
${INSTALL_DATA} ${WRKSRC}/contrib/emacs/* ${STAGEDIR}${DATADIR}/contrib/emacs
@@ -47,4 +43,8 @@ post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/$i
.endfor
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/Changes ${WRKSRC}/LICENSE ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
+
.include <bsd.port.mk>