aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ocaml
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2005-12-01 23:46:34 +0800
committergarga <garga@FreeBSD.org>2005-12-01 23:46:34 +0800
commit5b5bf8f7e52befa6424ab89d08fecd2037e89df1 (patch)
treeedc52ddb4539d0b37fb5319fb47ce3046751c7a2 /lang/ocaml
parent0544c7ca8ca0c4ff88b3ca7b31647b50f9879721 (diff)
downloadfreebsd-ports-graphics-5b5bf8f7e52befa6424ab89d08fecd2037e89df1.tar.gz
freebsd-ports-graphics-5b5bf8f7e52befa6424ab89d08fecd2037e89df1.tar.zst
freebsd-ports-graphics-5b5bf8f7e52befa6424ab89d08fecd2037e89df1.zip
- Update to 3.09.0
PR: ports/89780 Submitted by: maintainer
Diffstat (limited to 'lang/ocaml')
-rw-r--r--lang/ocaml/Makefile8
-rw-r--r--lang/ocaml/distinfo4
-rw-r--r--lang/ocaml/files/patch-configure10
-rw-r--r--lang/ocaml/pkg-plist17
4 files changed, 27 insertions, 12 deletions
diff --git a/lang/ocaml/Makefile b/lang/ocaml/Makefile
index 9167232a5dc..5be6901571d 100644
--- a/lang/ocaml/Makefile
+++ b/lang/ocaml/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= ocaml
-PORTVERSION= 3.08.3
-PORTREVISION= 2
+PORTVERSION= 3.09.0
CATEGORIES= lang
MASTER_SITES= http://caml.inria.fr/distrib/${DISTNAME:R}/ \
ftp://ftp.inria.fr/INRIA/caml-light/${DISTNAME:R}/ \
@@ -67,7 +66,8 @@ MANN= Arg.n Array.n ArrayLabels.n Bigarray.Array1.n \
Scanf.n Set.Make.n Set.OrderedType.n Set.S.n Set.n Sort.n \
Stack.n StdLabels.Array.n StdLabels.List.n StdLabels.String.n \
StdLabels.n Str.n Stream.n String.n StringLabels.n Sys.n \
- Unix.LargeFile.n Unix.n Weak.Make.n Weak.S.n Weak.n
+ Unix.LargeFile.n Unix.n Weak.Make.n Weak.S.n Weak.n \
+ CamlinternalMod.n
MLINKS= ocamlc.1 ocamlc.opt.1 ocamlopt.1 ocamlopt.opt.1 \
camlp4.1 camlp4o.1 camlp4.1 camlp4r.1 camlp4.1 mkcamlp4.1 \
camlp4.1 camlp4o.opt.1 camlp4.1 camlp4r.opt.1 \
@@ -89,7 +89,7 @@ MODOPT= camlp4o camlp4r ocamlc ocamldep ocamldoc ocamllex ocamlopt
.include <bsd.port.pre.mk>
.if ${ARCH} == sparc64 || ${ARCH} == ia64
-BROKEN= ocamlc.opt seg-faults on ${ARCH}, please try to fix
+BROKEN= "ocamlc.opt seg-faults on ${ARCH}, please try to fix"
.endif
PLIST_SUB+= PROF=""
diff --git a/lang/ocaml/distinfo b/lang/ocaml/distinfo
index 8626d95e09f..c548c92c3cc 100644
--- a/lang/ocaml/distinfo
+++ b/lang/ocaml/distinfo
@@ -1,2 +1,2 @@
-MD5 (ocaml-3.08.3.tar.bz2) = 8277bb1537051fe5151dc31c350d64cd
-SIZE (ocaml-3.08.3.tar.bz2) = 2055260
+MD5 (ocaml-3.09.0.tar.bz2) = 834f88b1f39aa066bb620747764c0588
+SIZE (ocaml-3.09.0.tar.bz2) = 2013495
diff --git a/lang/ocaml/files/patch-configure b/lang/ocaml/files/patch-configure
index 299803b7afc..f54943ec7e2 100644
--- a/lang/ocaml/files/patch-configure
+++ b/lang/ocaml/files/patch-configure
@@ -1,7 +1,6 @@
---- configure.orig Thu Jul 15 16:17:46 2004
-+++ configure Thu Jul 15 16:58:51 2004
-@@ -652,7 +652,8 @@
- case "$arch,$model,$system" in
+--- configure.orig Wed Sep 7 12:41:56 2005
++++ configure Wed Sep 7 12:30:03 2005
+@@ -653,6 +653,7 @@
alpha,*,digital) profiling='prof';;
i386,*,linux_elf) profiling='prof';;
i386,*,bsd_elf) profiling='prof';;
@@ -9,7 +8,7 @@
sparc,*,solaris)
profiling='prof'
case "$nativecc" in gcc*) ;; *) cc_profile='-xpg';; esac;;
-@@ -1113,116 +1113,14 @@
+@@ -1123,117 +1124,14 @@
x11_include="not found"
x11_link="not found"
@@ -72,6 +71,7 @@
- $x11_lib_dir \
- $x11_try_lib_dir \
- \
+- /usr/X11R6/lib64 \
- /usr/X11R6/lib \
- /usr/lib/X11R6 \
- /usr/local/X11R6/lib \
diff --git a/lang/ocaml/pkg-plist b/lang/ocaml/pkg-plist
index 4c3e4c80665..a12ab7f144e 100644
--- a/lang/ocaml/pkg-plist
+++ b/lang/ocaml/pkg-plist
@@ -11,6 +11,7 @@ bin/ocamlprof
bin/ocamlrun
bin/ocamlyacc
bin/ocpp
+lib/ocaml/Makefile.config
lib/ocaml/addlabels
lib/ocaml/arg.cmi
lib/ocaml/arg.cmx
@@ -65,6 +66,11 @@ lib/ocaml/caml/printexc.h
lib/ocaml/caml/signals.h
lib/ocaml/camlheader
lib/ocaml/camlheader_ur
+lib/ocaml/camlinternalMod.cmi
+lib/ocaml/camlinternalMod.cmx
+lib/ocaml/camlinternalMod.ml
+lib/ocaml/camlinternalMod.mli
+lib/ocaml/camlinternalMod.p.cmx
lib/ocaml/camlinternalOO.cmi
lib/ocaml/camlinternalOO.cmx
lib/ocaml/camlinternalOO.ml
@@ -588,6 +594,16 @@ lib/ocaml/int_misc.cmx
%%TK%%lib/ocaml/labltk/wm.cmi
%%TK%%lib/ocaml/labltk/wm.cmx
%%TK%%lib/ocaml/labltk/wm.mli
+%%TK%%lib/ocaml/labltk/fileevent.cmx
+%%TK%%lib/ocaml/labltk/protocol.cmx
+%%TK%%lib/ocaml/labltk/rawwidget.cmx
+%%TK%%lib/ocaml/labltk/textvariable.cmx
+%%TK%%lib/ocaml/labltk/timer.cmx
+%%TK%%lib/ocaml/labltk/tkthread.cmi
+%%TK%%lib/ocaml/labltk/tkthread.cmo
+%%TK%%lib/ocaml/labltk/tkthread.mli
+%%TK%%lib/ocaml/labltk/tkthread.o
+%%TK%%lib/ocaml/labltk/widget.cmx
lib/ocaml/lazy.cmi
lib/ocaml/lazy.cmx
lib/ocaml/lazy.ml
@@ -809,7 +825,6 @@ lib/ocaml/stringLabels.cmx
lib/ocaml/stringLabels.ml
lib/ocaml/stringLabels.mli
%%PROF%%lib/ocaml/stringLabels.p.cmx
-lib/ocaml/string_misc.cmx
lib/ocaml/stublibs/dllbigarray.so
%%X11%%lib/ocaml/stublibs/dllgraphics.so
%%TK%%lib/ocaml/stublibs/dlllabltk.so