aboutsummaryrefslogtreecommitdiffstats
path: root/lang/open-cobol/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-08-06 21:09:46 +0800
committerijliao <ijliao@FreeBSD.org>2002-08-06 21:09:46 +0800
commit37056dd368508be53e95bb9aa3f452eb84b2e1d6 (patch)
tree9721ce18c0b2411d668c2328e96cb009f0e645a2 /lang/open-cobol/Makefile
parent213324daf1faacb6b84581ad2fb9a054147351b0 (diff)
downloadfreebsd-ports-graphics-37056dd368508be53e95bb9aa3f452eb84b2e1d6.tar.gz
freebsd-ports-graphics-37056dd368508be53e95bb9aa3f452eb84b2e1d6.tar.zst
freebsd-ports-graphics-37056dd368508be53e95bb9aa3f452eb84b2e1d6.zip
add open-cobol 0.9.7
An open-source COBOL compiler
Diffstat (limited to 'lang/open-cobol/Makefile')
-rw-r--r--lang/open-cobol/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/lang/open-cobol/Makefile b/lang/open-cobol/Makefile
new file mode 100644
index 00000000000..c2489b35bda
--- /dev/null
+++ b/lang/open-cobol/Makefile
@@ -0,0 +1,33 @@
+# ex:ts=8
+# Ports collection makefile for: open-cobol
+# Date created: Aug 6, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= open-cobol
+PORTVERSION= 0.9.7
+CATEGORIES= lang
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= intl:${PORTSDIR}/devel/gettext \
+ iconv:${PORTSDIR}/converters/libiconv \
+ gnugetopt:${PORTSDIR}/devel/libgnugetopt \
+ db4:${PORTSDIR}/databases/db4 \
+ gmp.6:${PORTSDIR}/math/libgmp4
+
+USE_REINPLACE= yes
+USE_BISON= yes
+USE_LIBTOOL= yes
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt -lintl"
+CONFIGURE_ARGS= --with-readline
+INSTALLS_SHLIB= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|-ldb|-ldb4|g" ${WRKSRC}/configure
+
+.include <bsd.port.mk>