aboutsummaryrefslogtreecommitdiffstats
path: root/lang/php4
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2005-07-14 03:56:27 +0800
committerale <ale@FreeBSD.org>2005-07-14 03:56:27 +0800
commit5ae2cdaaaf5d37a9b166e8df967a0b92451de2d9 (patch)
treeaa3ce78a685fc0a58f5d5755706c29f2811b70c5 /lang/php4
parent6aa9a33068ed9b5e826ef2c0fdf3353718256fed (diff)
downloadfreebsd-ports-graphics-5ae2cdaaaf5d37a9b166e8df967a0b92451de2d9.tar.gz
freebsd-ports-graphics-5ae2cdaaaf5d37a9b166e8df967a0b92451de2d9.tar.zst
freebsd-ports-graphics-5ae2cdaaaf5d37a9b166e8df967a0b92451de2d9.zip
Update to 4.4.0 release:
- fix a serious memory corruption problem - remove automake dependency - switch to the latest autoconf version
Diffstat (limited to 'lang/php4')
-rw-r--r--lang/php4/Makefile7
-rw-r--r--lang/php4/Makefile.pear2
-rw-r--r--lang/php4/distinfo4
-rw-r--r--lang/php4/files/patch-pear::Makefile.frag2
-rw-r--r--lang/php4/files/patch-scripts::Makefile.frag35
-rw-r--r--lang/php4/files/patch-scripts::phpize.in24
-rw-r--r--lang/php4/pkg-plist1
7 files changed, 39 insertions, 36 deletions
diff --git a/lang/php4/Makefile b/lang/php4/Makefile
index 8c567b27046..c9edf38473a 100644
--- a/lang/php4/Makefile
+++ b/lang/php4/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= php4
-PORTVERSION= 4.3.11
-PORTREVISION?= 1
+PORTVERSION= 4.4.0
+PORTREVISION?= 0
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP:S,$,:release,} \
http://downloads.php.net/ilia/:rc \
@@ -84,9 +84,10 @@ CONFLICTS+= php5-5* php5-cli-5* mod_php5-5* php5-cgi-5*
CONFIGURE_ARGS+=--disable-cli
.endif
+MAN1= php-config.1 phpize.1
.if ${PHP_SAPI} == "full" || ${PHP_SAPI} == "cli"
PLIST_SUB+= CLI=""
-MAN1= php.1
+MAN1+= php.1
.else
PLIST_SUB+= CLI="@comment "
.endif
diff --git a/lang/php4/Makefile.pear b/lang/php4/Makefile.pear
index dc09d2be81f..f49c4e7b460 100644
--- a/lang/php4/Makefile.pear
+++ b/lang/php4/Makefile.pear
@@ -1,4 +1,4 @@
-PORTREVISION= 3
+PORTREVISION= 0
LIB_DEPENDS+= expat.5:${PORTSDIR}/textproc/expat2
diff --git a/lang/php4/distinfo b/lang/php4/distinfo
index c1655cc872e..f5409e3e2e7 100644
--- a/lang/php4/distinfo
+++ b/lang/php4/distinfo
@@ -1,2 +1,2 @@
-MD5 (php-4.3.11.tar.bz2) = fbc67d240812136a9842bc1f2a217b7a
-SIZE (php-4.3.11.tar.bz2) = 4012575
+MD5 (php-4.4.0.tar.bz2) = e85b606fe48198bfcd785e5a5b1c9613
+SIZE (php-4.4.0.tar.bz2) = 4086074
diff --git a/lang/php4/files/patch-pear::Makefile.frag b/lang/php4/files/patch-pear::Makefile.frag
index 082aa5e74fb..aec8fdddbf0 100644
--- a/lang/php4/files/patch-pear::Makefile.frag
+++ b/lang/php4/files/patch-pear::Makefile.frag
@@ -4,7 +4,7 @@
# -*- makefile -*-
peardir=$(PEAR_INSTALLDIR)
-+XML_RPC_ver=1.2.2
++XML_RPC_ver=1.3.1
# Skip all php.ini files altogether
PEAR_INSTALL_FLAGS = -n -dshort_open_tag=0 -dsafe_mode=0
diff --git a/lang/php4/files/patch-scripts::Makefile.frag b/lang/php4/files/patch-scripts::Makefile.frag
index 6a3f941cb2f..c0d6f9c744e 100644
--- a/lang/php4/files/patch-scripts::Makefile.frag
+++ b/lang/php4/files/patch-scripts::Makefile.frag
@@ -1,17 +1,22 @@
---- scripts/Makefile.frag.orig Wed Jul 7 13:15:53 2004
-+++ scripts/Makefile.frag Wed Jul 7 13:16:07 2004
-@@ -27,14 +27,7 @@
- Zend \
- TSRM \
- ext/standard \
-- ext/session \
-- ext/xml \
-- ext/xml/expat \
- main \
-- ext/mbstring \
-- ext/mbstring/libmbfl \
-- ext/mbstring/libmbfl/mbfl \
-- ext/pgsql \
- regex
+--- scripts/Makefile.frag.orig Wed Jun 8 12:34:41 2005
++++ scripts/Makefile.frag Wed Jul 13 09:28:45 2005
+@@ -34,18 +34,9 @@
+ / \
+ Zend/ \
+ TSRM/ \
+- include/ \
+ main/ \
+ regex/ \
+- ext/iconv/ \
+- ext/pgsql/ \
+- ext/standard/ \
+- ext/session/ \
+- ext/xml/ \
+- ext/xml/expat/ \
+- ext/mbstring/ \
+- ext/mbstring/libmbfl/ \
+- ext/mbstring/libmbfl/mbfl/
++ ext/standard/
install-headers:
+ -@for i in $(HEADER_DIRS); do \
diff --git a/lang/php4/files/patch-scripts::phpize.in b/lang/php4/files/patch-scripts::phpize.in
index 8b250b89790..83f38a65649 100644
--- a/lang/php4/files/patch-scripts::phpize.in
+++ b/lang/php4/files/patch-scripts::phpize.in
@@ -1,15 +1,13 @@
---- scripts/phpize.in.orig Fri Apr 1 11:37:05 2005
-+++ scripts/phpize.in Fri Apr 1 11:37:25 2005
-@@ -102,9 +102,9 @@
+--- scripts/phpize.in.orig Wed Jun 15 19:13:52 2005
++++ scripts/phpize.in Wed Jul 13 09:30:59 2005
+@@ -94,8 +94,8 @@
- phpize_autotools()
+ phpize_check_autotools()
{
-- aclocal || exit 1
-- autoconf || exit 1
-- autoheader || exit 1
-+ aclocal15 || exit 1
-+ autoconf253 || exit 1
-+ autoheader253 || exit 1
- }
-
- # Main script
+- test -z "$PHP_AUTOCONF" && PHP_AUTOCONF=autoconf
+- test -z "$PHP_AUTOHEADER" && PHP_AUTOHEADER=autoheader
++ test -z "$PHP_AUTOCONF" && PHP_AUTOCONF=autoconf259
++ test -z "$PHP_AUTOHEADER" && PHP_AUTOHEADER=autoheader259
+
+ if ! test -x "`$php_shtool path $PHP_AUTOCONF`"; then
+ cat <<EOF
diff --git a/lang/php4/pkg-plist b/lang/php4/pkg-plist
index 77fba0c8ea2..8d3460b38be 100644
--- a/lang/php4/pkg-plist
+++ b/lang/php4/pkg-plist
@@ -1,6 +1,5 @@
%%CLI%%bin/php
bin/php-config
-bin/phpextdist
bin/phpize
etc/php.conf
etc/php.ini-dist