aboutsummaryrefslogtreecommitdiffstats
path: root/lang/pike72
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2004-03-20 05:08:09 +0800
committervanilla <vanilla@FreeBSD.org>2004-03-20 05:08:09 +0800
commit572f6c4fef1e7a64be561ca7804261aecf6733bd (patch)
tree25234fff5d5921c784dff3499901c93c16e1cb8e /lang/pike72
parent659e078987459222c8eebf2768deeb17cdf3b11b (diff)
downloadfreebsd-ports-graphics-572f6c4fef1e7a64be561ca7804261aecf6733bd.tar.gz
freebsd-ports-graphics-572f6c4fef1e7a64be561ca7804261aecf6733bd.tar.zst
freebsd-ports-graphics-572f6c4fef1e7a64be561ca7804261aecf6733bd.zip
- Upgrade to 7.2.570.
- Fixing mirrors lists - Adding missing dependency with gettext. PR: ports/64456 Submitted by: maintainer
Diffstat (limited to 'lang/pike72')
-rw-r--r--lang/pike72/Makefile28
-rw-r--r--lang/pike72/distinfo4
-rw-r--r--lang/pike72/files/patch-aa12
-rw-r--r--lang/pike72/files/patch-ab338
-rw-r--r--lang/pike72/files/patch-ac42
-rw-r--r--lang/pike72/files/patch-ad16
-rw-r--r--lang/pike72/files/patch-ae18
-rw-r--r--lang/pike72/files/patch-module_support.c11
8 files changed, 106 insertions, 363 deletions
diff --git a/lang/pike72/Makefile b/lang/pike72/Makefile
index 6f337d46227..b5c4355a1d1 100644
--- a/lang/pike72/Makefile
+++ b/lang/pike72/Makefile
@@ -6,16 +6,11 @@
#
PORTNAME= pike72
-PORTVERSION= 7.2.492
-PORTREVISION= 2
+PORTVERSION= 7.2.570
CATEGORIES= lang
MASTER_SITES= ftp://ftp.oav.net/pkg_freebsd/distfiles/ \
- http://ftp.oav.net/pkg_freebsd/distfiles/ \
ftp://ftp.oav.net/pike/7.2/unofficial/ \
- http://ftp.oav.net/pike/7.2/unofficial/ \
- http://grendel.firewall.com/caudium-pkg/ \
- ftp://ftp.caudium.net/caudium/snapshots/pike/7.2/unofficial/ \
- http://ftp.caudium.net/caudium/snapshots/pike/7.2/unofficial/
+ http://grendel.firewall.com/caudium-pkg/
DISTNAME= pike-${PORTVERSION}
MAINTAINER= kiwi@oav.net
@@ -28,9 +23,8 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
WRKSRC= ${WRKDIR}/${DISTNAME}/src/
-WANT_MESA= yes
-WANT_GTK= yes
USE_BISON= yes
+USE_GETTEXT= yes
GNU_CONFIGURE= yes
@@ -49,6 +43,7 @@ CONFIGURE_ARGS+= --without-debug \
--without-relocatable-dumped-modules \
--without-libpanda \
--without-perl \
+ --without-GTK \
--with-gmp \
--with-zlib \
--with-threads \
@@ -95,10 +90,6 @@ WITH_IODBC= yes
WITH_SANE= yes
.endif
-.if exists(${LOCALBASE}/lib/libgtkgl.so.5)
-WITH_MESA= yes
-.endif
-
.if exists(${LOCALBASE}/lib/libpdf.so.5)
WITH_PDF= yes
.endif
@@ -179,14 +170,6 @@ CONFIGURE_ARGS+= --with-libpdf
CONFIGURE_ARGS+= --without-libpdf
.endif
-.if defined(HAVE_MESA) || defined(WITH_MESA)
-USE_MESA= yes
-LIB_DEPENDS+= gtkgl.5:${PORTSDIR}/x11-toolkits/gtkglarea
-CONFIGURE_ARGS+= --with-GL --with-GLUT
-.else
-CONFIGURE_ARGS+= --without-GL --without-GLUT
-.endif
-
USE_GMAKE= yes
MAN1= hilfe.1 pike.1
MAN1PREFIX= ${PREFIX}/pike/${PORTVERSION}
@@ -216,9 +199,6 @@ pre-everything::
.if !defined(WITH_SANE)
@${ECHO_MSG} "You can enable Sane support by defining WITH_SANE."
.endif
-.if !defined(WITH_SANE) || !defined(HAVE_MESA)
- @${ECHO_MSG} "You can enable MesaGL support by defining WITH_MESA."
-.endif
.if !defined(WITH_PDF)
@${ECHO_MSG} "You can enable PDF support by defining WITH_PDF."
.endif
diff --git a/lang/pike72/distinfo b/lang/pike72/distinfo
index 0f3ab1cc40b..f29009e5761 100644
--- a/lang/pike72/distinfo
+++ b/lang/pike72/distinfo
@@ -1,2 +1,2 @@
-MD5 (pike-7.2.492.tar.gz) = d6f458ece48b395cf40feb9d7bdc1bc2
-SIZE (pike-7.2.492.tar.gz) = 5311005
+MD5 (pike-7.2.570.tar.gz) = 0cfb90ee65daa0108fa9cacd763ed688
+SIZE (pike-7.2.570.tar.gz) = 5328593
diff --git a/lang/pike72/files/patch-aa b/lang/pike72/files/patch-aa
new file mode 100644
index 00000000000..45078dcedf6
--- /dev/null
+++ b/lang/pike72/files/patch-aa
@@ -0,0 +1,12 @@
+--- modules/_Image_FreeType/configure.orig Thu Mar 18 19:53:43 2004
++++ modules/_Image_FreeType/configure Thu Mar 18 19:55:48 2004
+@@ -932,7 +932,8 @@
+ #line 933 "configure"
+ #include "confdefs.h"
+
+-#include <freetype/freetype.h>
++#include <ft2build.h>
++#include FT_FREETYPE_H
+
+ int main() {
+
diff --git a/lang/pike72/files/patch-ab b/lang/pike72/files/patch-ab
index 1ae78742fe3..a5e991a5548 100644
--- a/lang/pike72/files/patch-ab
+++ b/lang/pike72/files/patch-ab
@@ -1,326 +1,12 @@
---- post_modules/GTK/configure.orig Thu Nov 8 13:49:17 2001
-+++ post_modules/GTK/configure Thu Nov 8 13:49:41 2001
-@@ -1269,8 +1269,8 @@
-
-
- if test "$PKG_CONFIG" = "no" ; then
-- # Extract the first word of "gtk-config", so it can be a program name with args.
--set dummy gtk-config; ac_word=$2
-+ # Extract the first word of "gtk12-config", so it can be a program name with args.
-+set dummy gtk12-config; ac_word=$2
- echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
- echo "configure:1276: checking for $ac_word" >&5
- if eval "test \"`echo '$''{'ac_cv_path_GTK_CONFIG'+set}'`\" = set"; then
-@@ -1332,21 +1332,21 @@
-
- if test x$gtk_config_exec_prefix != x ; then
- gtk_config_args="$gtk_config_args --exec-prefix=$gtk_config_exec_prefix"
-- if test -f $gtk_config_exec_prefix/bin/gtk-config-2.0; then
-- GTK_CONFIG=$gtk_config_exec_prefix/bin/gtk-config-2.0
-+ if test -f $gtk_config_exec_prefix/bin/gtk12-config-2.0; then
-+ GTK_CONFIG=$gtk_config_exec_prefix/bin/gtk12-config-2.0
- else
- if test x${GTK_CONFIG+set} != xset ; then
-- GTK_CONFIG=$gtk_config_exec_prefix/bin/gtk-config
-+ GTK_CONFIG=$gtk_config_exec_prefix/bin/gtk12-config
- fi
- fi
- fi
- if test x$gtk_config_prefix != x ; then
- gtk_config_args="$gtk_config_args --prefix=$gtk_config_prefix"
-- if test -f $gtk_config_prefix/bin/gtk-config-2.0; then
-- GTK_CONFIG=$gtk_config_prefix/bin/gtk-config-2.0
-+ if test -f $gtk_config_prefix/bin/gtk12-config-2.0; then
-+ GTK_CONFIG=$gtk_config_prefix/bin/gtk12-config-2.0
- else
- if test x${GTK_CONFIG+set} != xset ; then
-- GTK_CONFIG=$gtk_config_prefix/bin/gtk-config
-+ GTK_CONFIG=$gtk_config_prefix/bin/gtk12-config
- fi
- fi
- fi
-@@ -1433,16 +1433,16 @@
- (gtk_minor_version != $gtk_config_minor_version) ||
- (gtk_micro_version != $gtk_config_micro_version))
- {
-- printf("\n*** 'gtk-config --version' returned %d.%d.%d, but GTK+ (%d.%d.%d)\n",
-+ printf("\n*** 'gtk12-config --version' returned %d.%d.%d, but GTK+ (%d.%d.%d)\n",
- $gtk_config_major_version, $gtk_config_minor_version, $gtk_config_micro_version,
- gtk_major_version, gtk_minor_version, gtk_micro_version);
-- printf ("*** was found! If gtk-config was correct, then it is best\n");
-+ printf ("*** was found! If gtk12-config was correct, then it is best\n");
- printf ("*** to remove the old version of GTK+. You may also be able to fix the error\n");
- printf("*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing\n");
- printf("*** /etc/ld.so.conf. Make sure you have run ldconfig if that is\n");
- printf("*** required on your system.\n");
-- printf("*** If gtk-config was wrong, set the environment variable GTK_CONFIG\n");
-- printf("*** to point to the correct copy of gtk-config, and remove the file config.cache\n");
-+ printf("*** If gtk12-config was wrong, set the environment variable GTK_CONFIG\n");
-+ printf("*** to point to the correct copy of gtk12-config, and remove the file config.cache\n");
- printf("*** before re-running configure\n");
- }
- else
-@@ -1484,10 +1484,10 @@
- else
- echo "$ac_t""no" 1>&6
- if test "$GTK_CONFIG" = "no" ; then
-- echo "*** The gtk-config script installed by GTK could not be found"
-+ echo "*** The gtk12-config script installed by GTK could not be found"
- echo "*** If GTK was installed in PREFIX, make sure PREFIX/bin is in"
- echo "*** your path, or set the GTK_CONFIG environment variable to the"
-- echo "*** full path to gtk-config."
-+ echo "*** full path to gtk12-config."
- else
- if test -f conf.gtktest ; then
- :
-@@ -1529,7 +1529,7 @@
- echo "*** The test program failed to compile or link. See the file config.log for the"
- echo "*** exact error that occured. This usually means GTK was incorrectly installed"
- echo "*** or that you have moved GTK since it was installed. In the latter case, you"
-- echo "*** may want to edit the gtk-config script: $GTK_CONFIG"
-+ echo "*** may want to edit the gtk12-config script: $GTK_CONFIG"
- fi
- rm -f conftest*
- CFLAGS="$ac_save_CFLAGS"
-@@ -1572,21 +1572,21 @@
-
- if test x$gtk_config_exec_prefix != x ; then
- gtk_config_args="$gtk_config_args --exec-prefix=$gtk_config_exec_prefix"
-- if test -f $gtk_config_exec_prefix/bin/gtk-config-2.0; then
-- GTK_CONFIG=$gtk_config_exec_prefix/bin/gtk-config-2.0
-+ if test -f $gtk_config_exec_prefix/bin/gtk12-config-2.0; then
-+ GTK_CONFIG=$gtk_config_exec_prefix/bin/gtk12-config-2.0
- else
- if test x${GTK_CONFIG+set} != xset ; then
-- GTK_CONFIG=$gtk_config_exec_prefix/bin/gtk-config
-+ GTK_CONFIG=$gtk_config_exec_prefix/bin/gtk12-config
- fi
- fi
- fi
- if test x$gtk_config_prefix != x ; then
- gtk_config_args="$gtk_config_args --prefix=$gtk_config_prefix"
-- if test -f $gtk_config_prefix/bin/gtk-config-2.0; then
-- GTK_CONFIG=$gtk_config_prefix/bin/gtk-config-2.0
-+ if test -f $gtk_config_prefix/bin/gtk12-config-2.0; then
-+ GTK_CONFIG=$gtk_config_prefix/bin/gtk12-config-2.0
- else
- if test x${GTK_CONFIG+set} != xset ; then
-- GTK_CONFIG=$gtk_config_prefix/bin/gtk-config
-+ GTK_CONFIG=$gtk_config_prefix/bin/gtk12-config
- fi
- fi
- fi
-@@ -1673,16 +1673,16 @@
- (gtk_minor_version != $gtk_config_minor_version) ||
- (gtk_micro_version != $gtk_config_micro_version))
- {
-- printf("\n*** 'gtk-config --version' returned %d.%d.%d, but GTK+ (%d.%d.%d)\n",
-+ printf("\n*** 'gtk12-config --version' returned %d.%d.%d, but GTK+ (%d.%d.%d)\n",
- $gtk_config_major_version, $gtk_config_minor_version, $gtk_config_micro_version,
- gtk_major_version, gtk_minor_version, gtk_micro_version);
-- printf ("*** was found! If gtk-config was correct, then it is best\n");
-+ printf ("*** was found! If gtk12-config was correct, then it is best\n");
- printf ("*** to remove the old version of GTK+. You may also be able to fix the error\n");
- printf("*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing\n");
- printf("*** /etc/ld.so.conf. Make sure you have run ldconfig if that is\n");
- printf("*** required on your system.\n");
-- printf("*** If gtk-config was wrong, set the environment variable GTK_CONFIG\n");
-- printf("*** to point to the correct copy of gtk-config, and remove the file config.cache\n");
-+ printf("*** If gtk12-config was wrong, set the environment variable GTK_CONFIG\n");
-+ printf("*** to point to the correct copy of gtk12-config, and remove the file config.cache\n");
- printf("*** before re-running configure\n");
- }
- else
-@@ -1724,10 +1724,10 @@
- else
- echo "$ac_t""no" 1>&6
- if test "$GTK_CONFIG" = "no" ; then
-- echo "*** The gtk-config script installed by GTK could not be found"
-+ echo "*** The gtk12-config script installed by GTK could not be found"
- echo "*** If GTK was installed in PREFIX, make sure PREFIX/bin is in"
- echo "*** your path, or set the GTK_CONFIG environment variable to the"
-- echo "*** full path to gtk-config."
-+ echo "*** full path to gtk12-config."
- else
- if test -f conf.gtktest ; then
- :
-@@ -1769,7 +1769,7 @@
- echo "*** The test program failed to compile or link. See the file config.log for the"
- echo "*** exact error that occured. This usually means GTK was incorrectly installed"
- echo "*** or that you have moved GTK since it was installed. In the latter case, you"
-- echo "*** may want to edit the gtk-config script: $GTK_CONFIG"
-+ echo "*** may want to edit the gtk12-config script: $GTK_CONFIG"
- fi
- rm -f conftest*
- CFLAGS="$ac_save_CFLAGS"
-@@ -1844,8 +1844,8 @@
-
- WITH_GTK=2
- else
-- # Extract the first word of "gtk-config", so it can be a program name with args.
--set dummy gtk-config; ac_word=$2
-+ # Extract the first word of "gtk12-config", so it can be a program name with args.
-+set dummy gtk12-config; ac_word=$2
- echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
- echo "configure:1851: checking for $ac_word" >&5
- if eval "test \"`echo '$''{'ac_cv_path_GTK_CONFIG'+set}'`\" = set"; then
-@@ -1907,21 +1907,21 @@
-
- if test x$gtk_config_exec_prefix != x ; then
- gtk_config_args="$gtk_config_args --exec-prefix=$gtk_config_exec_prefix"
-- if test -f $gtk_config_exec_prefix/bin/gtk-config-2.0; then
-- GTK_CONFIG=$gtk_config_exec_prefix/bin/gtk-config-2.0
-+ if test -f $gtk_config_exec_prefix/bin/gtk12-config-2.0; then
-+ GTK_CONFIG=$gtk_config_exec_prefix/bin/gtk12-config-2.0
- else
- if test x${GTK_CONFIG+set} != xset ; then
-- GTK_CONFIG=$gtk_config_exec_prefix/bin/gtk-config
-+ GTK_CONFIG=$gtk_config_exec_prefix/bin/gtk12-config
- fi
- fi
- fi
- if test x$gtk_config_prefix != x ; then
- gtk_config_args="$gtk_config_args --prefix=$gtk_config_prefix"
-- if test -f $gtk_config_prefix/bin/gtk-config-2.0; then
-- GTK_CONFIG=$gtk_config_prefix/bin/gtk-config-2.0
-+ if test -f $gtk_config_prefix/bin/gtk12-config-2.0; then
-+ GTK_CONFIG=$gtk_config_prefix/bin/gtk12-config-2.0
- else
- if test x${GTK_CONFIG+set} != xset ; then
-- GTK_CONFIG=$gtk_config_prefix/bin/gtk-config
-+ GTK_CONFIG=$gtk_config_prefix/bin/gtk12-config
- fi
- fi
- fi
-@@ -2008,16 +2008,16 @@
- (gtk_minor_version != $gtk_config_minor_version) ||
- (gtk_micro_version != $gtk_config_micro_version))
- {
-- printf("\n*** 'gtk-config --version' returned %d.%d.%d, but GTK+ (%d.%d.%d)\n",
-+ printf("\n*** 'gtk12-config --version' returned %d.%d.%d, but GTK+ (%d.%d.%d)\n",
- $gtk_config_major_version, $gtk_config_minor_version, $gtk_config_micro_version,
- gtk_major_version, gtk_minor_version, gtk_micro_version);
-- printf ("*** was found! If gtk-config was correct, then it is best\n");
-+ printf ("*** was found! If gtk12-config was correct, then it is best\n");
- printf ("*** to remove the old version of GTK+. You may also be able to fix the error\n");
- printf("*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing\n");
- printf("*** /etc/ld.so.conf. Make sure you have run ldconfig if that is\n");
- printf("*** required on your system.\n");
-- printf("*** If gtk-config was wrong, set the environment variable GTK_CONFIG\n");
-- printf("*** to point to the correct copy of gtk-config, and remove the file config.cache\n");
-+ printf("*** If gtk12-config was wrong, set the environment variable GTK_CONFIG\n");
-+ printf("*** to point to the correct copy of gtk12-config, and remove the file config.cache\n");
- printf("*** before re-running configure\n");
- }
- else
-@@ -2059,10 +2059,10 @@
- else
- echo "$ac_t""no" 1>&6
- if test "$GTK_CONFIG" = "no" ; then
-- echo "*** The gtk-config script installed by GTK could not be found"
-+ echo "*** The gtk12-config script installed by GTK could not be found"
- echo "*** If GTK was installed in PREFIX, make sure PREFIX/bin is in"
- echo "*** your path, or set the GTK_CONFIG environment variable to the"
-- echo "*** full path to gtk-config."
-+ echo "*** full path to gtk12-config."
- else
- if test -f conf.gtktest ; then
- :
-@@ -2104,7 +2104,7 @@
- echo "*** The test program failed to compile or link. See the file config.log for the"
- echo "*** exact error that occured. This usually means GTK was incorrectly installed"
- echo "*** or that you have moved GTK since it was installed. In the latter case, you"
-- echo "*** may want to edit the gtk-config script: $GTK_CONFIG"
-+ echo "*** may want to edit the gtk12-config script: $GTK_CONFIG"
- fi
- rm -f conftest*
- CFLAGS="$ac_save_CFLAGS"
-@@ -2147,21 +2147,21 @@
-
- if test x$gtk_config_exec_prefix != x ; then
- gtk_config_args="$gtk_config_args --exec-prefix=$gtk_config_exec_prefix"
-- if test -f $gtk_config_exec_prefix/bin/gtk-config-2.0; then
-- GTK_CONFIG=$gtk_config_exec_prefix/bin/gtk-config-2.0
-+ if test -f $gtk_config_exec_prefix/bin/gtk12-config-2.0; then
-+ GTK_CONFIG=$gtk_config_exec_prefix/bin/gtk12-config-2.0
- else
- if test x${GTK_CONFIG+set} != xset ; then
-- GTK_CONFIG=$gtk_config_exec_prefix/bin/gtk-config
-+ GTK_CONFIG=$gtk_config_exec_prefix/bin/gtk12-config
- fi
- fi
- fi
- if test x$gtk_config_prefix != x ; then
- gtk_config_args="$gtk_config_args --prefix=$gtk_config_prefix"
-- if test -f $gtk_config_prefix/bin/gtk-config-2.0; then
-- GTK_CONFIG=$gtk_config_prefix/bin/gtk-config-2.0
-+ if test -f $gtk_config_prefix/bin/gtk12-config-2.0; then
-+ GTK_CONFIG=$gtk_config_prefix/bin/gtk12-config-2.0
- else
- if test x${GTK_CONFIG+set} != xset ; then
-- GTK_CONFIG=$gtk_config_prefix/bin/gtk-config
-+ GTK_CONFIG=$gtk_config_prefix/bin/gtk12-config
- fi
- fi
- fi
-@@ -2248,16 +2248,16 @@
- (gtk_minor_version != $gtk_config_minor_version) ||
- (gtk_micro_version != $gtk_config_micro_version))
- {
-- printf("\n*** 'gtk-config --version' returned %d.%d.%d, but GTK+ (%d.%d.%d)\n",
-+ printf("\n*** 'gtk12-config --version' returned %d.%d.%d, but GTK+ (%d.%d.%d)\n",
- $gtk_config_major_version, $gtk_config_minor_version, $gtk_config_micro_version,
- gtk_major_version, gtk_minor_version, gtk_micro_version);
-- printf ("*** was found! If gtk-config was correct, then it is best\n");
-+ printf ("*** was found! If gtk12-config was correct, then it is best\n");
- printf ("*** to remove the old version of GTK+. You may also be able to fix the error\n");
- printf("*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing\n");
- printf("*** /etc/ld.so.conf. Make sure you have run ldconfig if that is\n");
- printf("*** required on your system.\n");
-- printf("*** If gtk-config was wrong, set the environment variable GTK_CONFIG\n");
-- printf("*** to point to the correct copy of gtk-config, and remove the file config.cache\n");
-+ printf("*** If gtk12-config was wrong, set the environment variable GTK_CONFIG\n");
-+ printf("*** to point to the correct copy of gtk12-config, and remove the file config.cache\n");
- printf("*** before re-running configure\n");
- }
- else
-@@ -2299,10 +2299,10 @@
- else
- echo "$ac_t""no" 1>&6
- if test "$GTK_CONFIG" = "no" ; then
-- echo "*** The gtk-config script installed by GTK could not be found"
-+ echo "*** The gtk12-config script installed by GTK could not be found"
- echo "*** If GTK was installed in PREFIX, make sure PREFIX/bin is in"
- echo "*** your path, or set the GTK_CONFIG environment variable to the"
-- echo "*** full path to gtk-config."
-+ echo "*** full path to gtk12-config."
- else
- if test -f conf.gtktest ; then
- :
-@@ -2344,7 +2344,7 @@
- echo "*** The test program failed to compile or link. See the file config.log for the"
- echo "*** exact error that occured. This usually means GTK was incorrectly installed"
- echo "*** or that you have moved GTK since it was installed. In the latter case, you"
-- echo "*** may want to edit the gtk-config script: $GTK_CONFIG"
-+ echo "*** may want to edit the gtk12-config script: $GTK_CONFIG"
- fi
- rm -f conftest*
- CFLAGS="$ac_save_CFLAGS"
-@@ -2988,7 +2988,7 @@
- echo $ac_n "(cached) $ac_c" 1>&6
- else
- ac_save_LIBS="$LIBS"
--LIBS="-lgtkdatabox `gtk-config --libs` $LIBS"
-+LIBS="-lgtkdatabox `gtk12-config --libs` $LIBS"
- cat > conftest.$ac_ext <<EOF
- #line 2994 "configure"
- #include "confdefs.h"
-@@ -3223,7 +3223,7 @@
- echo $ac_n "(cached) $ac_c" 1>&6
- else
- ac_save_LIBS="$LIBS"
--LIBS="-lgtkgl `gtk-config --libs` $GL_LIBS $LIBS"
-+LIBS="-lgtkgl `gtk12-config --libs` $GL_LIBS $LIBS"
- cat > conftest.$ac_ext <<EOF
- #line 3229 "configure"
- #include "confdefs.h"
+--- modules/_Image_FreeType/freetype.c.orig Thu Mar 18 19:54:53 2004
++++ modules/_Image_FreeType/freetype.c Thu Mar 18 19:55:34 2004
+@@ -3,7 +3,8 @@
+ RCSID("$Id: freetype.c,v 1.5 2002/10/29 09:43:03 grubba Exp $");
+
+ #ifdef HAVE_LIBFT2
+-#include <freetype/freetype.h>
++#include <ft2build.h>
++#include FT_FREETYPE_H
+ #include "pike_macros.h"
+ #include "object.h"
+ #include "constants.h"
diff --git a/lang/pike72/files/patch-ac b/lang/pike72/files/patch-ac
new file mode 100644
index 00000000000..a743a11c6eb
--- /dev/null
+++ b/lang/pike72/files/patch-ac
@@ -0,0 +1,42 @@
+--- modules/_Image_TTF/configure.orig Tue Mar 9 00:18:25 2004
++++ modules/_Image_TTF/configure Fri Mar 19 12:19:13 2004
+@@ -963,7 +963,7 @@
+ fi
+ echo "$ac_t""$CPP" 1>&6
+
+-for ac_hdr in freetype.h ftxkern.h freetype/freetype.h freetype/ftxkern.h
++for ac_hdr in freetype.h ftxkern.h freetype1/freetype/freetype.h freetype1/freetype/ftxkern.h
+ do
+ ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
+ echo $ac_n "checking for $ac_hdr""... $ac_c" 1>&6
+@@ -1004,7 +1004,7 @@
+ done
+
+ else
+- for ac_hdr in freetype.h ftxkern.h freetype/freetype.h freetype/ftxkern.h
++ for ac_hdr in freetype.h ftxkern.h freetype1/freetype/freetype.h freetype1/freetype/ftxkern.h
+ do
+ ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
+ eval "ac_cv_header_$ac_safe=yes"
+@@ -1013,8 +1013,8 @@
+
+
+ parent="$ac_cv_header_ftxkern_h$ac_cv_header_freetype_h"
+- subdir="$ac_cv_header_freetype_ftxkern_h$ac_cv_header_freetype_freetype_h"
+- freetype_h="$ac_cv_header_freetype_h$ac_cv_header_freetype_freetype_h"
++ subdir="$ac_cv_header_freetype1_freetype_ftxkern_h$ac_cv_header_freetype1_freetype_freetype_h"
++ freetype_h="$ac_cv_header_freetype_h$ac_cv_header_freetype1_freetype_freetype_h"
+
+ if test "$parent" = "yesyes" -o "$subdir" = "yesyes"; then
+ echo $ac_n "checking for TT_Open_Collection in -lttf""... $ac_c" 1>&6
+@@ -1073,8 +1073,8 @@
+ #line 1074 "configure"
+ #include "confdefs.h"
+
+-#ifdef HAVE_FREETYPE_FREETYPE_H
+-#include <freetype/freetype.h>
++#ifdef HAVE_FREETYPE1_FREETYPE_FREETYPE_H
++#include <freetype1/freetype/freetype.h>
+ #else
+ #include <freetype.h>
+ #endif
diff --git a/lang/pike72/files/patch-ad b/lang/pike72/files/patch-ad
new file mode 100644
index 00000000000..3c3bf9f52cf
--- /dev/null
+++ b/lang/pike72/files/patch-ad
@@ -0,0 +1,16 @@
+--- modules/_Image_TTF/image_ttf.c.orig Tue Jun 12 15:21:10 2001
++++ modules/_Image_TTF/image_ttf.c Fri Mar 19 01:05:52 2004
+@@ -9,10 +9,10 @@
+ RCSID("$Id: image_ttf.c,v 1.40 2001/06/12 13:21:10 grubba Exp $");
+
+ #ifdef HAVE_LIBTTF
+-#if defined(HAVE_FREETYPE_FREETYPE_H) && defined(HAVE_FREETYPE_FTXKERN_H)
++#if defined(HAVE_FREETYPE1_FREETYPE_FREETYPE_H) && defined(HAVE_FREETYPE1_FREETYPE_FTXKERN_H)
+
+-#include <freetype/freetype.h>
+-#include <freetype/ftxkern.h>
++#include <freetype1/freetype/freetype.h>
++#include <freetype1/freetype/ftxkern.h>
+
+ #else /* !HAVE_FREETYPE_FREETYPE_H || !HAVE_FREETYPE_FTXKERN_H */
+
diff --git a/lang/pike72/files/patch-ae b/lang/pike72/files/patch-ae
new file mode 100644
index 00000000000..e0c2b4127e6
--- /dev/null
+++ b/lang/pike72/files/patch-ae
@@ -0,0 +1,18 @@
+--- modules/_Image_TTF/config.h.in.orig Fri Mar 19 01:04:12 2004
++++ modules/_Image_TTF/config.h.in Fri Mar 19 01:05:19 2004
+@@ -7,11 +7,11 @@
+ /* Define if you have the <freetype.h> header file. */
+ #undef HAVE_FREETYPE_H
+
+-/* Define if you have the <freetype/freetype.h> header file. */
+-#undef HAVE_FREETYPE_FREETYPE_H
++/* Define if you have the <freetype1/freetype/freetype.h> header file. */
++#undef HAVE_FREETYPE1_FREETYPE_FREETYPE_H
+
+-/* Define if you have the <freetype/ftxkern.h> header file. */
+-#undef HAVE_FREETYPE_FTXKERN_H
++/* Define if you have the <freetype1/freetype/ftxkern.h> header file. */
++#undef HAVE_FREETYPE1_FREETYPE_FTXKERN_H
+
+ /* Define if you have the <ftxkern.h> header file. */
+ #undef HAVE_FTXKERN_H
diff --git a/lang/pike72/files/patch-module_support.c b/lang/pike72/files/patch-module_support.c
deleted file mode 100644
index 38b74feb566..00000000000
--- a/lang/pike72/files/patch-module_support.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- module_support.c.orig Sat Mar 13 23:31:07 2004
-+++ module_support.c Sat Mar 13 23:31:34 2004
-@@ -314,7 +314,7 @@
- va_start(ptr, fmt);
- ret=va_get_args(s, num_args, fmt, ptr);
- #ifndef __TenDRA__
-- va_end(fmt);
-+ va_end(ptr);
- #endif /* !__TenDRA */
- return ret;
- }