aboutsummaryrefslogtreecommitdiffstats
path: root/lang/pm3-netobj/Makefile
diff options
context:
space:
mode:
authorjdp <jdp@FreeBSD.org>2000-02-14 07:46:10 +0800
committerjdp <jdp@FreeBSD.org>2000-02-14 07:46:10 +0800
commit1e0fe87bd216f0e44ef68483bbbd7221e48d2494 (patch)
treeb2801731f95bc3925b04412a23dc6ef0756a0730 /lang/pm3-netobj/Makefile
parentd3c040a16e0f09e1a179f515f35a18337ca18ff6 (diff)
downloadfreebsd-ports-graphics-1e0fe87bd216f0e44ef68483bbbd7221e48d2494.tar.gz
freebsd-ports-graphics-1e0fe87bd216f0e44ef68483bbbd7221e48d2494.tar.zst
freebsd-ports-graphics-1e0fe87bd216f0e44ef68483bbbd7221e48d2494.zip
New port for Network Objects. Network objects offer transparent
remote method invocation on objects. I.e., they're like RPC only better.
Diffstat (limited to 'lang/pm3-netobj/Makefile')
-rw-r--r--lang/pm3-netobj/Makefile85
1 files changed, 85 insertions, 0 deletions
diff --git a/lang/pm3-netobj/Makefile b/lang/pm3-netobj/Makefile
new file mode 100644
index 00000000000..acd49fe3707
--- /dev/null
+++ b/lang/pm3-netobj/Makefile
@@ -0,0 +1,85 @@
+# New ports collection makefile for: pm3-netobj
+# Version required: 1.1.13
+# Date created: 11 Feb 2000
+# Whom: John Polstra <jdp@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+DISTNAME= pm3-netobj-${VERSION}
+CATEGORIES= lang
+DISTFILES=
+
+MAINTAINER= jdp@FreeBSD.org
+
+BUILD_DEPENDS= ${L1}libm3tcp${L2}:${PORTSDIR}/lang/pm3-net \
+ ${L1}libm3tk${L2}:${PORTSDIR}/lang/pm3-m3tk
+RUN_DEPENDS= ${L1}libm3tcp${L2}:${PORTSDIR}/lang/pm3-net \
+ ${L1}libm3tk${L2}:${PORTSDIR}/lang/pm3-m3tk
+DEPENDS= ${PORTSDIR}/lang/pm3-base:configure
+
+DIST_SUBDIR= pm3
+INSTALL_TARGET= all
+MAN1= netobjd.1 stubgen.1
+PLIST_SUB+= SOVERSION=${SOVERSION} TARGET=${TARGET} \
+ TARGETDIR=${TARGETDIR} WORDSIZE=${WORDSIZE}
+WRKSRC= ${WRKDIRPREFIX}${.CURDIR}/../pm3-base/work/pm3-${VERSION}
+
+BUILDDIRS= network/netobjects/netobj \
+ network/netobjects/netobjd \
+ network/netobjects/stubgen
+PROGS= bin/netobjd \
+ bin/stubgen
+L1= ${PREFIX}/lib/m3/${TARGET}/
+SOVERSION= 7
+VERSION= 1.1.13
+
+.include <bsd.port.pre.mk>
+
+.if ${PORTOBJFORMAT} == "aout"
+L2= .so.${SOVERSION}.0
+TARGET= FreeBSD2
+TARGETDIR= freebsd-2
+WORDSIZE= 32
+.elif ${ARCH} == "i386"
+L2= .so.${SOVERSION}
+.if ${OSVERSION} < 400011
+TARGET= FreeBSD3
+TARGETDIR= freebsd-3
+.else
+TARGET= FreeBSD4
+TARGETDIR= freebsd-4
+.endif
+WORDSIZE= 32
+.elif ${ARCH} == "alpha"
+.if ${OSVERSION} < 400011
+BROKEN= Not supported on older versions of FreeBSD/Alpha
+.endif
+CFLAGS+= -mieee
+L2= .so.${SOVERSION}
+TARGET= FBSD_ALPHA
+TARGETDIR= fbsd-alpha
+WORDSIZE= 64
+.endif
+
+.if empty(TARGET)
+pre-fetch:
+ @${ECHO_MSG} "Cannot determine M3 target for this architecture"
+ @${FALSE}
+.endif
+
+do-build:
+ @${ECHO_MSG} "This port does everything in the install step."
+ @${ECHO_MSG} "The build step is a no-op."
+
+do-install:
+ @for i in ${BUILDDIRS}; do \
+ ${ECHO_MSG} "Building in $${i}"; \
+ cd ${WRKSRC}/$${i} && ${PREFIX}/bin/m3build && \
+ ${PREFIX}/bin/m3ship; \
+ done
+ @for i in ${PROGS}; do strip ${PREFIX}/$$i; done
+ @${MKDIR} ${PREFIX}/share/pm3-netobj
+ @${INSTALL_DATA} ${WRKSRC}/src/COPYRIGHT ${PREFIX}/share/pm3-netobj
+
+.include <bsd.port.post.mk>