aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python22/Makefile
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>1997-08-06 14:40:31 +0800
committertg <tg@FreeBSD.org>1997-08-06 14:40:31 +0800
commitbfe9497be923d5e534df6fc31e894124ba66eae9 (patch)
treea0ef748396f9fa1c986519667948c60033dd206d /lang/python22/Makefile
parent456653b34654386578ac39438096f5205a321835 (diff)
downloadfreebsd-ports-graphics-bfe9497be923d5e534df6fc31e894124ba66eae9.tar.gz
freebsd-ports-graphics-bfe9497be923d5e534df6fc31e894124ba66eae9.tar.zst
freebsd-ports-graphics-bfe9497be923d5e534df6fc31e894124ba66eae9.zip
Fix tk-4.1 dependency. While I'm here, add libreadline support.
Diffstat (limited to 'lang/python22/Makefile')
-rw-r--r--lang/python22/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/lang/python22/Makefile b/lang/python22/Makefile
index 328328c89dd..349211934c3 100644
--- a/lang/python22/Makefile
+++ b/lang/python22/Makefile
@@ -3,7 +3,7 @@
# Date created: 08 August 1995
# Whom: jkh
#
-# $Id: Makefile,v 1.14 1997/05/14 07:35:11 tg Exp $
+# $Id: Makefile,v 1.15 1997/06/02 11:42:56 tg Exp $
#
DISTNAME= python1.4
@@ -19,21 +19,21 @@ MAINTAINER= tg@FreeBSD.org
LIB_DEPENDS= tk41\\.1\\.:${PORTSDIR}/x11/tk41
WRKSRC= ${WRKDIR}/Python-1.4
-HAS_CONFIGURE= yes
-
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --with-readline
MAKE_FLAGS+= 'OPT=${CFLAGS}'
INSTALL_TARGET= install
MAN1= python.1
#
# If you want to use Python's thread module, you need to set WITH_THREADS
-# to 'yes', and you must have the FreeBSD threading c library (libc_r)
-# installed. See 'man 3 pthread' for details on libc_r.
+# to 'yes', and you must have the FreeBSD threading c library (libc_r)
+# installed. See 'man 3 pthread' for details on libc_r.
#
WITH_THREADS= yes
SETUP_FILE= 'Setup'
.if exists(/usr/lib/libc_r.a) && defined(WITH_THREADS) && ${WITH_THREADS} == yes
-CONFIGURE_ARGS= --with-thread
+CONFIGURE_ARGS+= --with-thread
SETUP_FILE= 'Setup.thread'
.endif