aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python22
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2004-04-14 14:49:21 +0800
committerperky <perky@FreeBSD.org>2004-04-14 14:49:21 +0800
commit9d3d93abf1c0793485256e0efc18a1cd3ae3417f (patch)
treef8c9bb9d4adde3fbdd5eee76293271d16e55547d /lang/python22
parentb9afde5e269c7a7c2433de3203557ac5773b37d4 (diff)
downloadfreebsd-ports-graphics-9d3d93abf1c0793485256e0efc18a1cd3ae3417f.tar.gz
freebsd-ports-graphics-9d3d93abf1c0793485256e0efc18a1cd3ae3417f.tar.zst
freebsd-ports-graphics-9d3d93abf1c0793485256e0efc18a1cd3ae3417f.zip
Fixed a bug where the configure script couldn't detect getaddrinfo()
properly if the KAME stack had SCTP support. Submitted by: suz
Diffstat (limited to 'lang/python22')
-rw-r--r--lang/python22/Makefile2
-rw-r--r--lang/python22/files/patch-configure10
2 files changed, 11 insertions, 1 deletions
diff --git a/lang/python22/Makefile b/lang/python22/Makefile
index 1ddb3c24e2f..c8a4818d472 100644
--- a/lang/python22/Makefile
+++ b/lang/python22/Makefile
@@ -7,7 +7,7 @@
PORTNAME= python
PORTVERSION= 2.2.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
diff --git a/lang/python22/files/patch-configure b/lang/python22/files/patch-configure
new file mode 100644
index 00000000000..1ed245321f0
--- /dev/null
+++ b/lang/python22/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Wed Apr 14 15:29:28 2004
++++ configure Wed Apr 14 15:30:25 2004
+@@ -5523,6 +5523,7 @@
+ hints.ai_family = AF_UNSPEC;
+ hints.ai_flags = passive ? AI_PASSIVE : 0;
+ hints.ai_socktype = SOCK_STREAM;
++ hints.ai_protocol = IPPROTO_TCP;
+ if ((gaierr = getaddrinfo(NULL, "54321", &hints, &aitop)) != 0) {
+ (void)gai_strerror(gaierr);
+ goto bad;