aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python22
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>1997-08-29 15:04:27 +0800
committertg <tg@FreeBSD.org>1997-08-29 15:04:27 +0800
commitc67fab318e1a7b71057771fb7b62fb736178f77b (patch)
treef364a6c2f37a465fbff1c0972d1320ad5a4771ba /lang/python22
parent14d531aad3c27dfc717b7e8bffb32e201b0e8b33 (diff)
downloadfreebsd-ports-graphics-c67fab318e1a7b71057771fb7b62fb736178f77b.tar.gz
freebsd-ports-graphics-c67fab318e1a7b71057771fb7b62fb736178f77b.tar.zst
freebsd-ports-graphics-c67fab318e1a7b71057771fb7b62fb736178f77b.zip
Use tk-8.0. Minor makefile cleanups. Add some `@dirrm's in PLIST.
Diffstat (limited to 'lang/python22')
-rw-r--r--lang/python22/Makefile15
-rw-r--r--lang/python22/distinfo2
-rw-r--r--lang/python22/files/Setup2
-rw-r--r--lang/python22/pkg-plist10
4 files changed, 22 insertions, 7 deletions
diff --git a/lang/python22/Makefile b/lang/python22/Makefile
index 349211934c3..74dccf93bca 100644
--- a/lang/python22/Makefile
+++ b/lang/python22/Makefile
@@ -3,21 +3,23 @@
# Date created: 08 August 1995
# Whom: jkh
#
-# $Id: Makefile,v 1.15 1997/06/02 11:42:56 tg Exp $
+# $Id: Makefile,v 1.16 1997/08/06 06:40:27 tg Exp $
#
DISTNAME= python1.4
PKGNAME= python-1.4
-CATEGORIES= lang tk41
+CATEGORIES= lang tk80
MASTER_SITES= ftp://www.python.org/pub/python/src/ \
ftp://ftp.cwi.nl/pub/python/src/ \
ftp://www.python.org/pub/python/contrib/Graphics/Tkinter/ \
ftp://ftp.cwi.nl/pub/python/contrib/Graphics/Tkinter/
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} _tkinter1.4.c
MAINTAINER= tg@FreeBSD.org
-LIB_DEPENDS= tk41\\.1\\.:${PORTSDIR}/x11/tk41
+LIB_DEPENDS= tk80\\.1\\.:${PORTSDIR}/x11/tk80
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
WRKSRC= ${WRKDIR}/Python-1.4
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-readline
@@ -31,12 +33,15 @@ MAN1= python.1
# installed. See 'man 3 pthread' for details on libc_r.
#
WITH_THREADS= yes
-SETUP_FILE= 'Setup'
+SETUP_FILE= Setup
.if exists(/usr/lib/libc_r.a) && defined(WITH_THREADS) && ${WITH_THREADS} == yes
CONFIGURE_ARGS+= --with-thread
-SETUP_FILE= 'Setup.thread'
+SETUP_FILE= Setup.thread
.endif
+post-extract:
+ ${CP} ${DISTDIR}/_tkinter1.4.c ${WRKSRC}/Modules/_tkinter.c
+
post-configure:
${CP} ${FILESDIR}/${SETUP_FILE} ${WRKSRC}/Modules/Setup
diff --git a/lang/python22/distinfo b/lang/python22/distinfo
index cc24c78b4b9..cace9956646 100644
--- a/lang/python22/distinfo
+++ b/lang/python22/distinfo
@@ -1,2 +1,2 @@
MD5 (python1.4.tar.gz) = 341e3f3c688842024e70af6a99b5fb90
-MD5 (PyTix-1.12.tar.gz) = 03b90d29ee8f5c42ff0dbb920b1341af
+MD5 (_tkinter1.4.c) = 118b13afb519c58cfcccb47849ab6090
diff --git a/lang/python22/files/Setup b/lang/python22/files/Setup
index 7a6b60916c4..cab0cf57b1a 100644
--- a/lang/python22/files/Setup
+++ b/lang/python22/files/Setup
@@ -250,7 +250,7 @@ TKPATH=:$(DESTLIB)/tkinter
#_tkinter _tkinter.c -I/usr/openwin/include -I/usr/local/include -L/usr/openwin/lib -L/usr/local/lib -ltk4.1 -ltcl7.5 -lX11
# For generic system (may have to add -I/-L options to find X11):
#_tkinter _tkinter.c -I/usr/local/include -L/usr/local/lib -ltk4.1 -ltcl7.5 -lX11
-_tkinter _tkinter.c -I${PREFIX}/include/tk4.1 -I${X11BASE}/include -L${PREFIX}/lib -L${X11BASE}/lib -ltk41 -ltcl75 -lX11
+_tkinter _tkinter.c -I${PREFIX}/include/tk8.0 -I${PREFIX}/include/tcl8.0 -I${X11BASE}/include -L${PREFIX}/lib -L${X11BASE}/lib -ltk80 -ltcl80 -lX11
# Lance Ellinghaus's modules:
diff --git a/lang/python22/pkg-plist b/lang/python22/pkg-plist
index 9627f1baa33..ea3e038516d 100644
--- a/lang/python22/pkg-plist
+++ b/lang/python22/pkg-plist
@@ -475,3 +475,13 @@ share/python1.4/whichdb.pyc
share/python1.4/whrandom.pyc
share/python1.4/xdrlib.pyc
share/python1.4/zmod.pyc
+@dirrm include/python1.4
+@dirrm lib/python1.4/config
+@dirrm lib/python1.4/sharedmodules
+@dirrm lib/python1.4
+@dirrm share/python1.4/stdwin
+@dirrm share/python1.4/tkinter
+@dirrm share/python1.4/test
+@dirrm share/python1.4/freebsd
+@dirrm share/python1.4/stdwin
+@dirrm share/python1.4
poolBen Woods2021-05-223-3/+3 * x11/runner: new port had been added (+)Alexey Dokuchaev2021-05-214-1/+42 * x11/bemenu: Update to 0.6.0Tobias Kortkamp2021-05-213-12/+15 * x11/libX11: Update to 1.7.1.Daniel Engberg2021-05-212-4/+4 * x11/{linux-nvidia-libs,nvidia-driver}{,-390}: update to the latest versionsAlexey Dokuchaev2021-05-206-16/+20 * x11/srandrd: Add a new port: a simple randr daemonMateusz Piotrowski2021-05-205-0/+53 * x11/sakura: Update to 3.8.2Danilo Egea Gondolfo2021-05-203-7/+7 * x11/kitty: connect to complete (bulk -a) buildJan Beich2021-05-201-0/+1 * x11/kitty: Tidy up Makefile and pkg-descr.Gleb Popov2021-05-192-11/+3 * x11/kitty: + Fast GPU-based terminal emulator.Alexis Praga2021-05-194-0/+258 * x11/alacritty: update to 0.8.0Jan Beich2021-05-192-164/+136 * x11/alacritty: regen distinfo after 3758b337a1b0Jan Beich2021-05-191-398/+398 * x11/libXres: update to 1.2.1Jan Beich2021-05-182-5/+4 * x11/libX11: update to 1.7.0Jan Beich2021-05-183-8/+8 * x11/xorgproto: update to 2021.4Jan Beich2021-05-182-4/+4 * x11/find-cursor: Update to 1.7Mateusz Piotrowski2021-05-172-12/+5 * x11/rxvt-unicode: upgrade to 9.26Thierry Thomas2021-05-152-4/+5 * x11/rxvt-unicode: upgrade to 9.25Thierry Thomas2021-05-1514-69/+48 * x11/libxkbcommon: update to 1.3.0Jan Beich2021-05-142-4/+4 * Update KDE Gear to 21.04.1Tobias C. Berner2021-05-143-12/+6 * Convert GitLab diffs back to patchesJan Beich2021-05-122-6/+6 * x11/virtboard: document patch originJan Beich2021-05-121-2/+2 * Rebuild lang/rust consumers after d8837418ea743776Tobias Kortkamp2021-05-125-3/+5 * Update KDE Frameworks to 5.82.0Tobias C. Berner2021-05-1218-38/+36 * x11/pmenu: Update to 2.3.0Mateusz Piotrowski2021-05-112-4/+4 * x11/showmethekey: add new portJan Beich2021-05-094-0/+48 * x11/plasma5-plasma-desktop: fix screen reader configurationTobias C. Berner2021-05-092-1/+7 * x11/screengrab: Update to 2.2.0Jesper Schmitz Mouridsen2021-05-093-5/+9 * x11/lxqt-runner: Update to 0.17.0Jesper Schmitz Mouridsen2021-05-093-5/+7 * x11/qterminal: Update to 0.17.0Jesper Schmitz Mouridsen2021-05-093-5/+6 * x11/lxqt-globalkeys: Update to 0.17.0Jesper Schmitz Mouridsen2021-05-093-4/+6 * x11/lxqt-about: Update to 0.17.0Jesper Schmitz Mouridsen2021-05-093-5/+7 * x11/libfm-qt: Update to 0.17.0Jesper Schmitz Mouridsen2021-05-093-6/+9 * x11/plasma5-plasma: update to 5.21.5Tobias C. Berner2021-05-0612-29/+32 * graphics/poppler: update to 21.05.0Tobias C. Berner2021-05-061-1/+1 * x11/sterm: only use general nonconflicting patchesPiotr Kubaj2021-05-062-15/+7 * x11/py-xdot: Add missing dependency NumPyYuri Victorovich2021-05-051-1/+3 * x11/fuzzel: update to 1.5.4Jan Beich2021-05-052-4/+4 * x11/xfce4-clipman-plugin: Update to 1.6.2Guido Falsi2021-05-043-6/+7 * x11/gnome-shell: reintroduce dependency upon x11/libgnomekbdRuslan Makhmatkhanov2021-05-041-1/+2 * x11/mako: update to 1.5Jan Beich2021-05-042-24/+4 * KDE Plasma Wayland: improve Wayland experienceAdriaan de Groot2021-05-042-18/+23 * x11/konsole: add usptream patch fix highlight colour contrastTobias C. Berner2021-05-032-1/+7 * x11/wezterm: update to 20210502.154244.3.f7122.cJan Beich2021-05-032-196/+184 * x11/wezterm: regen distinfo after 3758b337a1b0Jan Beich2021-05-031-916/+916 * x11/xpra: Update to 4.1.3Gleb Popov2021-05-022-5/+5 * x11/plasma-wayland-protocols: update to 1.3.0Tobias C. Berner2021-05-022-5/+4 * Clean up some thingsTobias Kortkamp2021-05-022-2/+1 * x11/libgnome: removeBaptiste Daroussin2021-05-0110-253/+0 * x11/plasma5-plasma-workspace: add helper script for Plasma WaylandAdriaan de Groot2021-04-303-1/+66 * x11/terminator: Update to 2.1.1.Hajimu UMEMOTO2021-04-302-4/+4 * x11/libfm: fix BROKEN for gtk3 flavorFernando Apesteguía2021-04-302-8/+9 * Bump PORTREVISION on *-sbcl ports after lang/sbcl upgrade.Kirill Ponomarev2021-04-301-1/+1 * [KDE Plasma] fix plistsAdriaan de Groot2021-04-261-0/+1 * - Update Ulauncher to version 5.11.0Alexey Dokuchaev2021-04-252-5/+9 * Cleanup LIB_DEPENDSAntoine Brodin2021-04-241-1/+1 * Update KDE Plasma to 5.21.4Adriaan de Groot2021-04-239-27/+27 * x11/slim: Add dbus runtime dependencyFernando Apesteguía2021-04-232-0/+6 * Update KDE Gear to 21.04Tobias C. Berner2021-04-234-8/+6 * KDE Plasma: update to 5.21.3Adriaan de Groot2021-04-2221-437/+505 * KDE Frameworks: remove kdoctools runtime dependencyAdriaan de Groot2021-04-224-4/+8 * x11/kf5-frameworks: correct typo in commentAdriaan de Groot2021-04-221-2/+1 * x11/kf5-kactivities: boost is only a build-time dependencyAdriaan de Groot2021-04-221-1/+2 * x11/xmenu: Update to 4.5.5Lewis Cook2021-04-223-13/+13 * Bump USES=cabal ports after 12837690ed0cTobias Kortkamp2021-04-212-0/+2 * x11/xfce4-terminal: Enable utmp/wtmp supportGuido Falsi2021-04-211-2/+3 * x11/keybinder-gtk3: Add DOCS/EXAMPLES optionsRainer Hurling2021-04-212-22/+46 * x11/wdisplays: update to 1.1Jan Beich2021-04-203-14/+8 * x11/wdisplays: unbreak fetch via forkJan Beich2021-04-203-4/+4 * New port: x11/dsbxinput: Graphical tool for configuring pointing devicesRainer Hurling2021-04-205-0/+31 * x11/wezterm: drop CARGO_USE_GITHUB workaround after 58744a09099aJan Beich2021-04-191-4/+0 * Clean up all commented PORTREVISION and PORTEPOCH linesTobias Kortkamp2021-04-191-1/+1 * Remove my useless "Created by" linesTobias Kortkamp2021-04-192-4/+0 * x11/xdg-desktop-portal-wlr: unbreak default config after 337aa4a3c88eJan Beich2021-04-192-0/+6 * x11/foot: update to 1.7.2Jan Beich2021-04-192-4/+4 * x11/xdg-desktop-portal-wlr: respect PREFIX in manpageJan Beich2021-04-191-0/+4 * x11/xdg-desktop-portal-wlr: update to 0.3.0Jan Beich2021-04-192-5/+14 * x11/luit: Update to 20210218Emanuel Haupt2021-04-182-5/+4 * x11/rubygem-gnome: Update COMMENTPo-Chuan Hsieh2021-04-181-1/+1 * x11/slurp: update to 1.3.2Jan Beich2021-04-182-4/+4 * x11/grim: update to 1.3.2Jan Beich2021-04-182-4/+4 * x11/squeekboard: update to 1.13.0Jan Beich2021-04-162-36/+35 * Unbreak nVidia driver build against new feature branch 465.xx, whichAlexey Dokuchaev2021-04-163-3/+11 * Update nVidia driver, Linux libraries, and tools to version 460.73.01,Alexey Dokuchaev2021-04-168-16/+12 * graphics/poppler: update to 21.04.0Tobias C. Berner2021-04-161-1/+1 * x11/waybar: update to 0.9.7Jan Beich2021-04-162-4/+4 * x11/waybar: update to 0.9.6Jan Beich2021-04-162-4/+5 * Create x11/xpra-html port - a HTML5 client for x11/xpraGleb Popov2021-04-155-0/+223 * Update KDE Frameworks to 5.81.0Tobias C. Berner2021-04-1511-33/+33 * Mk: Cleanup after moving apply-slist earlier.Mathieu Arnold2021-04-141-1/+0 * x11/xclickroot: Update to 1.3Mateusz Piotrowski2021-04-142-4/+4 * x11/libxdg-basedir: update to 1.2.2Kevin Bowling2021-04-142-7/+10 * update x11/slick-greeter to 1.5.2Eric Turgeon2021-04-143-29/+31 * x11/libfm: Update to 1.3.2Fernando Apesteguía2021-04-134-15/+15 * x11/fuzzel: update to 1.5.3Jan Beich2021-04-132-4/+4 * x11/libexo: Update to 4.16.2Guido Falsi2021-04-132-4/+4 * x11/fireflies: add LICENSE, update USE_GLDmitry Marakasov2021-04-131-1/+4 * x11/lavalauncher: update to 2.1.0Jan Beich2021-04-122-11/+11 * Allow to optionally build `x11/gxkb' against GTKv3 instead of v2 andAlexey Dokuchaev2021-04-122-5/+122 * Regenerate all distfiles using gitlab as source.Matthias Fechner2021-04-109-29/+29 * x11/ly: Update to 0.5.2Neel Chauhan2021-04-105-16/+24 * x11/xmascot: clean up portYoshihiro Takahashi2021-04-094-31/+28 * x11/libxkbcommon: update to 1.2.1Jan Beich2021-04-092-14/+5 * x11/libxkbcommon: expose evdev(4) support in xkbcliEvgeniy Khramtsov2021-04-093-3/+17 * x11/libxkbcommon: expose Wayland support in xkbcliJan Beich2021-04-092-3/+9 * x11/libxkbcommon: pet portlint via USE_LDCONFIGEvgeniy Khramtsov2021-04-091-0/+1 * x11/libxkbcommon: simplify OSVERSION checkJan Beich2021-04-091-8/+4 * devel/icu: update to 69.1Jan Beich2021-04-092-2/+2 * Remove useless Created by: headers mentioning meDmitry Marakasov2021-04-081-2/+0 * Remove expired ports:Rene Ladan2021-04-0849-1175/+0 * One more small cleanup, forgotten yesterday.Mathieu Arnold2021-04-07253-253/+0 * x11/polybar: Update to 3.5.5Alexandre C. Guimarães2021-04-072-4/+4 * x11/cinnamon: Attempt to fix build order bug (D29353)Tobias Kortkamp2021-04-071-0/+19 * x11/brisk-menu: Attempt to fix build order bug (D29353)Tobias Kortkamp2021-04-071-0/+20 * Update x11/plasma-wayland-protocols to latest upstreamAdriaan de Groot2021-04-072-4/+5 * all: Remove all other $FreeBSD keywords.Mathieu Arnold2021-04-0613-31/+2 * Remove # $FreeBSD$ from Makefiles.Mathieu Arnold2021-04-06555-557/+0 * x11/virtualgl: enable on powerpc64Piotr Kubaj2021-04-061-1/+1 * x11/virtualgl: enable on powerpc64lePiotr Kubaj2021-04-061-1/+1 * x11/wezterm: update to 20210405.110924.a5.b5.b8Jan Beich2021-04-062-204/+194 * Rebuild lang/rust consumers after r569489Tobias Kortkamp2021-03-305-4/+5 * Bump PORTREVISION on *-sbcl ports after lang/sbcl upgrade.Kirill Ponomarev2021-03-291-1/+1 * x11/foot: update to 1.7.1Jan Beich2021-03-292-4/+4 * x11/xterm: Update to 367Emanuel Haupt2021-03-272-4/+4 * x11/libxcvt: avoid conflict with xorg-serverJan Beich2021-03-262-4/+2 * x11/libxcvt: add new portJan Beich2021-03-265-0/+39 * x11/libxkbcommon: update to 1.1.0Jan Beich2021-03-262-4/+4 * Mark ports recursively depending on Python 2.7 for expiration on June 23.Rene Ladan2021-03-243-1/+11 * Unbreak fetch from git.sr.htJan Beich2021-03-233-3/+3 * sysutils/mxkill, x11/mxascii: Fix build.Cy Schubert2021-03-231-0/+3 * x11/gtk-app-menu: add WWW to pkg-descrKurt Jaeger2021-03-232-0/+3 * x11/wayland-logout: use C version on FreeBSD >= 12.3Jan Beich2021-03-211-1/+1 * x11/foot: update to 1.7.0Jan Beich2021-03-214-5/+17 * Update KDE Frameworks to 5.80.'Tobias C. Berner2021-03-1913-33/+38 * Update to version 460.67.Alexey Dokuchaev2021-03-198-14/+14 * x11/gtk-app-menu: Update to 0.7.6Neel Chauhan2021-03-177-47/+36 * x11/mxascii: remove an extraneous fileCy Schubert2021-03-171-15/+0 * sysutils/mxkill x11/mxascii: Fix FreeBSD-11 buildCy Schubert2021-03-171-0/+10 * x11/rofi-wayland: add new portJan Beich2021-03-175-6/+43 * x11/rofi: convert to USES=mesonJan Beich2021-03-171-7/+6 * rxvt-unicode: The terminfo definition is not needed anymore:Baptiste Daroussin2021-03-162-12/+2 * x11/alttab: Update to 1.6.0Dmitri Goutnik2021-03-152-4/+4 * x11/wezterm: adjust features after r568424Jan Beich2021-03-151-1/+1 * x11/wezterm: update to 20210314.114017.04.b7.cJan Beich2021-03-152-324/+366 * sysutils/mxkill, sysutils/mxascii: remove redunant +=Cy Schubert2021-03-141-1/+1 * x11/mxascii: Correct categoryCy Schubert2021-03-141-1/+1 * Add x11/mxascii: Similar to xascii but using X11/Motif widgetsCy Schubert2021-03-146-0/+57 * add mate-dock-applet/files/patch-src_dock.inEric Turgeon2021-03-142-1/+27 * - Update libexo to 4.16.1Guido Falsi2021-03-133-16/+4 * - Update math/glm to 0.9.9.8Dmitry Marakasov2021-03-121-1/+1 * x11/alacritty: enable X11 option by defaultMikael Urankar2021-03-121-2/+2 * x11/alacritty: Add video backend optionMikael Urankar2021-03-121-2/+16 * x11/xpra: Update to 4.1.1Gleb Popov2021-03-116-260/+114 * x11/mako: unbreak build on DragonFlyJan Beich2021-03-112-1/+5 * update x11/brisk-menu to 6.2Eric Turgeon2021-03-103-12/+29 * graphics/poppler: update to 21.03.0Tobias C. Berner2021-03-091-1/+1 * PyQt5: Update PyQt5 to 5.15.3, QScintilla2 to 2.12.0, py-qtbuilder to 1.9.0Loïc Bartoletti2021-03-081-1/+0 * x11/wayland-logout: update to 1.4Jan Beich2021-03-082-13/+17 * Remove redundant option descriptions that match the default onesTobias Kortkamp2021-03-082-4/+0 * Update xfce4-dashboard to 0.8.1Guido Falsi2021-03-053-9/+9 * x11/hs-xmobar: Update to 0.37Gleb Popov2021-03-052-11/+10 * Update KDE Release-Service releases to 20.12.3Tobias C. Berner2021-03-052-6/+6 * Update Linux CentOS ports to 7.9.2009.Tijl Coosemans2021-03-0513-39/+53 * Honor LOCALBASE in the xdm rc scriptMateusz Piotrowski2021-03-041-1/+1 * Ulauncher is graphical application launcher written in Python and GTK.Alexey Dokuchaev2021-03-045-0/+57 * x11/xpra: Fix packaging with Python 3.8Kai Knoblich2021-03-032-46/+46 * x11/mate-dock-applet: Fix pkg-plist issues with non-default Python versionsKai Knoblich2021-03-031-26/+26 * x11/workrave: Update to 1.10.44 and pass maintainership to submitterNeel Chauhan2021-03-033-5/+7 * Bump PORTREVISION on *-sbcl ports after lang/sbcl upgrade.Kirill Ponomarev2021-03-021-1/+1 * Import patch from upstream to fix key grabbing issues.Guido Falsi2021-03-023-22/+1325 * Update to version 2.0.7.Alexey Dokuchaev2021-03-012-4/+4 * Clean up some thingsTobias Kortkamp2021-02-281-3/+3 * Proposed changes by bapt@:Thierry Thomas2021-02-281-79/+39 * Clean up some thingsTobias Kortkamp2021-02-262-5/+1 * Chase r566595 and update Linux libraries and tools to version 460.56.Alexey Dokuchaev2021-02-267-21/+11 * Update NVidia mainline driver to version 460.56, which had:Alexey Dokuchaev2021-02-262-4/+4 * x11/foot: simplify terminfo supportJan Beich2021-02-251-5/+6 * x11/foot: expose terminfo support on -CURRENTJan Beich2021-02-251-0/+10 * x11/cde: Sadly, broken on all archs for headChris Rees2021-02-211-1/+1 * x11/xkb-switch: Update to 1.8.5Dmitri Goutnik2021-02-202-9/+5 * x11/alacritty: Update to 0.7.2Jan Beich2021-02-202-83/+82 * x11/cde: Still broken on head for i386Chris Rees2021-02-201-0/+1 * x11/xpra: Update to 4.0.6Gleb Popov2021-02-203-15/+4 * x11/x3270: Remove unneeded patchKevin Bowling2021-02-201-10/+0 * Unbreak fetch from git.sr.htJan Beich2021-02-193-3/+3 * Maintainer reset for jlaffayeYuri Victorovich2021-02-192-2/+2 * Unbreak fetch from git.sr.htJan Beich2021-02-184-11/+11 * x11/jgmenu: Update to 4.3.0Lewis Cook2021-02-182-5/+4 * x11/gnome-terminal: update to 3.38.3Tobias C. Berner2021-02-182-4/+4 * x11/yelp: update to 3.38.3Tobias C. Berner2021-02-182-4/+4 * Mark BROKEN on FreeBSD 13 and 14Antoine Brodin2021-02-171-0/+3 * x11/cde: Update to 2.3.2Chris Rees2021-02-177-57/+69 * x11/x3270: Add a pkg-message for fonts and high DPIKevin Bowling2021-02-161-0/+10 * x11/x3270: Fix manpage install and fix DBCS optionKevin Bowling2021-02-162-21/+23 * x11/x3270: Update the pkg-descrKevin Bowling2021-02-161-2/+7 * Update KDE Frameworks to 5.79Tobias C. Berner2021-02-1611-33/+33 * net/c3270: Make it a slave port of x11/x3270Kevin Bowling2021-02-163-46/+67 * x11/xdg-desktop-portal-wlr: update to 0.2.0Jan Beich2021-02-152-15/+4 * Update a few GNUstep ports:Neel Chauhan2021-02-154-4/+4 * lang/rust: Update to 1.50.0Mikael Urankar2021-02-145-2/+5 * x11/radare-cutter: update to 0.1.1Steve Wills2021-02-143-187/+188 * x11/foot: update to 1.6.4Jan Beich2021-02-132-9/+4 * x11/phosh: update to 0.8.1Jan Beich2021-02-133-33/+31 * x11/wezterm: unbreak on i386 via upstream fixJan Beich2021-02-132-2/+5 * Add compiler:c++11-lang to USES to fix build on GCC-based systems:Mark Linimon2021-02-121-1/+2 * x11/x3270: Remove two unneeded patchesKevin Bowling2021-02-122-21/+0 * x11/wezterm: simplify installJan Beich2021-02-121-5/+3 * When listing a directory as a target's order-only-prerequisite, there mustAlexey Dokuchaev2021-02-122-2/+10 * x11/wezterm: mark BROKEN on i386Jan Beich2021-02-121-0/+2 * Declare NSString pointer as `extern' to unbreak the build against modernAlexey Dokuchaev2021-02-111-3/+4 * New port: x11/screengrabJesper Schmitz Mouridsen2021-02-115-0/+62 * Update to 366Emanuel Haupt2021-02-113-21/+4 * x11/wezterm: add new portJan Beich2021-02-114-0/+1453 * x11/gromit-mpx: make summary similar to Arch/Gentoo/NixJan Beich2021-02-111-1/+1 * x11/gromit-mpx: add new portJan Beich2021-02-115-0/+70 * Submitted by: Nuno Teixeira <eduardo@FreeBSD.org> (maintainer)Nuno Teixeira2021-02-10