aboutsummaryrefslogtreecommitdiffstats
path: root/lang/python26
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2011-06-08 16:17:06 +0800
committerwen <wen@FreeBSD.org>2011-06-08 16:17:06 +0800
commit4b1fff1c10636b2003fc3e0a0190dbf56a58b105 (patch)
tree552ef25b5c43ce367e8c571f897e7a33e3fe31fc /lang/python26
parent9bc6e3301a431ce692e3a9fe40d3cdf7a80c9622 (diff)
downloadfreebsd-ports-graphics-4b1fff1c10636b2003fc3e0a0190dbf56a58b105.tar.gz
freebsd-ports-graphics-4b1fff1c10636b2003fc3e0a0190dbf56a58b105.tar.zst
freebsd-ports-graphics-4b1fff1c10636b2003fc3e0a0190dbf56a58b105.zip
- Update to 2.6.7
Diffstat (limited to 'lang/python26')
-rw-r--r--lang/python26/Makefile3
-rw-r--r--lang/python26/distinfo5
-rw-r--r--lang/python26/files/patch-CVE-2010-349341
-rw-r--r--lang/python26/pkg-plist4
4 files changed, 5 insertions, 48 deletions
diff --git a/lang/python26/Makefile b/lang/python26/Makefile
index f3bd63f4d4a..cef3f1d171c 100644
--- a/lang/python26/Makefile
+++ b/lang/python26/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= python26
-PORTVERSION= 2.6.6
-PORTREVISION= 1
+PORTVERSION= 2.6.7
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
diff --git a/lang/python26/distinfo b/lang/python26/distinfo
index 2deefda0612..cf0fb61390b 100644
--- a/lang/python26/distinfo
+++ b/lang/python26/distinfo
@@ -1,3 +1,2 @@
-MD5 (python/Python-2.6.6.tgz) = b2f209df270a33315e62c1ffac1937f0
-SHA256 (python/Python-2.6.6.tgz) = 372f66db46d773214e4619df1794a26449158f626138d4d2141a64c2f017fae1
-SIZE (python/Python-2.6.6.tgz) = 13318547
+SHA256 (python/Python-2.6.7.tgz) = a8093eace4cfd3e06b05f0deb5d765e3c6cec65908048640a8cadd7a948b3826
+SIZE (python/Python-2.6.7.tgz) = 13322372
diff --git a/lang/python26/files/patch-CVE-2010-3493 b/lang/python26/files/patch-CVE-2010-3493
deleted file mode 100644
index b8553d99339..00000000000
--- a/lang/python26/files/patch-CVE-2010-3493
+++ /dev/null
@@ -1,41 +0,0 @@
---- Lib/smtpd.py.orig 2011-03-05 13:51:22.000000000 +0000
-+++ Lib/smtpd.py 2011-03-05 13:52:42.000000000 +0000
-@@ -121,7 +121,15 @@
- self.__rcpttos = []
- self.__data = ''
- self.__fqdn = socket.getfqdn()
-- self.__peer = conn.getpeername()
-+ try:
-+ self.__peer = conn.getpeername()
-+ except socket.error as err:
-+ # a race condition may occur if the other end is closing
-+ # before we can get the peername
-+ self.close()
-+ if err.args[0] != errno.ENOTCONN:
-+ raise
-+ return
- print >> DEBUGSTREAM, 'Peer:', repr(self.__peer)
- self.push('220 %s %s' % (self.__fqdn, __version__))
- self.set_terminator('\r\n')
-@@ -291,7 +299,20 @@
- localaddr, remoteaddr)
-
- def handle_accept(self):
-- conn, addr = self.accept()
-+ try:
-+ conn, addr = self.accept()
-+ except TypeError:
-+ # sometimes accept() might return None
-+ return
-+ except socket.error as err:
-+ # ECONNABORTED might be thrown
-+ if err.args[0] != errno.ECONNABORTED:
-+ raise
-+ return
-+ else:
-+ # sometimes addr == None instead of (ip, port)
-+ if addr == None:
-+ return
- print >> DEBUGSTREAM, 'Incoming connection from %s' % repr(addr)
- channel = SMTPChannel(self, conn, addr)
-
diff --git a/lang/python26/pkg-plist b/lang/python26/pkg-plist
index f786de27c20..2b1db6a4cb3 100644
--- a/lang/python26/pkg-plist
+++ b/lang/python26/pkg-plist
@@ -697,9 +697,9 @@ lib/lib%%PYTHON_VERSION%%.so.1
%%PYTHON_LIBDIR%%/json/tool.py
%%PYTHON_LIBDIR%%/keyword.py
%%PYTHON_LIBDIR%%/lib2to3/Grammar.txt
-%%PYTHON_LIBDIR%%/lib2to3/Grammar2.6.6.final.0.pickle
+%%PYTHON_LIBDIR%%/lib2to3/Grammar2.6.7.final.0.pickle
%%PYTHON_LIBDIR%%/lib2to3/PatternGrammar.txt
-%%PYTHON_LIBDIR%%/lib2to3/PatternGrammar2.6.6.final.0.pickle
+%%PYTHON_LIBDIR%%/lib2to3/PatternGrammar2.6.7.final.0.pickle
%%PYTHON_LIBDIR%%/lib2to3/__init__.py
%%PYTHON_LIBDIR%%/lib2to3/fixer_base.py
%%PYTHON_LIBDIR%%/lib2to3/fixer_util.py