aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ruby-perl
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2000-08-13 04:09:41 +0800
committerknu <knu@FreeBSD.org>2000-08-13 04:09:41 +0800
commite932a87c5235b90fa671f5b453afd18c94f3b2f3 (patch)
tree7f470d6c370885834b1ad0e7ffcd9a38f0534974 /lang/ruby-perl
parent761a287d6d458a83abfd6ab90410b27c5cda14af (diff)
downloadfreebsd-ports-graphics-e932a87c5235b90fa671f5b453afd18c94f3b2f3.tar.gz
freebsd-ports-graphics-e932a87c5235b90fa671f5b453afd18c94f3b2f3.tar.zst
freebsd-ports-graphics-e932a87c5235b90fa671f5b453afd18c94f3b2f3.zip
Do The Right Thing. (R)
Overall changes: Use tabs instead of sequential spaces. Note Author as well as WWW in DESCR. Do not install examples when NOPORTDOCS. Make RUBY, RUBY_VER and RUBY_ARCH variables overridable. ruby-date2: share/doc/ruby/date2/examples/ -> share/examples/ruby/date2/cal.rb textproc/ruby-html-parser: databases/ruby-mysql: devel/ruby-optparse: devel/ruby-property: Install modules under lib/ruby/site_ruby/${RUBY_VER}/ instead of lib/ruby/site_ruby/ or lib/ruby/${RUBY_VER}/ textproc/ruby-rdtool: Install documents in .rd format too. Format optparse's rd file. (Since ruby-rdtool depends on optparse, it cannot be done during optparse's build process. So ruby-rdtool should take care of that when it is installed. :)
Diffstat (limited to 'lang/ruby-perl')
-rw-r--r--lang/ruby-perl/Makefile8
-rw-r--r--lang/ruby-perl/pkg-descr1
2 files changed, 5 insertions, 4 deletions
diff --git a/lang/ruby-perl/Makefile b/lang/ruby-perl/Makefile
index 26f55eabef9..c4f3236d7cd 100644
--- a/lang/ruby-perl/Makefile
+++ b/lang/ruby-perl/Makefile
@@ -24,9 +24,9 @@ PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
USE_PERL5= yes
-RUBY= ${LOCALBASE}/bin/ruby
-RUBY_VER= 1.4
-RUBY_ARCH= ${ARCH}-freebsd${OSREL}
+RUBY?= ${LOCALBASE}/bin/ruby
+RUBY_VER?= 1.4
+RUBY_ARCH?= ${ARCH}-freebsd${OSREL}
EXAMPLES= htmlparse.rb http.rb perllib.rb ping.rb \
test.rb xmlparser.rb
@@ -44,11 +44,11 @@ post-build:
post-install:
@cd ${WRKSRC}/Ruby; \
${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} install
+.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/examples/ruby/perl
.for f in ${EXAMPLES}
${INSTALL_DATA} ${WRKSRC}/samples/${f} ${PREFIX}/share/examples/ruby/perl/
.endfor
-.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/ruby/perl/ja
${INSTALL_DATA} ${WRKSRC}/README.ja ${PREFIX}/share/doc/ruby/perl/ja/
.endif
diff --git a/lang/ruby-perl/pkg-descr b/lang/ruby-perl/pkg-descr
index e9217e272b3..29827ca9dc3 100644
--- a/lang/ruby-perl/pkg-descr
+++ b/lang/ruby-perl/pkg-descr
@@ -2,4 +2,5 @@ This is a Ruby extension module to use the functions of Perl from Ruby.
You can also call Ruby functions back from within the Perl code.
+Author: Yoshida Masato <yoshidam@yoshidam.net>
WWW: http://www.bekkoame.ne.jp/~yoshidam/Ruby.html#perl