aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ruby16-shim-ruby18
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2004-02-27 03:20:09 +0800
committerknu <knu@FreeBSD.org>2004-02-27 03:20:09 +0800
commit6b623893ecdf432b2870e7f7218c1d3389d45ed9 (patch)
tree8c417f31d71dc4e8992042a279e9a110c7ec5190 /lang/ruby16-shim-ruby18
parent837d4c17a40e1e538f19d84ca605fc8b9c0e5a3d (diff)
downloadfreebsd-ports-graphics-6b623893ecdf432b2870e7f7218c1d3389d45ed9.tar.gz
freebsd-ports-graphics-6b623893ecdf432b2870e7f7218c1d3389d45ed9.tar.zst
freebsd-ports-graphics-6b623893ecdf432b2870e7f7218c1d3389d45ed9.zip
Change the default version of ruby to 1.8 for i386 as well, finally.
Always put a version suffix to the ruby name (no matter if ruby is the default version) to avoid mess in future. [Notes for i386 users] If you are a ruby developer and still want to stick with ruby 1.6 as default, please add RUBY_DEFAULT_VER=1.6 to /etc/make.conf. If you are a ruby developer and want to keep ruby 1.6 as default, please add RUBY_DEFAULT_VER=1.6 to /etc/make.conf. Otherwise, please run the following series of commands to migrate to ruby 1.8: 1) Reinstall portupgrade manually (and ruby 1.8 will be installed) pkg_delete portupgrade-\* (cd /usr/ports/sysutils/portupgrade; make install clean) 2) Reinstall everything that depends on ruby 1.6 (to use ruby 1.8) portupgrade -fr lang/ruby16 3) Reinstall ruby 1.8 (because the previous step kills symlinks) portupgrade -f lang/ruby18 4) Deinstall ruby 1.6 stuff (if you are paranoia) pkg_deinstall -ri lang/ruby16
Diffstat (limited to 'lang/ruby16-shim-ruby18')
-rw-r--r--lang/ruby16-shim-ruby18/Makefile2
-rw-r--r--lang/ruby16-shim-ruby18/pkg-plist6
2 files changed, 4 insertions, 4 deletions
diff --git a/lang/ruby16-shim-ruby18/Makefile b/lang/ruby16-shim-ruby18/Makefile
index 292afe44110..eac37967966 100644
--- a/lang/ruby16-shim-ruby18/Makefile
+++ b/lang/ruby16-shim-ruby18/Makefile
@@ -50,7 +50,7 @@ pre-install:
post-install:
.if ${RUBY_VER} == ${RUBY_DEFAULT_VER}
for f in ${INSTALLED_SCRIPTS}; do \
- ${LN} -f $${f}${RUBY_R} $${f}${_RUBY_SUFFIX}; \
+ ${LN} -f $${f}${RUBY_SUFFIX} $${f}${RUBY_R}; \
done
.endif
diff --git a/lang/ruby16-shim-ruby18/pkg-plist b/lang/ruby16-shim-ruby18/pkg-plist
index 8f9e1edbe96..60e87b19803 100644
--- a/lang/ruby16-shim-ruby18/pkg-plist
+++ b/lang/ruby16-shim-ruby18/pkg-plist
@@ -1,9 +1,9 @@
%%IF_DEFAULT%%bin/erb%%RUBY_R%%
-bin/erb%%_RUBY_SUFFIX%%
+bin/erb%%RUBY_SUFFIX%%
%%IF_DEFAULT%%bin/h2rb%%RUBY_R%%
-bin/h2rb%%_RUBY_SUFFIX%%
+bin/h2rb%%RUBY_SUFFIX%%
%%IF_DEFAULT%%bin/rdoc%%RUBY_R%%
-bin/rdoc%%_RUBY_SUFFIX%%
+bin/rdoc%%RUBY_SUFFIX%%
@comment features/ruby18
%%RUBY_SITEARCHLIBDIR%%/features/ruby18/file_ruby18.so
%%RUBY_SITEARCHLIBDIR%%/features/ruby18/io_ruby18.so