aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ruby18
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2007-04-05 16:13:48 +0800
committerpav <pav@FreeBSD.org>2007-04-05 16:13:48 +0800
commit2422ee3c4e977237bd697d7e96350c049ca24e50 (patch)
tree344b4c1e1c175c9787e622fff98a8ca7452ed243 /lang/ruby18
parentffe90d8ecf105b49f0bf818b08a1812f0e8bd706 (diff)
downloadfreebsd-ports-graphics-2422ee3c4e977237bd697d7e96350c049ca24e50.tar.gz
freebsd-ports-graphics-2422ee3c4e977237bd697d7e96350c049ca24e50.tar.zst
freebsd-ports-graphics-2422ee3c4e977237bd697d7e96350c049ca24e50.zip
- Hack around RUBY_PORTEPOCH being set later than PKGNAME suffix is determined
With hat: portmgr
Diffstat (limited to 'lang/ruby18')
-rw-r--r--lang/ruby18/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/lang/ruby18/Makefile b/lang/ruby18/Makefile
index 920998b6ce7..53ec1fedcb8 100644
--- a/lang/ruby18/Makefile
+++ b/lang/ruby18/Makefile
@@ -44,6 +44,9 @@ OPTIONS= PTHREADS "Enable pthreads support (may break some apps)" off \
.include <bsd.port.pre.mk>
+# PORTEPOCH hack
+_SUF2= ,${PORTEPOCH}
+
PKGNAMESUFFIX= #empty
CFLAGS+= ${PTHREAD_CFLAGS} # Keep this, else ruby will fail to load
LDFLAGS+= ${PTHREAD_LIBS} # libraries dependent op libpthread.