aboutsummaryrefslogtreecommitdiffstats
path: root/lang/ruby18
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-05-25 04:42:21 +0800
committerpav <pav@FreeBSD.org>2006-05-25 04:42:21 +0800
commit6d7ab21f5227270a6ed3e5452b34a77b31ce6bef (patch)
tree4f2342e120455d36a61c3caf44fad67bb8d40f9f /lang/ruby18
parentf6b1ef4f4d379b05b6655bcf9ef774c354ca25b7 (diff)
downloadfreebsd-ports-graphics-6d7ab21f5227270a6ed3e5452b34a77b31ce6bef.tar.gz
freebsd-ports-graphics-6d7ab21f5227270a6ed3e5452b34a77b31ce6bef.tar.zst
freebsd-ports-graphics-6d7ab21f5227270a6ed3e5452b34a77b31ce6bef.zip
- Revert previous commit, it broke ruby-gtk2
Reported by: mezz
Diffstat (limited to 'lang/ruby18')
-rw-r--r--lang/ruby18/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/lang/ruby18/Makefile b/lang/ruby18/Makefile
index 2d9072768da..51698d350b7 100644
--- a/lang/ruby18/Makefile
+++ b/lang/ruby18/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ruby
PORTVERSION= ${RUBY_PORTVERSION}
-PORTREVISION= 7
+PORTREVISION= 8
PORTEPOCH= 1
CATEGORIES= lang ruby ipv6
MASTER_SITES= ${MASTER_SITE_RUBY}
@@ -43,8 +43,6 @@ CONFIGURE_ARGS= ${RUBY_CONFIGURE_ARGS} \
.if defined(WITH_PTHREADS)
CONFIGURE_ARGS+=--enable-pthread
PKGNAMESUFFIX:= ${PKGNAMESUFFIX}+pthreads
-CONFIGURE_ENV= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}" \
- LIBS="${LIBS} ${PTHREAD_LIBS}"
.else
CONFIGURE_ARGS+=--disable-pthread
.endif
@@ -72,6 +70,9 @@ EXTRA_PATCHES= ${PATCHDIR}/extrapatch-eval.c
CONFIGURE_ARGS+= --enable-ipv6
.endif
+CONFIGURE_ENV= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}" \
+ LIBS="${LIBS} ${PTHREAD_LIBS}"
+
.if ${RUBY_VER} == ${RUBY_DEFAULT_VER}
MLINKS= ${RUBY_NAME}.1 ruby.1
IF_DEFAULT= ""