aboutsummaryrefslogtreecommitdiffstats
path: root/lang/seed7
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2011-11-24 17:05:43 +0800
committergahr <gahr@FreeBSD.org>2011-11-24 17:05:43 +0800
commit62f595e862ac74a922e2659b18668e4a30e2e8da (patch)
tree1f523e85df2b0043b5374c1f9b12c812a0050765 /lang/seed7
parente9d27d6c527c5e036cb51df07d1a3f18e9f7e140 (diff)
downloadfreebsd-ports-graphics-62f595e862ac74a922e2659b18668e4a30e2e8da.tar.gz
freebsd-ports-graphics-62f595e862ac74a922e2659b18668e4a30e2e8da.tar.zst
freebsd-ports-graphics-62f595e862ac74a922e2659b18668e4a30e2e8da.zip
- second attempt to respect CC and CFLAGS
Feature safe: yes
Diffstat (limited to 'lang/seed7')
-rw-r--r--lang/seed7/Makefile2
-rw-r--r--lang/seed7/files/patch-makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/lang/seed7/Makefile b/lang/seed7/Makefile
index 593fa1c0d5c..b7c8badb647 100644
--- a/lang/seed7/Makefile
+++ b/lang/seed7/Makefile
@@ -39,7 +39,7 @@ post-patch:
${WRKSRC}/../prg/chk_all.sd7
do-configure:
- (cd ${WRKSRC} && ${GMAKE} depend)
+ (cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} depend)
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/../bin/hi ${PREFIX}/bin
diff --git a/lang/seed7/files/patch-makefile b/lang/seed7/files/patch-makefile
index 26c0209c69c..7305962f152 100644
--- a/lang/seed7/files/patch-makefile
+++ b/lang/seed7/files/patch-makefile
@@ -5,7 +5,7 @@
# CFLAGS = -O2 -g -Wall -Wstrict-prototypes -Winline -Wconversion -Wshadow -Wpointer-arith -ftrapv
# CFLAGS = -O2 -g -x c++ -Wall -Winline -Wconversion -Wshadow -Wpointer-arith
-CFLAGS = -O2 -g -Wall -Wstrict-prototypes -Winline -Wconversion -Wshadow -Wpointer-arith
-+CFLAGS += -O2 -g -Wall -Wstrict-prototypes -Winline -Wconversion -Wshadow -Wpointer-arith -I%%LOCALBASE%%/include
++CFLAGS += -Wall -Wstrict-prototypes -Winline -Wconversion -Wshadow -Wpointer-arith -I%%LOCALBASE%%/include
# CFLAGS = -O2 -g -std=c99 -Wall -Wstrict-prototypes -Winline -Wconversion -Wshadow -Wpointer-arith
# CFLAGS = -O2 -g -Wall -Winline -Wconversion -Wshadow -Wpointer-arith
# CFLAGS = -O2 -g -Wall