aboutsummaryrefslogtreecommitdiffstats
path: root/lang/smalltalk
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2005-07-26 23:50:19 +0800
committervs <vs@FreeBSD.org>2005-07-26 23:50:19 +0800
commit73de3f9013a13e9bc2e194f4439350660ce3b7c5 (patch)
treeb4f401362d8dc137f65c7c46c3f8940c8a35b216 /lang/smalltalk
parenta3f1b2bb7bdfa4b59e32641c30e5709b55ac9f78 (diff)
downloadfreebsd-ports-graphics-73de3f9013a13e9bc2e194f4439350660ce3b7c5.tar.gz
freebsd-ports-graphics-73de3f9013a13e9bc2e194f4439350660ce3b7c5.tar.zst
freebsd-ports-graphics-73de3f9013a13e9bc2e194f4439350660ce3b7c5.zip
- Add dependency on devel/libexecinfo for missing backtrace_*() symbols
- Use OPTIONS and enable Tcl/Tk by default [me] PR: ports/83905 Submitted by: Konstantin Belousov
Diffstat (limited to 'lang/smalltalk')
-rw-r--r--lang/smalltalk/Makefile9
-rw-r--r--lang/smalltalk/files/patch-libgst_Makefile.in14
2 files changed, 20 insertions, 3 deletions
diff --git a/lang/smalltalk/Makefile b/lang/smalltalk/Makefile
index 351f896b0ea..e5582426cfb 100644
--- a/lang/smalltalk/Makefile
+++ b/lang/smalltalk/Makefile
@@ -15,7 +15,10 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= GNU Smalltalk
-LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm
+LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm \
+ execinfo.1:${PORTSDIR}/devel/libexecinfo
+
+OPTIONS= TCLTK "Enable Tcl/Tk binding" on
USE_REINPLACE= yes
USE_GMAKE= yes
@@ -32,6 +35,8 @@ INFO= gst gst-base gst-libs
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
+.include <bsd.port.pre.mk>
+
.if defined(WITH_TCLTK)
LIB_DEPENDS+= tk84.1:${PORTSDIR}/x11-toolkits/tk84
CONFIGURE_ARGS+= --with-tcl=${LOCALBASE}/lib/tcl8.4 \
@@ -42,8 +47,6 @@ CONFIGURE_ARGS+= --with-tcl=no
PLIST_SUB+= TCLTK="@comment "
.endif
-.include <bsd.port.pre.mk>
-
.if ${ARCH} != "i386" && ${ARCH} != "alpha"
BROKEN= "Does not compile on !i386 and !alpha"
.endif
diff --git a/lang/smalltalk/files/patch-libgst_Makefile.in b/lang/smalltalk/files/patch-libgst_Makefile.in
new file mode 100644
index 00000000000..b91c25fd3fe
--- /dev/null
+++ b/lang/smalltalk/files/patch-libgst_Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- libgst/Makefile.in.orig
++++ libgst/Makefile.in
+@@ -212,7 +212,7 @@
+
+ # definitions for libgst.la
+ libgst_la_LIBADD = $(top_builddir)/lib-src/library.la $(LIBSIGSEGV) \
+- @LIBLTDL@ @LIBSNPRINTFV@ @LIBREADLINE@ @LIBGMP@
++ @LIBLTDL@ @LIBSNPRINTFV@ @LIBREADLINE@ @LIBGMP@ -lexecinfo
+
+
+ libgst_la_LDFLAGS = -version-info $(VERSION_INFO)