aboutsummaryrefslogtreecommitdiffstats
path: root/lang/spl
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2004-05-31 19:24:06 +0800
committerperky <perky@FreeBSD.org>2004-05-31 19:24:06 +0800
commit739c4681ce7c7d3c49aa912a2e181e5d17457ddb (patch)
tree76440ed4313336d9d9fdd2f5b7e2bf2e2d5a21fb /lang/spl
parentf945c1a8123b60373ee1e455db6b82d951f2faa2 (diff)
downloadfreebsd-ports-graphics-739c4681ce7c7d3c49aa912a2e181e5d17457ddb.tar.gz
freebsd-ports-graphics-739c4681ce7c7d3c49aa912a2e181e5d17457ddb.tar.zst
freebsd-ports-graphics-739c4681ce7c7d3c49aa912a2e181e5d17457ddb.zip
Install on install phases and unmark BROKEN.
Diffstat (limited to 'lang/spl')
-rw-r--r--lang/spl/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/lang/spl/Makefile b/lang/spl/Makefile
index 48c49206ae2..5f532df2002 100644
--- a/lang/spl/Makefile
+++ b/lang/spl/Makefile
@@ -14,8 +14,6 @@ MASTER_SITES= http://shakespearelang.sourceforge.net/download/
MAINTAINER= perky@FreeBSD.org
COMMENT= The Shakespeare programming language
-BROKEN= Installs during build phase
-
USE_BISON= yes
USE_GMAKE= yes
USE_REINPLACE= yes
@@ -24,13 +22,13 @@ ALL_EXAMPLES= Makefile fibonacci.spl fibonacci2.spl guess.spl hello.spl \
primes.spl reverse.spl shakesbeer.spl
post-patch:
- @for f in ${WRKSRC}/Makefile ${WRKSRC}/examples/Makefile; do \
- ${REINPLACE_CMD} -i "" -e 's,= gcc,?= gcc,' -e 's,^CCFLAGS.*,CFLAGS += -Wall,' \
- -e 's,CCFLAGS,CFLAGS,g' -e 's,^SPLPATH =.*,SPLPATH =${PREFIX},g' \
- -e 's, spl/, ${PREFIX}/,g' $$f; \
- done
+.for f in . examples
+ ${REINPLACE_CMD} -e 's,= gcc,?= gcc,' -e 's,^CCFLAGS.*,CFLAGS += -Wall,' \
+ -e 's,CCFLAGS,CFLAGS,g' ${WRKSRC}/${f}/Makefile
+.endfor
-post-install:
+do-install:
+ ${TAR} -C ${WRKSRC}/spl -cf - . | ${TAR} -C ${PREFIX} -xf -
.if !defined(NOPORTDOCS)
${MKDIR} ${EXAMPLESDIR}
cd ${WRKSRC}/examples && ${INSTALL_DATA} ${ALL_EXAMPLES} ${EXAMPLESDIR}