aboutsummaryrefslogtreecommitdiffstats
path: root/lang/tinycobol
diff options
context:
space:
mode:
authorsf <sf@FreeBSD.org>2003-07-14 10:53:03 +0800
committersf <sf@FreeBSD.org>2003-07-14 10:53:03 +0800
commit971087c2b4d6b0b917e3fac3ac1334b04f7c9907 (patch)
tree7181a8316bbb1b7be4386d9173b3c6ace07025da /lang/tinycobol
parent0cc85c09b55a7d94ca1d7c16c8eedae091f2840c (diff)
downloadfreebsd-ports-graphics-971087c2b4d6b0b917e3fac3ac1334b04f7c9907.tar.gz
freebsd-ports-graphics-971087c2b4d6b0b917e3fac3ac1334b04f7c9907.tar.zst
freebsd-ports-graphics-971087c2b4d6b0b917e3fac3ac1334b04f7c9907.zip
get rid of libgnugetopt dependency for -CURRENT,
use USE_GETOPT_LONG instead.
Diffstat (limited to 'lang/tinycobol')
-rw-r--r--lang/tinycobol/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/lang/tinycobol/Makefile b/lang/tinycobol/Makefile
index 9388d95814d..1eacf6b7b92 100644
--- a/lang/tinycobol/Makefile
+++ b/lang/tinycobol/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tinycobol
PORTVERSION= 0.59
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= tiny-cobol
@@ -14,19 +15,20 @@ MASTER_SITE_SUBDIR= tiny-cobol
MAINTAINER= patrick@freebsd.org
COMMENT= A tiny COBOL compiler for IA32 platforms
-LIB_DEPENDS= db2.0:${PORTSDIR}/databases/db2 \
- gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+LIB_DEPENDS= db2.0:${PORTSDIR}/databases/db2
ONLY_FOR_ARCHS= i386
+USE_GETOPT_LONG=yes
HAS_CONFIGURE= yes
USE_BISON= yes
USE_GMAKE= yes
CONFIGURE_ARGS= "--with-readline"
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt ${LDFLAGS}" \
- CPPFLAGS="-I${LOCALBASE}/include"
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-MAN1= htcobol.1 htcobf2f.1 htcobolpp.1
+MAN1= htcobol.1 htcobf2f.1 htcobolpp.1
pre-install: