aboutsummaryrefslogtreecommitdiffstats
path: root/lang/x10/Makefile
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2011-12-27 03:15:23 +0800
committerpawel <pawel@FreeBSD.org>2011-12-27 03:15:23 +0800
commitf32565fb5ed38bafe2edb8fa3eb6eaaa06e5a42d (patch)
tree1c1e264718765006d5829fe2ddd4876108deec96 /lang/x10/Makefile
parent5f234aa756d3f879cb3a6ca604fac32927394d11 (diff)
downloadfreebsd-ports-graphics-f32565fb5ed38bafe2edb8fa3eb6eaaa06e5a42d.tar.gz
freebsd-ports-graphics-f32565fb5ed38bafe2edb8fa3eb6eaaa06e5a42d.tar.zst
freebsd-ports-graphics-f32565fb5ed38bafe2edb8fa3eb6eaaa06e5a42d.zip
IBM Research is developing the open-source X10 programming language to
provide a programming model that can address the architectural challenge of multiples cores, hardware accelerators, clusters, and supercomputers in a manner that provides scalable performance in a productive manner. WWW: http://x10-lang.org PR: ports/163269 Submitted by: Jason Bacon <jwbacon@tds.net>
Diffstat (limited to 'lang/x10/Makefile')
-rw-r--r--lang/x10/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/lang/x10/Makefile b/lang/x10/Makefile
new file mode 100644
index 00000000000..1a91fa41692
--- /dev/null
+++ b/lang/x10/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: x10
+# Date created: 2011-10-12
+# Whom: Jason Bacon <jwbacon@tds.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= x10
+PORTVERSION= 2.2.1
+CATEGORIES= lang devel java
+MASTER_SITES= SF
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= jwbacon@tds.net
+COMMENT= Object-oriented parallal programming language
+
+USE_BZIP2= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.5+
+USE_ANT= yes
+
+USE_LDCONFIG= ${PREFIX}/stdlib/lib
+
+# Can't have USE_GMAKE with USE_ANT: They imply conflicting do-build actions.
+BUILD_DEPENDS+= gmake:${PORTSDIR}/devel/gmake \
+ bash:${PORTSDIR}/shells/bash
+
+WRKSRC= ${WRKDIR}/x10.dist
+
+post-patch:
+ ${REINPLACE_CMD} -e 's/value="make"/value="gmake"/g' \
+ ${WRKDIR}/x10.runtime/build.xml
+
+do-install:
+.for f in X10Launcher apgas precommit x10 x10c x10c++ x10j
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/${f} ${PREFIX}/bin
+.endfor
+ ${MKDIR} ${PREFIX}/stdlib
+ ${INSTALL_DATA} ${WRKSRC}/etc/* ${PREFIX}/etc
+ ${INSTALL_DATA} ${WRKSRC}/include/* ${PREFIX}/include
+ ${INSTALL_DATA} ${WRKSRC}/lib/* ${PREFIX}/lib
+ ${CP} -R ${WRKSRC}/stdlib/* ${PREFIX}/stdlib
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/samples/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>