aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorbms <bms@FreeBSD.org>2008-01-18 22:42:01 +0800
committerbms <bms@FreeBSD.org>2008-01-18 22:42:01 +0800
commit068e47c3fe290c1f6c52ad686c77299a6e9d3e47 (patch)
tree666fc6bc23885e159afa328a3bca3b439fdfbba2 /lang
parentf2912acca5a2cefe9fdd61b1a1738c78ee4f06b6 (diff)
downloadfreebsd-ports-graphics-068e47c3fe290c1f6c52ad686c77299a6e9d3e47.tar.gz
freebsd-ports-graphics-068e47c3fe290c1f6c52ad686c77299a6e9d3e47.tar.zst
freebsd-ports-graphics-068e47c3fe290c1f6c52ad686c77299a6e9d3e47.zip
Add port of libstdc++ documentation for the version shipping with
gcc 3.4.x versions. Supersedes lang/stldoc. Note: Versioning convention must be explicit in port name as different versions of this library exist.
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/libstdc++_stldoc_3.4.0/.pkg-descr.swpbin0 -> 12288 bytes
-rw-r--r--lang/libstdc++_stldoc_3.4.0/Makefile33
-rw-r--r--lang/libstdc++_stldoc_3.4.0/distinfo3
-rw-r--r--lang/libstdc++_stldoc_3.4.0/pkg-descr6
5 files changed, 43 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index c8d42607b42..9946fb942ef 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -135,6 +135,7 @@
SUBDIR += lafontaine
SUBDIR += libjit
SUBDIR += librep
+ SUBDIR += libstdc++_stldoc_3.4.0
SUBDIR += libutils
SUBDIR += linux-j
SUBDIR += linux-libg2c
diff --git a/lang/libstdc++_stldoc_3.4.0/.pkg-descr.swp b/lang/libstdc++_stldoc_3.4.0/.pkg-descr.swp
new file mode 100644
index 00000000000..255b060513d
--- /dev/null
+++ b/lang/libstdc++_stldoc_3.4.0/.pkg-descr.swp
Binary files differ
diff --git a/lang/libstdc++_stldoc_3.4.0/Makefile b/lang/libstdc++_stldoc_3.4.0/Makefile
new file mode 100644
index 00000000000..954958bd099
--- /dev/null
+++ b/lang/libstdc++_stldoc_3.4.0/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: libstdc++_stldoc
+# Date created: 18th January 2008
+# Whom: Bruce M. Simpson
+#
+# $FreeBSD$
+#
+# Note: Specific versions of this documentation exist for each version
+# of the libstdc++ library, note versioning convention below.
+#
+
+PORTNAME= libstdc++_stldoc_3.4.0
+PORTVERSION= 20040609
+CATEGORIES= lang devel
+MASTER_SITES= ${MASTER_SITE_GCC}
+MASTER_SITE_SUBDIR= \
+ libstdc++/doxygen
+DISTNAME= libstdc++-html-USERS-3.4.0
+
+MAINTAINER= bms@FreeBSD.org
+COMMENT= GNU libstdc++ API documentation
+
+USE_BZIP2= yes
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+PORTDOCS= *
+
+do-install:
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/html_user/* ${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/lang/libstdc++_stldoc_3.4.0/distinfo b/lang/libstdc++_stldoc_3.4.0/distinfo
new file mode 100644
index 00000000000..c502486ed54
--- /dev/null
+++ b/lang/libstdc++_stldoc_3.4.0/distinfo
@@ -0,0 +1,3 @@
+MD5 (libstdc++-html-USERS-3.4.0.tar.bz2) = 0862e3b0eb0cb5212ee36d54f5f02d45
+SHA256 (libstdc++-html-USERS-3.4.0.tar.bz2) = 9cb4d260e45fd7cadd926537cbc11ae79f4e9e8ac661d6b2efc4f43f7c8c374c
+SIZE (libstdc++-html-USERS-3.4.0.tar.bz2) = 2476410
diff --git a/lang/libstdc++_stldoc_3.4.0/pkg-descr b/lang/libstdc++_stldoc_3.4.0/pkg-descr
new file mode 100644
index 00000000000..f01446aa4b5
--- /dev/null
+++ b/lang/libstdc++_stldoc_3.4.0/pkg-descr
@@ -0,0 +1,6 @@
+This is the source / API documentation for the GNU C++ Library.
+
+It includes documentation of the implementation of the C++ Standard
+Template Library as shipped with GNU C++.
+
+WWW: http://gcc.gnu.org/onlinedocs/libstdc++/latest-doxygen/index.html