aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-07-24 11:33:36 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-07-24 11:33:36 +0800
commit10be04f0aa8a06afe5ab583ce984312c420e2db1 (patch)
tree36adb8e195e1f6a75e62bffcbfe24abf879d706f /lang
parent5ab87d1085e182bfbd6679990a3974606e307aa7 (diff)
downloadfreebsd-ports-graphics-10be04f0aa8a06afe5ab583ce984312c420e2db1.tar.gz
freebsd-ports-graphics-10be04f0aa8a06afe5ab583ce984312c420e2db1.tar.zst
freebsd-ports-graphics-10be04f0aa8a06afe5ab583ce984312c420e2db1.zip
- Add LICENSE
- Add OPTIONS: AUTHOR - Fix *_DEPENDS - Bump PORTREVISION for dependency change PR: ports/159015 Submitted by: milki <milki@rescomp.berkeley.edu> (maintainer)
Diffstat (limited to 'lang')
-rw-r--r--lang/p5-TryCatch/Makefile38
-rw-r--r--lang/p5-TryCatch/pkg-descr2
2 files changed, 29 insertions, 11 deletions
diff --git a/lang/p5-TryCatch/Makefile b/lang/p5-TryCatch/Makefile
index 764c65420ae..fc05ef02c8b 100644
--- a/lang/p5-TryCatch/Makefile
+++ b/lang/p5-TryCatch/Makefile
@@ -7,6 +7,7 @@
PORTNAME= TryCatch
PORTVERSION= 1.003000
+PORTREVISION= 1
CATEGORIES= lang perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:ASH
@@ -15,23 +16,40 @@ PKGNAMEPREFIX= p5-
MAINTAINER= milki@rescomp.berkeley.edu
COMMENT= First class try catch semantics for Perl, without source filters
-BUILD_DEPENDS= p5-ExtUtils-Depends>=0.302:${PORTSDIR}/devel/p5-ExtUtils-Depends \
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-ExtUtils-Depends>=0.302:${PORTSDIR}/devel/p5-ExtUtils-Depends
+RUN_DEPENDS= p5-B-Hooks-EndOfScope>=0.08:${PORTSDIR}/devel/p5-B-Hooks-EndOfScope \
p5-B-Hooks-OP-Check>=0.18:${PORTSDIR}/devel/p5-B-Hooks-OP-Check \
- p5-B-Hooks-OP-PPAddr>=0.03:${PORTSDIR}/devel/p5-B-Hooks-OP-PPAddr
-RUN_DEPENDS= p5-Parse-Method-Signatures>=1.003012:${PORTSDIR}/devel/p5-Parse-Method-Signatures \
- p5-B-Hooks-EndOfScope>=0.08:${PORTSDIR}/devel/p5-B-Hooks-EndOfScope \
+ p5-B-Hooks-OP-PPAddr>=0.03:${PORTSDIR}/devel/p5-B-Hooks-OP-PPAddr \
p5-Devel-Declare>=0.005007:${PORTSDIR}/devel/p5-Devel-Declare \
p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
p5-MooseX-Types>=0:${PORTSDIR}/devel/p5-MooseX-Types \
+ p5-Parse-Method-Signatures>=1.003012:${PORTSDIR}/devel/p5-Parse-Method-Signatures \
p5-Scope-Upper>=0.06:${PORTSDIR}/devel/p5-Scope-Upper \
- p5-Variable-Magic>=0.28:${PORTSDIR}/devel/p5-Variable-Magic \
p5-Sub-Exporter>=0.979:${PORTSDIR}/devel/p5-Sub-Exporter \
- p5-XSLoader>=0:${PORTSDIR}/devel/p5-XSLoader
-TEST_DEPENDS= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple \
- p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
+ p5-Variable-Magic>=0.28:${PORTSDIR}/devel/p5-Variable-Magic
+
+TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
+
+OPTIONS= AUTHOR "Include dependencies for AUTHORING" off
PERL_CONFIGURE= 5.8.1+
-MAN3= TryCatch.3
+MAN3= TryCatch.3
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_AUTHOR)
+BUILD_DEPENDS+= p5-B-Hooks-OP-Check>=0.18:${PORTSDIR}/devel/p5-B-Hooks-OP-Check \
+ p5-B-Hooks-OP-PPAddr>=0.03:${PORTSDIR}/devel/p5-B-Hooks-OP-PPAddr
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/lang/p5-TryCatch/pkg-descr b/lang/p5-TryCatch/pkg-descr
index f46efdf5fb0..ac1b71e1654 100644
--- a/lang/p5-TryCatch/pkg-descr
+++ b/lang/p5-TryCatch/pkg-descr
@@ -4,4 +4,4 @@ or C++). The standard method of using eval {}; if ($@) {} is often prone
to subtle bugs, primarily that its far too easy to stomp on the error in
error handlers. And also eval/if isn't the nicest idiom.
-WWW: http://search.cpan.org/dist/TryCatch
+WWW: http://search.cpan.org/dist/TryCatch/