aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2005-10-14 14:00:49 +0800
committerale <ale@FreeBSD.org>2005-10-14 14:00:49 +0800
commit13cd97451adbdeb302e0254f64c1bef429e172ba (patch)
tree0943f4570acb6b0ebfcd3664f8b999598552d92f /lang
parent6a4888ea368191e7664e4fb8a9a1c96b3f5b1658 (diff)
downloadfreebsd-ports-graphics-13cd97451adbdeb302e0254f64c1bef429e172ba.tar.gz
freebsd-ports-graphics-13cd97451adbdeb302e0254f64c1bef429e172ba.tar.zst
freebsd-ports-graphics-13cd97451adbdeb302e0254f64c1bef429e172ba.zip
AMD64 fixes:
- fix crypto part again [1] - fix object serialization [2] PR: ports/86885 [2] Submitted by: André Böhm <andre@gaarden.net> [2], Claus Guttesen <kometen@gmail.com> [1]
Diffstat (limited to 'lang')
-rw-r--r--lang/php5/Makefile2
-rw-r--r--lang/php5/files/patch-configure28
-rw-r--r--lang/php5/files/patch-ext_standard_incomplete_class.c20
-rw-r--r--lang/php5/files/patch-ext_standard_php_incomplete_class.h22
-rw-r--r--lang/php53/Makefile2
-rw-r--r--lang/php53/files/patch-configure28
-rw-r--r--lang/php53/files/patch-ext_standard_incomplete_class.c20
-rw-r--r--lang/php53/files/patch-ext_standard_php_incomplete_class.h22
8 files changed, 114 insertions, 30 deletions
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index 924dec8c239..1674ca5c05a 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -7,7 +7,7 @@
PORTNAME= php5
PORTVERSION= 5.0.5
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP:S,$,:release,} \
http://downloads.php.net/ilia/:rc \
diff --git a/lang/php5/files/patch-configure b/lang/php5/files/patch-configure
index a1219ce6bda..ecd4454dd4f 100644
--- a/lang/php5/files/patch-configure
+++ b/lang/php5/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Sun Apr 3 11:42:50 2005
-+++ configure Wed Apr 6 16:41:26 2005
-@@ -2805,7 +2805,7 @@
+--- configure.orig Mon Sep 5 13:16:17 2005
++++ configure Fri Oct 14 07:48:01 2005
+@@ -2890,7 +2890,7 @@
save_LIBS=$LIBS
if test -n "$ac_cv_pthreads_lib"; then
@@ -9,7 +9,7 @@
fi
if test -n "$ac_cv_pthreads_cflags"; then
-@@ -11201,7 +11201,7 @@
+@@ -11285,7 +11285,7 @@
if test "$enable_maintainer_zts" = "yes"; then
if test -n "$ac_cv_pthreads_lib"; then
@@ -18,7 +18,7 @@
fi
if test -n "$ac_cv_pthreads_cflags"; then
-@@ -11218,8 +11218,6 @@
+@@ -11302,8 +11302,6 @@
case $host_alias in
*solaris*)
PTHREAD_FLAGS="-D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT";;
@@ -27,8 +27,8 @@
*linux*)
PTHREAD_FLAGS=-D_REENTRANT;;
*aix*)
-@@ -80628,6 +80626,10 @@
- #line 80629 "configure"
+@@ -88384,6 +88382,10 @@
+ #line 88385 "configure"
#include "confdefs.h"
+#if HAVE_UNISTD_H
@@ -38,8 +38,8 @@
#if HAVE_CRYPT_H
#include <crypt.h>
#endif
-@@ -80685,6 +80687,10 @@
- #line 80686 "configure"
+@@ -88441,6 +88443,10 @@
+ #line 88442 "configure"
#include "confdefs.h"
+#if HAVE_UNISTD_H
@@ -49,8 +49,8 @@
#if HAVE_CRYPT_H
#include <crypt.h>
#endif
-@@ -80742,6 +80748,10 @@
- #line 80743 "configure"
+@@ -88498,6 +88504,10 @@
+ #line 88499 "configure"
#include "confdefs.h"
+#if HAVE_UNISTD_H
@@ -60,8 +60,8 @@
#if HAVE_CRYPT_H
#include <crypt.h>
#endif
-@@ -80837,6 +80847,10 @@
- #line 80838 "configure"
+@@ -88593,6 +88603,10 @@
+ #line 88594 "configure"
#include "confdefs.h"
+#if HAVE_UNISTD_H
@@ -71,7 +71,7 @@
#if HAVE_CRYPT_H
#include <crypt.h>
#endif
-@@ -92387,7 +92401,7 @@
+@@ -101571,7 +101585,7 @@
save_LIBS=$LIBS
if test -n "$ac_cv_pthreads_lib"; then
diff --git a/lang/php5/files/patch-ext_standard_incomplete_class.c b/lang/php5/files/patch-ext_standard_incomplete_class.c
new file mode 100644
index 00000000000..f4b5c40e4c3
--- /dev/null
+++ b/lang/php5/files/patch-ext_standard_incomplete_class.c
@@ -0,0 +1,20 @@
+--- ext/standard/incomplete_class.c.orig Fri Oct 14 07:49:19 2005
++++ ext/standard/incomplete_class.c Fri Oct 14 07:50:12 2005
+@@ -122,7 +122,7 @@
+
+ /* {{{ php_lookup_class_name
+ */
+-char *php_lookup_class_name(zval *object, size_t *nlen)
++char *php_lookup_class_name(zval *object, zend_uint *nlen)
+ {
+ zval **val;
+ char *retval = NULL;
+@@ -144,7 +144,7 @@
+
+ /* {{{ php_store_class_name
+ */
+-void php_store_class_name(zval *object, const char *name, size_t len)
++void php_store_class_name(zval *object, const char *name, zend_uint len)
+ {
+ zval *val;
+ TSRMLS_FETCH();
diff --git a/lang/php5/files/patch-ext_standard_php_incomplete_class.h b/lang/php5/files/patch-ext_standard_php_incomplete_class.h
new file mode 100644
index 00000000000..936036a1b56
--- /dev/null
+++ b/lang/php5/files/patch-ext_standard_php_incomplete_class.h
@@ -0,0 +1,22 @@
+--- ext/standard/php_incomplete_class.h.orig Fri Oct 14 07:50:22 2005
++++ ext/standard/php_incomplete_class.h Fri Oct 14 07:50:59 2005
+@@ -42,7 +42,7 @@
+
+ #define PHP_CLASS_ATTRIBUTES \
+ char *class_name; \
+- size_t name_len; \
++ zend_uint name_len; \
+ zend_bool free_class_name = 0; \
+ zend_bool incomplete_class = 0
+
+@@ -55,8 +55,8 @@
+
+ zend_class_entry *php_create_incomplete_class(TSRMLS_D);
+
+-char *php_lookup_class_name(zval *object, size_t *nlen);
+-void php_store_class_name(zval *object, const char *name, size_t len);
++char *php_lookup_class_name(zval *object, zend_uint *nlen);
++void php_store_class_name(zval *object, const char *name, zend_uint len);
+
+ #ifdef __cplusplus
+ };
diff --git a/lang/php53/Makefile b/lang/php53/Makefile
index 924dec8c239..1674ca5c05a 100644
--- a/lang/php53/Makefile
+++ b/lang/php53/Makefile
@@ -7,7 +7,7 @@
PORTNAME= php5
PORTVERSION= 5.0.5
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP:S,$,:release,} \
http://downloads.php.net/ilia/:rc \
diff --git a/lang/php53/files/patch-configure b/lang/php53/files/patch-configure
index a1219ce6bda..ecd4454dd4f 100644
--- a/lang/php53/files/patch-configure
+++ b/lang/php53/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Sun Apr 3 11:42:50 2005
-+++ configure Wed Apr 6 16:41:26 2005
-@@ -2805,7 +2805,7 @@
+--- configure.orig Mon Sep 5 13:16:17 2005
++++ configure Fri Oct 14 07:48:01 2005
+@@ -2890,7 +2890,7 @@
save_LIBS=$LIBS
if test -n "$ac_cv_pthreads_lib"; then
@@ -9,7 +9,7 @@
fi
if test -n "$ac_cv_pthreads_cflags"; then
-@@ -11201,7 +11201,7 @@
+@@ -11285,7 +11285,7 @@
if test "$enable_maintainer_zts" = "yes"; then
if test -n "$ac_cv_pthreads_lib"; then
@@ -18,7 +18,7 @@
fi
if test -n "$ac_cv_pthreads_cflags"; then
-@@ -11218,8 +11218,6 @@
+@@ -11302,8 +11302,6 @@
case $host_alias in
*solaris*)
PTHREAD_FLAGS="-D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT";;
@@ -27,8 +27,8 @@
*linux*)
PTHREAD_FLAGS=-D_REENTRANT;;
*aix*)
-@@ -80628,6 +80626,10 @@
- #line 80629 "configure"
+@@ -88384,6 +88382,10 @@
+ #line 88385 "configure"
#include "confdefs.h"
+#if HAVE_UNISTD_H
@@ -38,8 +38,8 @@
#if HAVE_CRYPT_H
#include <crypt.h>
#endif
-@@ -80685,6 +80687,10 @@
- #line 80686 "configure"
+@@ -88441,6 +88443,10 @@
+ #line 88442 "configure"
#include "confdefs.h"
+#if HAVE_UNISTD_H
@@ -49,8 +49,8 @@
#if HAVE_CRYPT_H
#include <crypt.h>
#endif
-@@ -80742,6 +80748,10 @@
- #line 80743 "configure"
+@@ -88498,6 +88504,10 @@
+ #line 88499 "configure"
#include "confdefs.h"
+#if HAVE_UNISTD_H
@@ -60,8 +60,8 @@
#if HAVE_CRYPT_H
#include <crypt.h>
#endif
-@@ -80837,6 +80847,10 @@
- #line 80838 "configure"
+@@ -88593,6 +88603,10 @@
+ #line 88594 "configure"
#include "confdefs.h"
+#if HAVE_UNISTD_H
@@ -71,7 +71,7 @@
#if HAVE_CRYPT_H
#include <crypt.h>
#endif
-@@ -92387,7 +92401,7 @@
+@@ -101571,7 +101585,7 @@
save_LIBS=$LIBS
if test -n "$ac_cv_pthreads_lib"; then
diff --git a/lang/php53/files/patch-ext_standard_incomplete_class.c b/lang/php53/files/patch-ext_standard_incomplete_class.c
new file mode 100644
index 00000000000..f4b5c40e4c3
--- /dev/null
+++ b/lang/php53/files/patch-ext_standard_incomplete_class.c
@@ -0,0 +1,20 @@
+--- ext/standard/incomplete_class.c.orig Fri Oct 14 07:49:19 2005
++++ ext/standard/incomplete_class.c Fri Oct 14 07:50:12 2005
+@@ -122,7 +122,7 @@
+
+ /* {{{ php_lookup_class_name
+ */
+-char *php_lookup_class_name(zval *object, size_t *nlen)
++char *php_lookup_class_name(zval *object, zend_uint *nlen)
+ {
+ zval **val;
+ char *retval = NULL;
+@@ -144,7 +144,7 @@
+
+ /* {{{ php_store_class_name
+ */
+-void php_store_class_name(zval *object, const char *name, size_t len)
++void php_store_class_name(zval *object, const char *name, zend_uint len)
+ {
+ zval *val;
+ TSRMLS_FETCH();
diff --git a/lang/php53/files/patch-ext_standard_php_incomplete_class.h b/lang/php53/files/patch-ext_standard_php_incomplete_class.h
new file mode 100644
index 00000000000..936036a1b56
--- /dev/null
+++ b/lang/php53/files/patch-ext_standard_php_incomplete_class.h
@@ -0,0 +1,22 @@
+--- ext/standard/php_incomplete_class.h.orig Fri Oct 14 07:50:22 2005
++++ ext/standard/php_incomplete_class.h Fri Oct 14 07:50:59 2005
+@@ -42,7 +42,7 @@
+
+ #define PHP_CLASS_ATTRIBUTES \
+ char *class_name; \
+- size_t name_len; \
++ zend_uint name_len; \
+ zend_bool free_class_name = 0; \
+ zend_bool incomplete_class = 0
+
+@@ -55,8 +55,8 @@
+
+ zend_class_entry *php_create_incomplete_class(TSRMLS_D);
+
+-char *php_lookup_class_name(zval *object, size_t *nlen);
+-void php_store_class_name(zval *object, const char *name, size_t len);
++char *php_lookup_class_name(zval *object, zend_uint *nlen);
++void php_store_class_name(zval *object, const char *name, zend_uint len);
+
+ #ifdef __cplusplus
+ };