aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2007-01-20 06:08:32 +0800
committeritetcu <itetcu@FreeBSD.org>2007-01-20 06:08:32 +0800
commit171bb98da22e38d7ae5ac9db3c2b4595d6757f3d (patch)
treeb9f0d99c95c5ecd45604ac157ee5f31a374c24bb /lang
parent8f808685f635d0bfd5852ac9e38d1fcd60bb7c5e (diff)
downloadfreebsd-ports-graphics-171bb98da22e38d7ae5ac9db3c2b4595d6757f3d.tar.gz
freebsd-ports-graphics-171bb98da22e38d7ae5ac9db3c2b4595d6757f3d.tar.zst
freebsd-ports-graphics-171bb98da22e38d7ae5ac9db3c2b4595d6757f3d.zip
The Gambit programming system is a full implementation of the Scheme
language which conforms to the R4RS and IEEE Scheme standards. It consists of two main programs: gsi, the Gambit Scheme interpreter, and gsc, the Gambit Scheme compiler. Gambit-C is a version of the Gambit programming system in which the compiler generates portable C code, making the whole Gambit-C system and the programs compiled with it easily portable to many computer architectures for which a C compiler is available. With appropriate declarations in the source code the executable programs generated by the compiler run roughly as fast as equivalent C programs. WWW: http://www.iro.umontreal.ca/~gambit/ PR: ports/107405 Submitted by: Rob Zinkov
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/gambc/Makefile29
-rw-r--r--lang/gambc/distinfo3
-rw-r--r--lang/gambc/pkg-descr13
-rw-r--r--lang/gambc/pkg-plist28
-rw-r--r--lang/gambit-c/Makefile29
-rw-r--r--lang/gambit-c/distinfo3
-rw-r--r--lang/gambit-c/pkg-descr13
-rw-r--r--lang/gambit-c/pkg-plist28
9 files changed, 147 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index c4f349b3c1c..2f3c162c326 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -68,6 +68,7 @@
SUBDIR += fpc-utils
SUBDIR += freetxl
SUBDIR += gambas
+ SUBDIR += gambc
SUBDIR += gauche
SUBDIR += gawk
SUBDIR += gcc-objc
diff --git a/lang/gambc/Makefile b/lang/gambc/Makefile
new file mode 100644
index 00000000000..b023bbf5f64
--- /dev/null
+++ b/lang/gambc/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: gambc
+# Date created: 28 December 2006
+# Whom: Rob Zinkov
+#
+# $FreeBSD$
+#
+
+PORTNAME= gambc
+DISTVERSION= 4.0b20
+CATEGORIES= lang
+MASTER_SITES= http://www.iro.umontreal.ca/~gambit/download/gambit/4.0/source/
+
+MAINTAINER= rzinkov@gmail.com
+COMMENT= Gambit programming system where the compiler generates portable C code
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+CONFIGURE_ARGS= --enable-single-host --enable-gcc-opts
+
+INFO= gambit-c
+
+pre-configure:
+ @${REINPLACE_CMD} -e 's|/4.0b20||' ${WRKSRC}/configure
+
+post-configure:
+ @${MV} ${WRKSRC}/makefile ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/lang/gambc/distinfo b/lang/gambc/distinfo
new file mode 100644
index 00000000000..919c6fec79c
--- /dev/null
+++ b/lang/gambc/distinfo
@@ -0,0 +1,3 @@
+MD5 (gambc-4.0b20.tar.gz) = fb58e5bd67e52d88797672cbf04d34b3
+SHA256 (gambc-4.0b20.tar.gz) = 2ab46aead25b82b06d8f8dbe59b33896d32055f8340df2522ecfc11844ebb5a8
+SIZE (gambc-4.0b20.tar.gz) = 7025146
diff --git a/lang/gambc/pkg-descr b/lang/gambc/pkg-descr
new file mode 100644
index 00000000000..6dab4995bf4
--- /dev/null
+++ b/lang/gambc/pkg-descr
@@ -0,0 +1,13 @@
+The Gambit programming system is a full implementation of the Scheme
+language which conforms to the R4RS and IEEE Scheme standards. It
+consists of two main programs: gsi, the Gambit Scheme interpreter, and
+gsc, the Gambit Scheme compiler.
+
+Gambit-C is a version of the Gambit programming system in which the
+compiler generates portable C code, making the whole Gambit-C system
+and the programs compiled with it easily portable to many computer
+architectures for which a C compiler is available. With appropriate
+declarations in the source code the executable programs generated by
+the compiler run roughly as fast as equivalent C programs.
+
+WWW: http://www.iro.umontreal.ca/~gambit/
diff --git a/lang/gambc/pkg-plist b/lang/gambc/pkg-plist
new file mode 100644
index 00000000000..09186a47f63
--- /dev/null
+++ b/lang/gambc/pkg-plist
@@ -0,0 +1,28 @@
+bin/six
+bin/gsc
+bin/gsc-cc-o
+bin/gsc-script
+bin/gsi
+bin/gsi-script
+bin/scheme-ieee-1178-1990
+bin/scheme-r4rs
+bin/scheme-r5rs
+bin/scheme-srfi-0
+bin/six-script
+current
+doc/gambit-c.html
+doc/gambit-c.pdf
+doc/gambit-c.txt
+include/gambit.h
+lib/_gambc.c
+lib/digest#.scm
+lib/digest.scm
+lib/gambit#.scm
+lib/libgambc.a
+lib/r4rs#.scm
+lib/r5rs#.scm
+share/emacs/site-lisp/gambit.el
+share/nls/POSIX
+share/nls/en_US.US-ASCII
+syntax-case.scm
+@dirrm doc
diff --git a/lang/gambit-c/Makefile b/lang/gambit-c/Makefile
new file mode 100644
index 00000000000..b023bbf5f64
--- /dev/null
+++ b/lang/gambit-c/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: gambc
+# Date created: 28 December 2006
+# Whom: Rob Zinkov
+#
+# $FreeBSD$
+#
+
+PORTNAME= gambc
+DISTVERSION= 4.0b20
+CATEGORIES= lang
+MASTER_SITES= http://www.iro.umontreal.ca/~gambit/download/gambit/4.0/source/
+
+MAINTAINER= rzinkov@gmail.com
+COMMENT= Gambit programming system where the compiler generates portable C code
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+CONFIGURE_ARGS= --enable-single-host --enable-gcc-opts
+
+INFO= gambit-c
+
+pre-configure:
+ @${REINPLACE_CMD} -e 's|/4.0b20||' ${WRKSRC}/configure
+
+post-configure:
+ @${MV} ${WRKSRC}/makefile ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/lang/gambit-c/distinfo b/lang/gambit-c/distinfo
new file mode 100644
index 00000000000..919c6fec79c
--- /dev/null
+++ b/lang/gambit-c/distinfo
@@ -0,0 +1,3 @@
+MD5 (gambc-4.0b20.tar.gz) = fb58e5bd67e52d88797672cbf04d34b3
+SHA256 (gambc-4.0b20.tar.gz) = 2ab46aead25b82b06d8f8dbe59b33896d32055f8340df2522ecfc11844ebb5a8
+SIZE (gambc-4.0b20.tar.gz) = 7025146
diff --git a/lang/gambit-c/pkg-descr b/lang/gambit-c/pkg-descr
new file mode 100644
index 00000000000..6dab4995bf4
--- /dev/null
+++ b/lang/gambit-c/pkg-descr
@@ -0,0 +1,13 @@
+The Gambit programming system is a full implementation of the Scheme
+language which conforms to the R4RS and IEEE Scheme standards. It
+consists of two main programs: gsi, the Gambit Scheme interpreter, and
+gsc, the Gambit Scheme compiler.
+
+Gambit-C is a version of the Gambit programming system in which the
+compiler generates portable C code, making the whole Gambit-C system
+and the programs compiled with it easily portable to many computer
+architectures for which a C compiler is available. With appropriate
+declarations in the source code the executable programs generated by
+the compiler run roughly as fast as equivalent C programs.
+
+WWW: http://www.iro.umontreal.ca/~gambit/
diff --git a/lang/gambit-c/pkg-plist b/lang/gambit-c/pkg-plist
new file mode 100644
index 00000000000..09186a47f63
--- /dev/null
+++ b/lang/gambit-c/pkg-plist
@@ -0,0 +1,28 @@
+bin/six
+bin/gsc
+bin/gsc-cc-o
+bin/gsc-script
+bin/gsi
+bin/gsi-script
+bin/scheme-ieee-1178-1990
+bin/scheme-r4rs
+bin/scheme-r5rs
+bin/scheme-srfi-0
+bin/six-script
+current
+doc/gambit-c.html
+doc/gambit-c.pdf
+doc/gambit-c.txt
+include/gambit.h
+lib/_gambc.c
+lib/digest#.scm
+lib/digest.scm
+lib/gambit#.scm
+lib/libgambc.a
+lib/r4rs#.scm
+lib/r5rs#.scm
+share/emacs/site-lisp/gambit.el
+share/nls/POSIX
+share/nls/en_US.US-ASCII
+syntax-case.scm
+@dirrm doc