aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2012-03-12 13:22:46 +0800
committermaho <maho@FreeBSD.org>2012-03-12 13:22:46 +0800
commit17e613ba645d907307f8f2eabb9c2d3dfa132539 (patch)
tree2326b82b2edf598a4189299a8927d0871535ebb3 /lang
parentfa450bb0f7870f48758b88f1fdddf0b9db93215a (diff)
downloadfreebsd-ports-graphics-17e613ba645d907307f8f2eabb9c2d3dfa132539.tar.gz
freebsd-ports-graphics-17e613ba645d907307f8f2eabb9c2d3dfa132539.tar.zst
freebsd-ports-graphics-17e613ba645d907307f8f2eabb9c2d3dfa132539.zip
Add WANT_LEAD_0 knob.
Submitted by: Ted Hatfield <ted@io-tx.com> Feature safe: yes
Diffstat (limited to 'lang')
-rw-r--r--lang/f2c/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/lang/f2c/Makefile b/lang/f2c/Makefile
index 8a2aefe6ad9..8e4dcb6c54d 100644
--- a/lang/f2c/Makefile
+++ b/lang/f2c/Makefile
@@ -24,6 +24,9 @@ GUNZIP_CMD= minigzip -d
USE_GMAKE= yes
USE_LDCONFIG= yes
+OPTIONS= LEAD_0 "Print with leading zeros" Off
+
+
# Set FCNAME to the name of the Fortran 77 / F2C wrapper.
FCNAME?= fc
PLIST_SUB= FCNAME=${FCNAME}
@@ -50,6 +53,12 @@ pre-patch:
pre-configure:
${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' ${WRKSRC}/fc
+.if !defined(WITHOUT_LEAD_0)
+ ${REINPLACE_CMD} -e 's|CFLAGS += -fPIC|CFLAGS += -fPIC -DWANT_LEAD_0|' ${WRKSRC}/libf2c/Makefile
+ ${REINPLACE_CMD} -e 's|#CFLAGS = -O|CFLAGS = -O -DWANT_LEAD_0|' ${WRKSRC}/src/Makefile
+.endif
+
+
do-build:
@${ECHO_MSG} "===> Building f2c..."