aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-11-07 17:12:58 +0800
committermarcus <marcus@FreeBSD.org>2003-11-07 17:12:58 +0800
commit264cdcd7a6bead083ad3106f86fb0744dedb57f5 (patch)
tree1a018b24ee2f215bd6917d868f44c8f904dda8bf /lang
parent8ea77b67d66da4a3b085568e881b2aab1f559c32 (diff)
downloadfreebsd-ports-graphics-264cdcd7a6bead083ad3106f86fb0744dedb57f5.tar.gz
freebsd-ports-graphics-264cdcd7a6bead083ad3106f86fb0744dedb57f5.tar.zst
freebsd-ports-graphics-264cdcd7a6bead083ad3106f86fb0744dedb57f5.zip
Use the new Apache bits from bsd.port.mk.
Submitted by: dinoex
Diffstat (limited to 'lang')
-rw-r--r--lang/eperl/Makefile2
-rw-r--r--lang/php4/Makefile9
-rw-r--r--lang/php5/Makefile8
-rw-r--r--lang/php53/Makefile8
4 files changed, 13 insertions, 14 deletions
diff --git a/lang/eperl/Makefile b/lang/eperl/Makefile
index eb7ce49a267..89e8648f25b 100644
--- a/lang/eperl/Makefile
+++ b/lang/eperl/Makefile
@@ -22,7 +22,7 @@ COMMENT= Embedded Perl 5 Language
#INSTALL_ALSO_AS_SSSL= yes
.if defined(INSTALL_ALSO_AS_SSSL)
-RUN_DEPENDS= ${PREFIX}/etc/apache/srm.conf:${PORTSDIR}/www/apache
+RUN_DEPENDS= ${PREFIX}/etc/apache/srm.conf:${PORTSDIR}/${APACHE_PORT}
.endif
USE_PERL5= yes
diff --git a/lang/php4/Makefile b/lang/php4/Makefile
index 7223038f6c8..fbcb8abc0cb 100644
--- a/lang/php4/Makefile
+++ b/lang/php4/Makefile
@@ -522,21 +522,20 @@ CONFIGURE_ARGS+=--with-zlib=yes
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_APACHE)
-APXS?= ${LOCALBASE}/sbin/apxs
.if exists(${LOCALBASE}/include/apache2/apr.h)
WITH_APACHE2= yes
.endif
.if defined(WITH_APACHE2)
-APACHE_PORT?= ${PORTSDIR}/www/apache2
+APACHE_PORT?= www/apache2
CONFIGURE_ARGS+=--with-apxs2=${APXS}
SAPI_FILE= libexec/apache2/libphp4.so
.else
-APACHE_PORT?= ${PORTSDIR}/www/apache13
+APACHE_PORT?= www/apache13
CONFIGURE_ARGS+=--with-apxs=${APXS}
SAPI_FILE= libexec/apache/libphp4.so
.endif
-BUILD_DEPENDS+= ${APXS}:${APACHE_PORT}
-RUN_DEPENDS+= ${APXS}:${APACHE_PORT}
+BUILD_DEPENDS+= ${APXS}:${PORTSDIR}/${APACHE_PORT}
+RUN_DEPENDS+= ${APXS}:${PORTSDIR}/${APACHE_PORT}
.endif
PLIST_SUB+= SAPI_FILE=${SAPI_FILE} \
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index 13723599a53..9588ecdd0e2 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -513,16 +513,16 @@ APXS?= ${LOCALBASE}/sbin/apxs
WITH_APACHE2= yes
.endif
.if defined(WITH_APACHE2)
-APACHE_PORT?= ${PORTSDIR}/www/apache2
+APACHE_PORT?= www/apache2
CONFIGURE_ARGS+=--with-apxs2=${APXS}
SAPI_FILE= libexec/apache2/libphp5.so
.else
-APACHE_PORT?= ${PORTSDIR}/www/apache13
+APACHE_PORT?= www/apache13
CONFIGURE_ARGS+=--with-apxs=${APXS}
SAPI_FILE= libexec/apache/libphp5.so
.endif
-BUILD_DEPENDS+= ${APXS}:${APACHE_PORT}
-RUN_DEPENDS+= ${APXS}:${APACHE_PORT}
+BUILD_DEPENDS+= ${APXS}:${PORTSDIR}/${APACHE_PORT}
+RUN_DEPENDS+= ${APXS}:${PORTSDIR}/${APACHE_PORT}
.endif
PLIST_SUB+= SAPI_FILE=${SAPI_FILE} \
diff --git a/lang/php53/Makefile b/lang/php53/Makefile
index 13723599a53..9588ecdd0e2 100644
--- a/lang/php53/Makefile
+++ b/lang/php53/Makefile
@@ -513,16 +513,16 @@ APXS?= ${LOCALBASE}/sbin/apxs
WITH_APACHE2= yes
.endif
.if defined(WITH_APACHE2)
-APACHE_PORT?= ${PORTSDIR}/www/apache2
+APACHE_PORT?= www/apache2
CONFIGURE_ARGS+=--with-apxs2=${APXS}
SAPI_FILE= libexec/apache2/libphp5.so
.else
-APACHE_PORT?= ${PORTSDIR}/www/apache13
+APACHE_PORT?= www/apache13
CONFIGURE_ARGS+=--with-apxs=${APXS}
SAPI_FILE= libexec/apache/libphp5.so
.endif
-BUILD_DEPENDS+= ${APXS}:${APACHE_PORT}
-RUN_DEPENDS+= ${APXS}:${APACHE_PORT}
+BUILD_DEPENDS+= ${APXS}:${PORTSDIR}/${APACHE_PORT}
+RUN_DEPENDS+= ${APXS}:${PORTSDIR}/${APACHE_PORT}
.endif
PLIST_SUB+= SAPI_FILE=${SAPI_FILE} \