aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-03-08 19:32:11 +0800
committerbapt <bapt@FreeBSD.org>2013-03-08 19:32:11 +0800
commit385eac9654e9de3b90ce25e1efffa8c08a547655 (patch)
tree9c130b083139cc77280c7e96cc9cea75a84d2d4c /lang
parentf2d169546a0f3c0e7fb3d21a855ac4b44aae5036 (diff)
downloadfreebsd-ports-graphics-385eac9654e9de3b90ce25e1efffa8c08a547655.tar.gz
freebsd-ports-graphics-385eac9654e9de3b90ce25e1efffa8c08a547655.tar.zst
freebsd-ports-graphics-385eac9654e9de3b90ce25e1efffa8c08a547655.zip
Convert USE_BISON to USES= bison
It brings bison as a build dependency in case it is set the following way: USES= bison or USES= bison:build it brings bison as a run dependency in case it is set the following way: USES= bison:run it brings bison both as a run and build dependency in case it the set the following way: USES= bison:both While here trim some headers Convert some USE_GNOME= gnomehack to USES= pathfix
Diffstat (limited to 'lang')
-rw-r--r--lang/basic256/Makefile2
-rw-r--r--lang/gcc/Makefile2
-rw-r--r--lang/gcc34/Makefile9
-rw-r--r--lang/gcc42/Makefile9
-rw-r--r--lang/gcc44/Makefile9
-rw-r--r--lang/gcc46/Makefile2
-rw-r--r--lang/gcc47/Makefile2
-rw-r--r--lang/gcc48/Makefile2
-rw-r--r--lang/gdc/Makefile8
-rw-r--r--lang/gnat/Makefile10
-rw-r--r--lang/harbour/Makefile8
-rw-r--r--lang/hla/Makefile9
-rw-r--r--lang/hugs/Makefile8
-rw-r--r--lang/maude/Makefile8
-rw-r--r--lang/mono/Makefile4
-rw-r--r--lang/ohugs/Makefile7
-rw-r--r--lang/parrot/Makefile2
-rw-r--r--lang/pike76/Makefile2
-rw-r--r--lang/pike78/Makefile2
-rw-r--r--lang/ptoc/Makefile8
-rw-r--r--lang/q/Makefile2
-rw-r--r--lang/rakudo/Makefile2
-rw-r--r--lang/spl/Makefile8
-rw-r--r--lang/vala/Makefile4
-rw-r--r--lang/yabasic/Makefile8
25 files changed, 40 insertions, 97 deletions
diff --git a/lang/basic256/Makefile b/lang/basic256/Makefile
index 9d6c7c53993..86b3682d613 100644
--- a/lang/basic256/Makefile
+++ b/lang/basic256/Makefile
@@ -18,7 +18,7 @@ BUILD_DEPENDS= espeak:${PORTSDIR}/audio/espeak \
WRKSRC= ${WRKDIR}
-USE_BISON= build
+USES= bison
USE_SDL= sdl mixer
USE_QT4= corelib gui network xml webkit moc_build qmake_build rcc_build uic_build
USE_DOS2UNIX= yes
diff --git a/lang/gcc/Makefile b/lang/gcc/Makefile
index 8b13cad3d0c..c0cdeead508 100644
--- a/lang/gcc/Makefile
+++ b/lang/gcc/Makefile
@@ -30,7 +30,7 @@ GCC_VERSION= ${PORTVERSION:C/(.+)\.[0-9]{8}/\1/}
SUFFIX= ${PORTVERSION:C/([0-9]+).([0-9]+).*/\1\2/}
ONLY_FOR_ARCHS= amd64 i386 ia64 powerpc sparc64
USE_BINUTILS= yes
-USE_BISON= build
+USES= bison
USE_BZIP2= yes
USE_GMAKE= yes
USE_ICONV= yes
diff --git a/lang/gcc34/Makefile b/lang/gcc34/Makefile
index e06390a18e3..a5eca33842f 100644
--- a/lang/gcc34/Makefile
+++ b/lang/gcc34/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: egcs
-# Date created: 9 Jan 1998
-# Whom: John Polstra <jdp@polstra.com>
-#
+# Created by: John Polstra <jdp@polstra.com>
# $FreeBSD$
-#
PORTNAME= gcc
PORTVERSION= 3.4.6
@@ -23,7 +18,7 @@ COMMENT= GNU Compiler Collection 3.4
SUFFIX= 34
LATEST_LINK= gcc${SUFFIX}${PKGNAMESUFFIX}
-USE_BISON= build
+USES= bison
USE_BZIP2= yes
USE_GMAKE= yes
USE_ICONV= yes
diff --git a/lang/gcc42/Makefile b/lang/gcc42/Makefile
index bc9aba3e005..2cf116f1494 100644
--- a/lang/gcc42/Makefile
+++ b/lang/gcc42/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: gcc42
-# Date created: 2005-12-11
-# Whom: Gerald Pfeifer <gerald@FreeBSD.org>
-#
+# Created by: Gerald Pfeifer <gerald@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= gcc
PORTVERSION= 4.2.5.20090325
@@ -28,7 +23,7 @@ VERSIONSTRING= ${PORTVERSION:C/([0-9]+\.[0-9]+).*\.([0-9]+)/\1-\2/}
SUFFIX= ${PORTVERSION:C/([0-9]+).([0-9]+).*/\1\2/}
LATEST_LINK= gcc${SUFFIX}${PKGNAMESUFFIX}
NOT_FOR_ARCHS= arm powerpc
-USE_BISON= build
+USES= bison
USE_BZIP2= yes
USE_GCC= any
USE_GMAKE= yes
diff --git a/lang/gcc44/Makefile b/lang/gcc44/Makefile
index d18a514d568..212ee36613d 100644
--- a/lang/gcc44/Makefile
+++ b/lang/gcc44/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: gcc44
-# Date created: 2008-03-01
-# Whom: Gerald Pfeifer <gerald@FreeBSD.org>
-#
+# Created by: Gerald Pfeifer <gerald@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= gcc
PORTVERSION= 4.4.7
@@ -27,7 +22,7 @@ SUFFIX= ${PORTVERSION:C/([0-9]+).([0-9]+).*/\1\2/}
LATEST_LINK= gcc${SUFFIX}${PKGNAMESUFFIX}
ONLY_FOR_ARCHS= amd64 i386 sparc64
USE_BINUTILS= yes
-USE_BISON= build
+USES= bison
USE_BZIP2= yes
USE_GCC= any
USE_GMAKE= yes
diff --git a/lang/gcc46/Makefile b/lang/gcc46/Makefile
index 680840415cb..7e393d92004 100644
--- a/lang/gcc46/Makefile
+++ b/lang/gcc46/Makefile
@@ -31,7 +31,7 @@ SUFFIX= ${PORTVERSION:C/([0-9]+).([0-9]+).*/\1\2/}
LATEST_LINK= gcc${SUFFIX}${PKGNAMESUFFIX}
ONLY_FOR_ARCHS= amd64 i386 ia64 powerpc sparc64
USE_BINUTILS= yes
-USE_BISON= build
+USES= bison
USE_BZIP2= yes
USE_GMAKE= yes
USE_ICONV= yes
diff --git a/lang/gcc47/Makefile b/lang/gcc47/Makefile
index c9b407a1cb7..16f35d211c2 100644
--- a/lang/gcc47/Makefile
+++ b/lang/gcc47/Makefile
@@ -29,7 +29,7 @@ SUFFIX= ${PORTVERSION:C/([0-9]+).([0-9]+).*/\1\2/}
LATEST_LINK= gcc${SUFFIX}${PKGNAMESUFFIX}
ONLY_FOR_ARCHS= amd64 i386 powerpc powerpc64 sparc64
USE_BINUTILS= yes
-USE_BISON= build
+USES= bison
USE_BZIP2= yes
USE_GMAKE= yes
USE_ICONV= yes
diff --git a/lang/gcc48/Makefile b/lang/gcc48/Makefile
index d97c6b2cb26..7a0bde30429 100644
--- a/lang/gcc48/Makefile
+++ b/lang/gcc48/Makefile
@@ -29,7 +29,7 @@ SUFFIX= ${PORTVERSION:C/([0-9]+).([0-9]+).*/\1\2/}
LATEST_LINK= gcc${SUFFIX}${PKGNAMESUFFIX}
ONLY_FOR_ARCHS= amd64 i386 powerpc powerpc64 sparc64
USE_BINUTILS= yes
-USE_BISON= build
+USES= bison
USE_BZIP2= yes
USE_GMAKE= yes
USE_ICONV= yes
diff --git a/lang/gdc/Makefile b/lang/gdc/Makefile
index ce742a21fd4..01cb808a03b 100644
--- a/lang/gdc/Makefile
+++ b/lang/gdc/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: D Front End for GCC
-# Date created: 18 November 2004
-# Whom: Masanori OZAWA (ozawa@ongs.co.jp)
-#
+# Created by: Masanori OZAWA (ozawa@ongs.co.jp)
# $FreeBSD$
-#
PORTNAME= gdc
PORTVERSION= 0.24
@@ -23,7 +19,7 @@ ONLY_FOR_ARCHS= i386 amd64
BROKEN= fails to build
-USE_BISON= build
+USES= bison
USE_BZIP2= yes
USE_GMAKE= yes
USE_PERL5= yes
diff --git a/lang/gnat/Makefile b/lang/gnat/Makefile
index 8fae7e2e37f..77e549c2b4d 100644
--- a/lang/gnat/Makefile
+++ b/lang/gnat/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: GNU Ada gnat
-# Date created: Sat Mar 18 02:16:45 1995
-# Whom: hsu
-# Porter (original): nils@guru.ims.uni-stuttgart.de
-# Porter (version 3): maurice@serc.rmit.edu.au
-#
+# Created by: hsu, nils@guru.ims.uni-stuttgart.de, maurice@serc.rmit.edu.au
# $FreeBSD$
#
# Note:
@@ -12,7 +7,6 @@
# conflict with other gcc based products. Standard names can be provided
# using symbolic links.
-PORTNAME= gnat
PORTVERSION= 2010
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_LOCAL:S/$/:boot/}
@@ -31,7 +25,7 @@ LICENSE= GPLv3 LGPL3
ONLY_FOR_ARCHS= i386
USE_GMAKE= yes
-USE_BISON= build
+USES= bison
USE_ICONV= yes
USE_PERL5_BUILD= yes
diff --git a/lang/harbour/Makefile b/lang/harbour/Makefile
index 8ef0def7081..0af4fbf796a 100644
--- a/lang/harbour/Makefile
+++ b/lang/harbour/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Harbour
-# Date created: 9 May 2003
-# Whom: David G. Holm <harbour@netfang.net>
-#
+# Created by: David G. Holm <harbour@netfang.net>
# $FreeBSD$
-#
PORTNAME= harbour
PORTVERSION= 3.0.0
@@ -32,7 +28,7 @@ PORTDOCS= *.txt *.hbd NEWS INSTALL TODO COPYING ChangeLog
MAKE_JOBS_SAFE= yes
-USE_BISON= build
+USES= bison
USE_GMAKE= yes
USE_OPENSSL= yes
USE_LDCONFIG= ${LOCALBASE}/lib/harbour
diff --git a/lang/hla/Makefile b/lang/hla/Makefile
index feb7c6d928d..c81bd8e3a8c 100644
--- a/lang/hla/Makefile
+++ b/lang/hla/Makefile
@@ -1,10 +1,5 @@
-# vim: ts=8
-# New ports collection Makefile for: hla
-# Date created: 29 May 2008
-# Whom: gahr
-#
+# Created by: gahr
# $FreeBSD$
-#
PORTNAME= hla
PORTVERSION= 1.103
@@ -24,7 +19,7 @@ MAINTAINER= gahr@FreeBSD.org
COMMENT= High Level Assembly
USE_ZIP= yes
-USE_BISON= build
+USES= bison
WRKSRC= ${WRKDIR}/hlasrc/trunk/trunk
MAKEFILE= makefile.bsd
diff --git a/lang/hugs/Makefile b/lang/hugs/Makefile
index a90439edaa3..06af0d33487 100644
--- a/lang/hugs/Makefile
+++ b/lang/hugs/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: hugs
-# Date created: 22 September 1997
-# Whom: Torsten Teg Grust (Torsten.Grust@uni-konstanz.de)
-#
+# Created by: Torsten Teg Grust (Torsten.Grust@uni-konstanz.de)
# $FreeBSD$
-#
PORTNAME= hugs98
PORTVERSION= 200609
@@ -21,7 +17,7 @@ WRKSRC= ${WRKDIR}/${DISTNAME}
#OPTIONS= HUGS_OPENGL "OpenGL/GLUT support" off
HUGS_DATE= Sep2006
-USE_BISON= build
+USES= bison
USE_GMAKE= yes
GNU_CONFIGURE= yes
#CONFIGURE_ARGS+= --prefix=${PREFIX} --enable-ffi
diff --git a/lang/maude/Makefile b/lang/maude/Makefile
index 36bad1e5657..4f5d599fe3b 100644
--- a/lang/maude/Makefile
+++ b/lang/maude/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: maude
-# Date created: 25 Mar 2005
-# Whom: Rick van der Zwet <rick@wzoeterwoude.net>
-#
+# Created by: Rick van der Zwet <rick@wzoeterwoude.net>
# $FreeBSD$
-#
PORTNAME= maude
PORTVERSION= 2.6
@@ -19,7 +15,7 @@ LIB_DEPENDS= bdd:${PORTSDIR}/science/buddy \
gmp:${PORTSDIR}/math/gmp \
sigsegv:${PORTSDIR}/devel/libsigsegv
-USE_BISON= build
+USES= bison
USE_AUTOTOOLS= aclocal autoheader automake
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/lang/mono/Makefile b/lang/mono/Makefile
index 22e906c0e51..1d3ecb63db6 100644
--- a/lang/mono/Makefile
+++ b/lang/mono/Makefile
@@ -14,8 +14,8 @@ BUILD_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser \
bash:${PORTSDIR}/shells/bash
USE_BZIP2= yes
-USE_BISON= build
-USE_GNOME= gnomehack glib20
+USES= bison pathfix
+USE_GNOME= glib20
USE_GMAKE= yes
USE_PERL5_BUILD=yes
GNU_CONFIGURE= yes
diff --git a/lang/ohugs/Makefile b/lang/ohugs/Makefile
index 325b7143618..ea1642c7e0b 100644
--- a/lang/ohugs/Makefile
+++ b/lang/ohugs/Makefile
@@ -1,8 +1,5 @@
-# New ports collection makefile for: ohugs
-# Date created: 03.03.03
-# Whom: Steffen Mazanek <steffen.mazanek@unibw-muenchen.de>
+# Created by: Steffen Mazanek <steffen.mazanek@unibw-muenchen.de>
# $FreeBSD$
-#
PORTNAME= ohugs
PORTVERSION= 0.5
@@ -25,7 +22,7 @@ LIB_DEPENDS= Tix8.4.3.0:${PORTSDIR}/x11-toolkits/tix
WRKSRC= ${WRKDIR}/${DISTNAME:S/.src//}
BUILD_WRKSRC= ${WRKSRC}/src
-USE_BISON= build
+USES= bison
LDFLAGS+= -lm -lreadline -ltermcap
.if empty(PORT_OPTIONS:MX11)
USE_TK= 84+
diff --git a/lang/parrot/Makefile b/lang/parrot/Makefile
index 732b332019c..b38c1f07025 100644
--- a/lang/parrot/Makefile
+++ b/lang/parrot/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= gmp:${PORTSDIR}/math/gmp \
MAKE_JOBS_UNSAFE= yes
USE_BZIP2= yes
-USE_BISON= build
+USES= bison
USE_PERL5= yes
USE_GMAKE= yes
diff --git a/lang/pike76/Makefile b/lang/pike76/Makefile
index abe5c41e236..5ae1c9d9dd6 100644
--- a/lang/pike76/Makefile
+++ b/lang/pike76/Makefile
@@ -84,7 +84,7 @@ CONFIGURE_ARGS+= --without-debug \
MAKE_ARGS= CONFIGUREARGS="${CONFIGURE_ARGS}"
USE_GETTEXT= yes
-USE_BISON= build
+USES= bison
USE_GMAKE= yes
# Allow building Embedded Perl
diff --git a/lang/pike78/Makefile b/lang/pike78/Makefile
index c383e1fec7d..29727e669f5 100644
--- a/lang/pike78/Makefile
+++ b/lang/pike78/Makefile
@@ -75,7 +75,7 @@ MAKE_ARGS= "CONFIGUREARGS=${CONFIGURE_ARGS}"
MAKE_ENV= "ac_cv_lib_nettle_nettle_md5_init=no"
USE_GETTEXT= yes
-USE_BISON= build
+USES= bison
USE_GMAKE= yes
# Allow building Embedded Perl
diff --git a/lang/ptoc/Makefile b/lang/ptoc/Makefile
index e98804be158..188f61f7474 100644
--- a/lang/ptoc/Makefile
+++ b/lang/ptoc/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ptoc
-# Date created: 10 December 1997
-# Whom: Andrey Zakhvatov
-#
+# Created by: Andrey Zakhvatov
# $FreeBSD$
-#
PORTNAME= ptoc
PORTVERSION= 3.58
@@ -16,7 +12,7 @@ COMMENT= ANSI/Turbo Pascal to C/C++ converter
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_XORG= x11
-USE_BISON= build
+USES= bison
EXAMPLES= arr.pas bgidemo.pas ccall.pas coord.txt dos.h dos.pas \
func.pas hello.pas impact.pas lister.pas makefile.bsd \
diff --git a/lang/q/Makefile b/lang/q/Makefile
index b7f8bf71836..a6c33321bac 100644
--- a/lang/q/Makefile
+++ b/lang/q/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= MagickWand:${PORTSDIR}/graphics/ImageMagick \
xslt.2:${PORTSDIR}/textproc/libxslt \
ggi.2:${PORTSDIR}/graphics/libggi
-USE_BISON= build
+USES= bison
USE_GCC= any
USE_ICONV= yes
USE_TK= 84+
diff --git a/lang/rakudo/Makefile b/lang/rakudo/Makefile
index 10fa5dd3436..be2f95d408a 100644
--- a/lang/rakudo/Makefile
+++ b/lang/rakudo/Makefile
@@ -41,7 +41,7 @@ CONFIGURE_ARGS= --with-parrot=${PREFIX}/bin/parrot \
BROKEN= Does not compile on ia64, powerpc, or sparc64
.endif
-USE_BISON= build
+USES+= bison
USE_PERL5_BUILD= yes
USE_GMAKE= yes
diff --git a/lang/spl/Makefile b/lang/spl/Makefile
index 8a53234c2a1..07577e56fb3 100644
--- a/lang/spl/Makefile
+++ b/lang/spl/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: spl
-# Date created: 6 September 2001
-# Whom: Hye-Shik Chang <perky@fallin.lv>
-#
+# Created by: Hye-Shik Chang <perky@fallin.lv>
# $FreeBSD$
-#
PORTNAME= spl
PORTVERSION= 1.2.1
@@ -14,7 +10,7 @@ MASTER_SITES= http://shakespearelang.sourceforge.net/download/
MAINTAINER= ports@FreeBSD.org
COMMENT= The Shakespeare programming language
-USE_BISON= build
+USES= bison
USE_GMAKE= yes
ALL_EXAMPLES= Makefile fibonacci.spl fibonacci2.spl guess.spl hello.spl \
diff --git a/lang/vala/Makefile b/lang/vala/Makefile
index d85c5f68398..05fcf6ea6f7 100644
--- a/lang/vala/Makefile
+++ b/lang/vala/Makefile
@@ -12,15 +12,15 @@ COMMENT= Programming language and compiler that converts Vala code into C code
LICENSE= LGPL21
+USES= bison pathfix
USE_XZ= yes
-USE_GNOME= gnomehack glib20 gnomeprefix libxslt
+USE_GNOME= glib20 gnomeprefix libxslt
USE_GMAKE= yes
USE_PKGCONFIG= build
GNU_CONFIGURE= yes
USE_GETTEXT= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-USE_BISON= build
USE_LDCONFIG= yes
MAN1?= valac.1 valac-${VALA_VER}.1
diff --git a/lang/yabasic/Makefile b/lang/yabasic/Makefile
index cb4c2347a88..7753e9cd25f 100644
--- a/lang/yabasic/Makefile
+++ b/lang/yabasic/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: yabasic
-# Date created: 11 Nov 1999
-# Whom: Frank Gruender
-#
+# Created by: Frank Gruender
# $FreeBSD$
-#
PORTNAME= yabasic
PORTVERSION= 2.763
@@ -15,7 +11,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Yet another Basic for Unix and Windows
USE_XORG= x11 ice sm xt
-USE_BISON= build
+USES= bison
GNU_CONFIGURE= yes
MAN1= yabasic.1