aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2010-10-01 20:44:34 +0800
committerpav <pav@FreeBSD.org>2010-10-01 20:44:34 +0800
commit38b5d0909022bd403c1b893f011bc19f61101a18 (patch)
treec3d6f804ef8827190dbd03b8c2ef60c0e6d1e947 /lang
parente1ff50a18f5230702279f344d1f5d4b4ada42687 (diff)
downloadfreebsd-ports-graphics-38b5d0909022bd403c1b893f011bc19f61101a18.tar.gz
freebsd-ports-graphics-38b5d0909022bd403c1b893f011bc19f61101a18.tar.zst
freebsd-ports-graphics-38b5d0909022bd403c1b893f011bc19f61101a18.zip
- Update to 4.6.0
PR: ports/151045 Submitted by: Adrien Pierard <pmn@bakarika.net> (maintainer)
Diffstat (limited to 'lang')
-rw-r--r--lang/gambit-c/Makefile19
-rw-r--r--lang/gambit-c/distinfo6
-rw-r--r--lang/gambit-c/pkg-descr20
-rw-r--r--lang/gambit-c/pkg-plist62
4 files changed, 52 insertions, 55 deletions
diff --git a/lang/gambit-c/Makefile b/lang/gambit-c/Makefile
index 323ce43e1b9..e926b42b393 100644
--- a/lang/gambit-c/Makefile
+++ b/lang/gambit-c/Makefile
@@ -6,26 +6,27 @@
#
PORTNAME= gambit-c
-DISTVERSION= v4_4_3
+DISTVERSION= v4_6_0
PORTEPOCH= 1
CATEGORIES= lang
-MASTER_SITES= http://www.iro.umontreal.ca/~gambit/download/gambit/v4.4/source/
-EXTRACT_SUFX= .tgz
+MASTER_SITES= http://www.iro.umontreal.ca/~gambit/download/gambit/v4.6/source/
DISTNAME= gambc-${DISTVERSION}
+EXTRACT_SUFX= .tgz
MAINTAINER= pmn@bakarika.net
COMMENT= Gambit programming system where the compiler generates portable C code
+MAN1= gsi.1
+
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-single-host --enable-gcc-opts
-CONFIGURE_ARGS+= --prefix=${PREFIX} --docdir=${PREFIX}/share/doc/gambit-c
+CONFIGURE_ARGS = --enable-single-host --enable-gcc-opts
+CONFIGURE_ARGS+= --prefix=${PREFIX} --docdir=${PREFIX}/share/doc/gambit-c
CONFIGURE_ARGS+= --libdir=${PREFIX}/lib/gambit-c/ --includedir=${PREFIX}/include/gambit-c
+CONFIGURE_ARGS+= --enable-interpreter-name=gsi-gambit --enable-compiler-name=gsc-gambit
-# Will need upstream patch to avoid the error
-#INFO= gambit-c
+INFO= gambit-c
-# Will need upstream patch too
MAKE_JOBS_SAFE= yes
.include <bsd.port.pre.mk>
@@ -45,8 +46,6 @@ post-patch:
@${REINPLACE_CMD} -e 's|^\(FLAGS_DYN = \).*|\1 ${CFLAGS}|' ${WRKSRC}/gsi/makefile.in
@${REINPLACE_CMD} -e 's|^\(FLAGS_OBJ = \).*|\1 ${CFLAGS}|' ${WRKSRC}/gsc/makefile.in
@${REINPLACE_CMD} -e 's|^\(FLAGS_DYN = \).*|\1 ${CFLAGS}|' ${WRKSRC}/gsc/makefile.in
- @${REINPLACE_CMD} -e 's|^EXECUTABLE = gsi@exe@|EXECUTABLE = gsi-gambit@exe@|' ${WRKSRC}/gsi/makefile.in
- @${REINPLACE_CMD} -e 's|^EXECUTABLE = gsc@exe@|EXECUTABLE = gsc-gambit@exe@|' ${WRKSRC}/gsc/makefile.in
post-configure:
@${MV} ${WRKSRC}/makefile ${WRKSRC}/Makefile
diff --git a/lang/gambit-c/distinfo b/lang/gambit-c/distinfo
index 6440b31e7f6..af36e3fb714 100644
--- a/lang/gambit-c/distinfo
+++ b/lang/gambit-c/distinfo
@@ -1,3 +1,3 @@
-MD5 (gambc-v4_4_3.tgz) = 925dad46461994e13b680dd3a9d4c38a
-SHA256 (gambc-v4_4_3.tgz) = 8f5d9ad292d806c99baea11c696a34000ef0f38e175cc114dfee85128faaf565
-SIZE (gambc-v4_4_0.tgz) = 8028618
+MD5 (gambc-v4_6_0.tgz) = 4f0e8b3e90a96f2203cbaf1e1cc1388a
+SHA256 (gambc-v4_6_0.tgz) = 905cea7435f5e23c955713466f4baca07100d375e35520a0132b4d7472863be2
+SIZE (gambc-v4_6_0.tgz) = 8196859
diff --git a/lang/gambit-c/pkg-descr b/lang/gambit-c/pkg-descr
index 5681a3a7a70..9cd75aa58c4 100644
--- a/lang/gambit-c/pkg-descr
+++ b/lang/gambit-c/pkg-descr
@@ -1,14 +1,14 @@
-The Gambit programming system is a full implementation of the Scheme
-language which conforms to the R4RS and IEEE Scheme standards. It
-consists of two main programs: gsi-gambit, the Gambit Scheme interpreter,
-and gsc-gambit, the Gambit Scheme compiler.
+The Gambit programming system is a full implementation of the Scheme
+language which conforms to the R4RS and IEEE Scheme standards. It
+consists of two main programs: gsi-gambit, the Gambit Scheme
+interpreter, and gsc-gambit, the Gambit Scheme compiler.
-Gambit-C is a version of the Gambit programming system in which the
-compiler generates portable C code, making the whole Gambit-C system
-and the programs compiled with it easily portable to many computer
-architectures for which a C compiler is available. With appropriate
-declarations in the source code the executable programs generated by
-the compiler run roughly as fast as equivalent C programs.
+Gambit-C is a version of the Gambit programming system in which the
+compiler generates portable C code, making the whole Gambit-C system
+and the programs compiled with it easily portable to many computer
+architectures for which a C compiler is available. With appropriate
+declarations in the source code the executable programs generated by
+the compiler run roughly as fast as equivalent C programs.
WWW: http://www.iro.umontreal.ca/~gambit/
diff --git a/lang/gambit-c/pkg-plist b/lang/gambit-c/pkg-plist
index eddd0f70af6..43528eabb6f 100644
--- a/lang/gambit-c/pkg-plist
+++ b/lang/gambit-c/pkg-plist
@@ -1,47 +1,45 @@
-bin/six
-bin/gsi-gambit
-bin/gsc-gambit
-bin/gsc-cc-o.bat
+bin/gambc-cc.bat
bin/gambc-doc.bat
+bin/gsc-gambit
+bin/gsc-script
+bin/gsi-gambit
bin/gsi-script
-bin/six-script
-bin/scheme-srfi-0
-bin/scheme-r5rs
-bin/scheme-r4rs
bin/scheme-ieee-1178-1990
-bin/gsc-script
+bin/scheme-r4rs
+bin/scheme-r5rs
+bin/scheme-srfi-0
+bin/six
+bin/six-script
+include/gambit-c/gambit-not406000.h
include/gambit-c/gambit.h
-include/gambit-c/gambit-not404003.h
-info/gambit-c.info
-info/gambit-c.info-1
-info/gambit-c.info-2
-info/gambit-c.info-3
+lib/gambit-c/_eval#.scm
lib/gambit-c/_gambc.c
+lib/gambit-c/_gambcgsc.c
+lib/gambit-c/_gambcgsi.c
+lib/gambit-c/_gambit#.scm
+lib/gambit-c/_io#.scm
lib/gambit-c/_kernel#.scm
-lib/gambit-c/_system#.scm
+lib/gambit-c/_nonstd#.scm
lib/gambit-c/_num#.scm
+lib/gambit-c/_repl#.scm
lib/gambit-c/_std#.scm
-lib/gambit-c/_eval#.scm
-lib/gambit-c/_io#.scm
-lib/gambit-c/_nonstd#.scm
+lib/gambit-c/_system#.scm
lib/gambit-c/_thread#.scm
-lib/gambit-c/_repl#.scm
-lib/gambit-c/_gambit#.scm
-lib/gambit-c/gambit#.scm
-lib/gambit-c/r5rs#.scm
-lib/gambit-c/r4rs#.scm
lib/gambit-c/digest#.scm
lib/gambit-c/digest.scm
-lib/gambit-c/syntax-case.scm
+lib/gambit-c/gambit#.scm
lib/gambit-c/libgambc.a
-lib/gambit-c/_gambcgsi.c
-lib/gambit-c/libgambcgsi.a
-lib/gambit-c/_gambcgsc.c
lib/gambit-c/libgambcgsc.a
-share/doc/gambit-c/gambit-c.pdf
-share/doc/gambit-c/gambit-c.html
-share/doc/gambit-c/gambit-c.txt
+lib/gambit-c/libgambcgsi.a
+lib/gambit-c/r4rs#.scm
+lib/gambit-c/r5rs#.scm
+lib/gambit-c/syntax-case.scm
+%%PORTDOCS%%%%DOCSDIR%%/gambit-c.html
+%%PORTDOCS%%%%DOCSDIR%%/gambit-c.pdf
+%%PORTDOCS%%%%DOCSDIR%%/gambit-c.txt
share/emacs/site-lisp/gambit.el
-@dirrm include/gambit-c
+@dirrmtry share/emacs/site-lisp
+@dirrmtry share/emacs
+%%PORTDOCS%%@dirrmtry %%DOCSDIR%%
@dirrm lib/gambit-c
-@dirrm share/doc/gambit-c
+@dirrm include/gambit-c