aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2006-06-17 20:38:07 +0800
committergerald <gerald@FreeBSD.org>2006-06-17 20:38:07 +0800
commit3eefa6ba3c46dbc65489cb05bb0de0c7b44e1ae3 (patch)
tree1bb12f9d46ce74f55a319d18adb7c8b1fa90098a /lang
parent48ac29213f89b3ede8cf8a4e7a4a199c7aa081fb (diff)
downloadfreebsd-ports-graphics-3eefa6ba3c46dbc65489cb05bb0de0c7b44e1ae3.tar.gz
freebsd-ports-graphics-3eefa6ba3c46dbc65489cb05bb0de0c7b44e1ae3.tar.zst
freebsd-ports-graphics-3eefa6ba3c46dbc65489cb05bb0de0c7b44e1ae3.zip
Employ the new USE_LDCONFIG feature, which allows us to get rid of the
various, much more manual and error-prone hacks we needed so far. Reviewed by: flz
Diffstat (limited to 'lang')
-rw-r--r--lang/gcc40/Makefile8
-rw-r--r--lang/gcc40/files/gcc.sh.in14
-rw-r--r--lang/gcc40/pkg-plist1
3 files changed, 1 insertions, 22 deletions
diff --git a/lang/gcc40/Makefile b/lang/gcc40/Makefile
index bbdfe874fb9..de5f65719a1 100644
--- a/lang/gcc40/Makefile
+++ b/lang/gcc40/Makefile
@@ -55,11 +55,7 @@ CONFIGURE_ARGS+= --disable-nls \
CONFIGURE_ENV= RANLIB=:
MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
ALL_TARGET= bootstrap-lean
-INSTALLS_SHLIB= yes
-LDCONFIG_DIRS= ${TARGLIB}
-SUB_LIST= TARGLIB="${TARGLIB}"
-SUB_FILES= gcc.sh
-RC_D_SH= etc/rc.d/gcc${SUFFIX}.sh
+USE_LDCONFIG= ${TARGLIB}
PLIST_SUB= GCC_VER=${PORTVERSION} GNU_HOST=${CONFIGURE_TARGET} \
SUFFIX=${SUFFIX}
MAN1= cpp${SUFFIX}.1 \
@@ -93,8 +89,6 @@ check: build
cd ${WRKSRC}; export RUNTESTFLAGS='--target_board ''unix{-pthread}'''; ${GMAKE} -sk check
post-install:
- -@${MKDIR} ${PREFIX}/etc/rc.d
- ${INSTALL_SCRIPT} ${WRKDIR}/gcc.sh ${PREFIX}/${RC_D_SH}
# man pages can only be generated if Perl >= 5.6 is installed;
# fake them otherwise.
for mp in ${_MANPAGES}; do \
diff --git a/lang/gcc40/files/gcc.sh.in b/lang/gcc40/files/gcc.sh.in
deleted file mode 100644
index 987e9531e37..00000000000
--- a/lang/gcc40/files/gcc.sh.in
+++ /dev/null
@@ -1,14 +0,0 @@
-#!/bin/sh
-
-case "$1" in
-start)
- ldconfig -m %%TARGLIB%%
- ;;
-stop)
- ;;
-*)
- echo "Usage: ${0##*/} { start | stop }" >&2
- exit 64
- ;;
-esac
-exit 0
diff --git a/lang/gcc40/pkg-plist b/lang/gcc40/pkg-plist
index d34fedef390..af92003847f 100644
--- a/lang/gcc40/pkg-plist
+++ b/lang/gcc40/pkg-plist
@@ -9,6 +9,5 @@ bin/%%GNU_HOST%%-c++%%SUFFIX%%
bin/%%GNU_HOST%%-g++%%SUFFIX%%
bin/%%GNU_HOST%%-gcc-%%GCC_VER%%
bin/%%GNU_HOST%%-gcc%%SUFFIX%%
-etc/rc.d/gcc%%SUFFIX%%.sh
info/gcc%%SUFFIX%%/dir
@comment Insert PLIST.lib here