aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2006-06-17 23:47:43 +0800
committergerald <gerald@FreeBSD.org>2006-06-17 23:47:43 +0800
commit558c565486fde28e55339218b6e6abd6f914a33f (patch)
tree3bbdf1c8f402a6e3e3131de6ebdfbf83a6f8f5ff /lang
parent7d97f65860e416b419c18a168a12c1aea564318d (diff)
downloadfreebsd-ports-graphics-558c565486fde28e55339218b6e6abd6f914a33f.tar.gz
freebsd-ports-graphics-558c565486fde28e55339218b6e6abd6f914a33f.tar.zst
freebsd-ports-graphics-558c565486fde28e55339218b6e6abd6f914a33f.zip
Make CONFIGURE_ARGS additive, for the sake of child ports and to
bring my lang/gcc* ports more in sync. Employ the new USE_LDCONFIG feature, which allows us to get rid of the various, much more manual and error-prone hacks we needed so far. Reviewed by: flz (for lang/gcc40)
Diffstat (limited to 'lang')
-rw-r--r--lang/gcc34/Makefile10
-rw-r--r--lang/gcc34/files/gcc.sh.in14
-rw-r--r--lang/gcc34/pkg-plist1
3 files changed, 2 insertions, 23 deletions
diff --git a/lang/gcc34/Makefile b/lang/gcc34/Makefile
index 2b61bded0ec..5c836332c85 100644
--- a/lang/gcc34/Makefile
+++ b/lang/gcc34/Makefile
@@ -49,7 +49,7 @@ SRCDIR= ${WRKDIR}/gcc-${VERSIONSTRING}
WRKSRC= ${WRKDIR}/build
TARGLIB= ${PREFIX}/lib/gcc/${CONFIGURE_TARGET}/${PORTVERSION}
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-nls \
+CONFIGURE_ARGS+= --disable-nls \
--with-system-zlib \
--with-libiconv-prefix=${LOCALBASE} \
--program-suffix=${SUFFIX} \
@@ -59,11 +59,7 @@ CONFIGURE_ARGS= --disable-nls \
CONFIGURE_ENV= RANLIB=:
MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
ALL_TARGET= bootstrap-lean
-INSTALLS_SHLIB= yes
-LDCONFIG_DIRS= ${TARGLIB}
-SUB_LIST= TARGLIB="${TARGLIB}"
-SUB_FILES= gcc.sh
-RC_D_SH= etc/rc.d/gcc${SUFFIX}.sh
+USE_LDCONFIG= ${TARGLIB}
.if ${OSVERSION} < 500000 && ${ARCH} == alpha
CXXFLAGS+= -fPIC
.endif
@@ -102,8 +98,6 @@ check: build
cd ${WRKSRC}; export RUNTESTFLAGS='--target_board ''unix{-pthread}'''; ${GMAKE} -sk check
post-install:
- -@${MKDIR} ${PREFIX}/etc/rc.d
- ${INSTALL_SCRIPT} ${WRKDIR}/gcc.sh ${PREFIX}/${RC_D_SH}
# man pages can only be generated if Perl >= 5.6 is installed;
# fake them otherwise.
for mp in ${_MANPAGES}; do \
diff --git a/lang/gcc34/files/gcc.sh.in b/lang/gcc34/files/gcc.sh.in
deleted file mode 100644
index 987e9531e37..00000000000
--- a/lang/gcc34/files/gcc.sh.in
+++ /dev/null
@@ -1,14 +0,0 @@
-#!/bin/sh
-
-case "$1" in
-start)
- ldconfig -m %%TARGLIB%%
- ;;
-stop)
- ;;
-*)
- echo "Usage: ${0##*/} { start | stop }" >&2
- exit 64
- ;;
-esac
-exit 0
diff --git a/lang/gcc34/pkg-plist b/lang/gcc34/pkg-plist
index a3351d8b3e2..6e2f599b435 100644
--- a/lang/gcc34/pkg-plist
+++ b/lang/gcc34/pkg-plist
@@ -10,7 +10,6 @@ bin/%%GNU_HOST%%-c++%%SUFFIX%%
bin/%%GNU_HOST%%-g++%%SUFFIX%%
bin/%%GNU_HOST%%-gcc-%%GCC_VER%%
bin/%%GNU_HOST%%-gcc%%SUFFIX%%
-etc/rc.d/gcc%%SUFFIX%%.sh
libexec/gcc/%%GNU_HOST%%/%%GCC_VER%%/cc1
libexec/gcc/%%GNU_HOST%%/%%GCC_VER%%/cc1plus
libexec/gcc/%%GNU_HOST%%/%%GCC_VER%%/f771