aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>2000-06-16 15:38:43 +0800
committertg <tg@FreeBSD.org>2000-06-16 15:38:43 +0800
commit5600809f38f9851c85dfdf67859ed6df78800ba9 (patch)
tree84ecb9bc02641ed2855c953295405579e0c8ce5b /lang
parentde8ed5f2e16ce1ed60675336124dd2533655a99b (diff)
downloadfreebsd-ports-graphics-5600809f38f9851c85dfdf67859ed6df78800ba9.tar.gz
freebsd-ports-graphics-5600809f38f9851c85dfdf67859ed6df78800ba9.tar.zst
freebsd-ports-graphics-5600809f38f9851c85dfdf67859ed6df78800ba9.zip
Make this actually work. Fix MASTER_SITES while I'm here.
PR: 19259 Submitted by: Dominic Mitchell <hdm@mistral.co.uk>
Diffstat (limited to 'lang')
-rw-r--r--lang/py-mx-base/Makefile8
-rw-r--r--lang/py-mx-base/pkg-plist6
2 files changed, 11 insertions, 3 deletions
diff --git a/lang/py-mx-base/Makefile b/lang/py-mx-base/Makefile
index aabb493d163..9b573bbd2e3 100644
--- a/lang/py-mx-base/Makefile
+++ b/lang/py-mx-base/Makefile
@@ -8,7 +8,7 @@
PORTNAME= py-mxTextTools
PORTVERSION= 1.1.1
CATEGORIES= textproc python
-MASTER_SITES= http://starship.skyport.net/~lemburg/
+MASTER_SITES= http://starship.python.net/~lemburg/
DISTNAME= mxTextTools-1.1.1
MAINTAINER= tg@FreeBSD.org
@@ -32,11 +32,15 @@ post-extract:
do-configure:
@(cd ${WRKSRC} && ${CONFIGURE_ENV} ${MAKE} -f Makefile.pre.in boot)
-post-install:
+do-install:
@${MKDIR} ${TEXTTOOLSDIR}
${INSTALL_DATA} ${WRKDIR}/TextTools/*.py ${TEXTTOOLSDIR}
@${MKDIR} ${TEXTTOOLSDIR}/Constants
${INSTALL_DATA} ${WRKDIR}/TextTools/Constants/*.py ${TEXTTOOLSDIR}/Constants
+ @${MKDIR} ${TEXTTOOLSDIR}/mxTextTools
+.for file in __init__.py mxTextTools.so
+ ${INSTALL_DATA} ${WRKDIR}/TextTools/mxTextTools/${file} ${TEXTTOOLSDIR}/mxTextTools
+.endfor
@${PREFIX}/bin/python ${PYTHONSCRIPTDIR}/compileall.py ${TEXTTOOLSDIR}
@${PREFIX}/bin/python -O ${PYTHONSCRIPTDIR}/compileall.py ${TEXTTOOLSDIR}
@${MKDIR} ${EXAMPLEDIR}
diff --git a/lang/py-mx-base/pkg-plist b/lang/py-mx-base/pkg-plist
index ddeaf851a9c..32e485f4a07 100644
--- a/lang/py-mx-base/pkg-plist
+++ b/lang/py-mx-base/pkg-plist
@@ -14,7 +14,11 @@ lib/python1.5/site-packages/TextTools/TextTools.pyo
lib/python1.5/site-packages/TextTools/__init__.py
lib/python1.5/site-packages/TextTools/__init__.pyc
lib/python1.5/site-packages/TextTools/__init__.pyo
-lib/python1.5/site-packages/mxTextTools.so
+lib/python1.5/site-packages/TextTools/mxTextTools/__init__.py
+lib/python1.5/site-packages/TextTools/mxTextTools/__init__.pyc
+lib/python1.5/site-packages/TextTools/mxTextTools/__init__.pyo
+lib/python1.5/site-packages/TextTools/mxTextTools/mxTextTools.so
+@dirrm lib/python1.5/site-packages/TextTools/mxTextTools
@dirrm lib/python1.5/site-packages/TextTools
share/doc/py-mxTextTools/mxTextTools.html
@dirrm share/doc/py-mxTextTools