aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2014-02-08 18:06:40 +0800
committersunpoet <sunpoet@FreeBSD.org>2014-02-08 18:06:40 +0800
commit68938875f09568a90568c12d96ee1be6730b602a (patch)
treee49ddb7096a2cd456f0e90e14c69ca90ed9a1e62 /lang
parente15ac8a9812fd9b0df498267676d502040a3a22f (diff)
downloadfreebsd-ports-graphics-68938875f09568a90568c12d96ee1be6730b602a.tar.gz
freebsd-ports-graphics-68938875f09568a90568c12d96ee1be6730b602a.tar.zst
freebsd-ports-graphics-68938875f09568a90568c12d96ee1be6730b602a.zip
- Add LICENSE
- Fix build for users with python 3.x as default - Simplify shebang fix Submitted by: sunpoet (myself) Approved by: vanilla (maintainer)
Diffstat (limited to 'lang')
-rw-r--r--lang/v8-devel/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/lang/v8-devel/Makefile b/lang/v8-devel/Makefile
index bcf0d35530e..3690105651a 100644
--- a/lang/v8-devel/Makefile
+++ b/lang/v8-devel/Makefile
@@ -11,6 +11,8 @@ PKGNAMESUFFIX= -devel
MAINTAINER= vanilla@FreeBSD.org
COMMENT= Google\'s open source JavaScript engine
+LICENSE= BSD3CLAUSE
+
BUILD_DEPENDS= python:${PORTSDIR}/lang/python
LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
libicui18n.so:${PORTSDIR}/devel/icu
@@ -18,7 +20,6 @@ LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
CONFLICTS= v8-3.19.*
USES= gmake shebangfix compiler
-SHEBANG_LANG= sh
SHEBANG_FILES= ${WRKSRC}/build/gyp/gyp
USE_XZ= yes
USE_PYTHON= 2
@@ -26,8 +27,7 @@ USE_LDCONFIG= yes
ALL_TARGET= native
MAKE_ARGS= library=shared use_system_icu=on
MAKE_ENV+= CC.host=${CC} CXX.host=${CXX} LINK.host=${CXX} LINK.target=${CXX}
-sh_OLD_CMD= /bin/bash
-sh_CMD= ${SH}
+bash_CMD= ${SH}
.include <bsd.port.pre.mk>
@@ -45,6 +45,9 @@ USE_GCC= any
ONLY_FOR_ARCHS= i386 amd64
+post-patch:
+ @${REINPLACE_CMD} -e '/^exec python / s| python | ${PYTHON_CMD} |' ${WRKSRC}/build/gyp/gyp
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/out/native/d8 ${STAGEDIR}${PREFIX}/bin/d8
${INSTALL_LIB} -m 755 ${WRKSRC}/out/native/lib.target/libv8.so ${STAGEDIR}${PREFIX}/lib/libv8.so.1