aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2015-04-20 03:51:25 +0800
committerswills <swills@FreeBSD.org>2015-04-20 03:51:25 +0800
commit6999e19fd94b2581b8539ac7b2c1c23c1be14312 (patch)
tree89b795c0683ede771d0db4f9075c16654069fc7d /lang
parent817f8b5543906f3968d2f9531aec7dd929bce7ab (diff)
downloadfreebsd-ports-graphics-6999e19fd94b2581b8539ac7b2c1c23c1be14312.tar.gz
freebsd-ports-graphics-6999e19fd94b2581b8539ac7b2c1c23c1be14312.tar.zst
freebsd-ports-graphics-6999e19fd94b2581b8539ac7b2c1c23c1be14312.zip
Fix build on arm
Diffstat (limited to 'lang')
-rw-r--r--lang/ruby20/Makefile4
-rw-r--r--lang/ruby21/Makefile4
-rw-r--r--lang/ruby22/Makefile4
3 files changed, 12 insertions, 0 deletions
diff --git a/lang/ruby20/Makefile b/lang/ruby20/Makefile
index 959bc616bc1..dedf13798f4 100644
--- a/lang/ruby20/Makefile
+++ b/lang/ruby20/Makefile
@@ -93,6 +93,10 @@ CONFIGURE_ARGS+= --disable-dtrace
.endif
.endif
+.if ${ARCH} == "armv6" || ${ARCH} == "armv6hf"
+CONFIGURE_ARGS+= --with-setjmp-type=_setjmp
+.endif
+
CONFIGURE_ENV= debugflags=
.if ${PORT_OPTIONS:MCAPIDOCS}
diff --git a/lang/ruby21/Makefile b/lang/ruby21/Makefile
index 9986323ef80..d045b48b0b9 100644
--- a/lang/ruby21/Makefile
+++ b/lang/ruby21/Makefile
@@ -92,6 +92,10 @@ CONFIGURE_ARGS+= --disable-dtrace
.endif
.endif
+.if ${ARCH} == "armv6" || ${ARCH} == "armv6hf"
+CONFIGURE_ARGS+= --with-setjmp-type=_setjmp
+.endif
+
CONFIGURE_ENV= debugflags=
.if ${PORT_OPTIONS:MCAPIDOCS}
diff --git a/lang/ruby22/Makefile b/lang/ruby22/Makefile
index 3811a197f6b..f8abcd3e073 100644
--- a/lang/ruby22/Makefile
+++ b/lang/ruby22/Makefile
@@ -92,6 +92,10 @@ CONFIGURE_ARGS+= --disable-dtrace
.endif
.endif
+.if ${ARCH} == "armv6" || ${ARCH} == "armv6hf"
+CONFIGURE_ARGS+= --with-setjmp-type=_setjmp
+.endif
+
CONFIGURE_ENV= debugflags=
.if ${PORT_OPTIONS:MCAPIDOCS}