aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorwjv <wjv@FreeBSD.org>2002-04-23 22:35:59 +0800
committerwjv <wjv@FreeBSD.org>2002-04-23 22:35:59 +0800
commit6b79646518e52db42af9ea2e8d46de5797fe0157 (patch)
tree27158710a3c151c3059b987b14cbe7a880219707 /lang
parent65a80d0de8325822b519e32b406c74e1fc495335 (diff)
downloadfreebsd-ports-graphics-6b79646518e52db42af9ea2e8d46de5797fe0157.tar.gz
freebsd-ports-graphics-6b79646518e52db42af9ea2e8d46de5797fe0157.tar.zst
freebsd-ports-graphics-6b79646518e52db42af9ea2e8d46de5797fe0157.zip
- Mark FORBIDDEN if PYTHON_REL >= 220. The compiler is now part of
Python's standard library. PR: 37088 (indirectly) Submitted by: Andreas Schulz <ats@first.fhg.de>
Diffstat (limited to 'lang')
-rw-r--r--lang/py-compiler/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/lang/py-compiler/Makefile b/lang/py-compiler/Makefile
index 98ceefa97d4..8331614f4e4 100644
--- a/lang/py-compiler/Makefile
+++ b/lang/py-compiler/Makefile
@@ -23,6 +23,11 @@ DIST_SUBDIR= python
USE_PYTHON= yes
WRKSRC= ${PYTHON_WRKSRC}/Tools/${PORTNAME}
+.include <bsd.port.pre.mk>
+.if ${PYTHON_REL} >= 220
+FORBIDDEN= "Part of the standard library from Python 2.2 upwards"
+.endif
+
do-build:
@ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} setup.py build
@@ -30,4 +35,4 @@ do-install:
@ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} \
setup.py install -c -O1 --prefix=${PREFIX}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>