aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2015-04-14 08:38:43 +0800
committerswills <swills@FreeBSD.org>2015-04-14 08:38:43 +0800
commit6ff3c622d853db88dca8f939a0f06ab62d358033 (patch)
tree13658318ca50af69c2dec901ff3069fb31b36419 /lang
parentc27609cdb1032cded53a94e17b57a7d43ef7a15c (diff)
downloadfreebsd-ports-graphics-6ff3c622d853db88dca8f939a0f06ab62d358033.tar.gz
freebsd-ports-graphics-6ff3c622d853db88dca8f939a0f06ab62d358033.tar.zst
freebsd-ports-graphics-6ff3c622d853db88dca8f939a0f06ab62d358033.zip
Don't enable dtrace on non-x86 platforms since it causes build issues.
Diffstat (limited to 'lang')
-rw-r--r--lang/ruby21/Makefile2
-rw-r--r--lang/ruby22/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/lang/ruby21/Makefile b/lang/ruby21/Makefile
index 8ca7cd0b692..9986323ef80 100644
--- a/lang/ruby21/Makefile
+++ b/lang/ruby21/Makefile
@@ -85,7 +85,7 @@ CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -lpthread -L${LOCALBASE}/lib
.if ${OPSYS} == "FreeBSD"
-.if exists(/usr/sbin/dtrace) && (${OSVERSION} > 1100032)
+.if exists(/usr/sbin/dtrace) && (${OSVERSION} > 1100032) && (${ARCH} == "amd64" || ${ARCH} == "i386")
CONFIGURE_ARGS+= --enable-dtrace
.else
CONFIGURE_ARGS+= --disable-dtrace
diff --git a/lang/ruby22/Makefile b/lang/ruby22/Makefile
index da67a81398c..3811a197f6b 100644
--- a/lang/ruby22/Makefile
+++ b/lang/ruby22/Makefile
@@ -85,7 +85,7 @@ CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -lpthread -L${LOCALBASE}/lib
.if ${OPSYS} == "FreeBSD"
-.if exists(/usr/sbin/dtrace) && (${OSVERSION} > 1100032)
+.if exists(/usr/sbin/dtrace) && (${OSVERSION} > 1100032) && (${ARCH} == "amd64" || ${ARCH} == "i386")
CONFIGURE_ARGS+= --enable-dtrace
.else
CONFIGURE_ARGS+= --disable-dtrace