aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorpatrick <patrick@FreeBSD.org>2002-02-07 22:03:15 +0800
committerpatrick <patrick@FreeBSD.org>2002-02-07 22:03:15 +0800
commit7d172225c6246c13340500fccfe37fb6ace6d1ea (patch)
tree72a1bb21e0db103abf32cfaf79fb7a2cdc0b89e6 /lang
parent6808a445a1f88b5d57520db45aa9d09947a735a4 (diff)
downloadfreebsd-ports-graphics-7d172225c6246c13340500fccfe37fb6ace6d1ea.tar.gz
freebsd-ports-graphics-7d172225c6246c13340500fccfe37fb6ace6d1ea.tar.zst
freebsd-ports-graphics-7d172225c6246c13340500fccfe37fb6ace6d1ea.zip
Modify the port to use gnugetopt. Our standard getopt does not work.
The developers are working to fix that.
Diffstat (limited to 'lang')
-rw-r--r--lang/tinycobol/Makefile9
-rw-r--r--lang/tinycobol/files/getopt.h129
-rw-r--r--lang/tinycobol/files/patch-aa27
3 files changed, 18 insertions, 147 deletions
diff --git a/lang/tinycobol/Makefile b/lang/tinycobol/Makefile
index a4b5dadb7e5..8f9ba741d4f 100644
--- a/lang/tinycobol/Makefile
+++ b/lang/tinycobol/Makefile
@@ -13,7 +13,8 @@ MASTER_SITE_SUBDIR= tiny-cobol
MAINTAINER= patrick@freebsd.org
-LIB_DEPENDS= db2.0:${PORTSDIR}/databases/db
+LIB_DEPENDS= db2.0:${PORTSDIR}/databases/db \
+ gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
ONLY_FOR_ARCHS= i386
HAS_CONFIGURE= yes
@@ -21,10 +22,8 @@ USE_BISON= yes
USE_GMAKE= yes
CONFIGURE_ARGS= "--with-readline"
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib ${LDFLAGS}"
-
-pre-build:
- ${CP} ${FILESDIR}/getopt.h ${WRKSRC}
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt ${LDFLAGS}" \
+ CPPFLAGS="-I${LOCALBASE}/include"
pre-install:
diff --git a/lang/tinycobol/files/getopt.h b/lang/tinycobol/files/getopt.h
deleted file mode 100644
index 4ac33b71824..00000000000
--- a/lang/tinycobol/files/getopt.h
+++ /dev/null
@@ -1,129 +0,0 @@
-/* Declarations for getopt.
- Copyright (C) 1989, 90, 91, 92, 93, 94 Free Software Foundation, Inc.
-
- This program is free software; you can redistribute it and/or modify it
- under the terms of the GNU General Public License as published by the
- Free Software Foundation; either version 2, or (at your option) any
- later version.
-
- This program is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- GNU General Public License for more details.
-
- You should have received a copy of the GNU General Public License
- along with this program; if not, write to the Free Software
- Foundation, 675 Mass Ave, Cambridge, MA 02139, USA. */
-
-#ifndef _GETOPT_H
-#define _GETOPT_H 1
-
-#ifdef __cplusplus
-extern "C" {
-#endif
-
-/* For communication from `getopt' to the caller.
- When `getopt' finds an option that takes an argument,
- the argument value is returned here.
- Also, when `ordering' is RETURN_IN_ORDER,
- each non-option ARGV-element is returned here. */
-
-extern char *optarg;
-
-/* Index in ARGV of the next element to be scanned.
- This is used for communication to and from the caller
- and for communication between successive calls to `getopt'.
-
- On entry to `getopt', zero means this is the first call; initialize.
-
- When `getopt' returns EOF, this is the index of the first of the
- non-option elements that the caller should itself scan.
-
- Otherwise, `optind' communicates from one call to the next
- how much of ARGV has been scanned so far. */
-
-extern int optind;
-
-/* Callers store zero here to inhibit the error message `getopt' prints
- for unrecognized options. */
-
-extern int opterr;
-
-/* Set to an option character which was unrecognized. */
-
-extern int optopt;
-
-/* Describe the long-named options requested by the application.
- The LONG_OPTIONS argument to getopt_long or getopt_long_only is a vector
- of `struct option' terminated by an element containing a name which is
- zero.
-
- The field `has_arg' is:
- no_argument (or 0) if the option does not take an argument,
- required_argument (or 1) if the option requires an argument,
- optional_argument (or 2) if the option takes an optional argument.
-
- If the field `flag' is not NULL, it points to a variable that is set
- to the value given in the field `val' when the option is found, but
- left unchanged if the option is not found.
-
- To have a long-named option do something other than set an `int' to
- a compiled-in constant, such as set a value from `optarg', set the
- option's `flag' field to zero and its `val' field to a nonzero
- value (the equivalent single-letter option character, if there is
- one). For long options that have a zero `flag' field, `getopt'
- returns the contents of the `val' field. */
-
-struct option
-{
-#if defined (__STDC__) && __STDC__
- const char *name;
-#else
- char *name;
-#endif
- /* has_arg can't be an enum because some compilers complain about
- type mismatches in all the code that assumes it is an int. */
- int has_arg;
- int *flag;
- int val;
-};
-
-/* Names for the values of the `has_arg' field of `struct option'. */
-
-#define no_argument 0
-#define required_argument 1
-#define optional_argument 2
-
-#if defined (__STDC__) && __STDC__
-#ifdef __GNU_LIBRARY__
-/* Many other libraries have conflicting prototypes for getopt, with
- differences in the consts, in stdlib.h. To avoid compilation
- errors, only prototype getopt for the GNU C library. */
-extern int getopt (int argc, char *const *argv, const char *shortopts);
-#else /* not __GNU_LIBRARY__ */
-extern int getopt ();
-#endif /* __GNU_LIBRARY__ */
-extern int getopt_long (int argc, char *const *argv, const char *shortopts,
- const struct option *longopts, int *longind);
-extern int getopt_long_only (int argc, char *const *argv,
- const char *shortopts,
- const struct option *longopts, int *longind);
-
-/* Internal only. Users should not call this directly. */
-extern int _getopt_internal (int argc, char *const *argv,
- const char *shortopts,
- const struct option *longopts, int *longind,
- int long_only);
-#else /* not __STDC__ */
-extern int getopt ();
-extern int getopt_long ();
-extern int getopt_long_only ();
-
-extern int _getopt_internal ();
-#endif /* __STDC__ */
-
-#ifdef __cplusplus
-}
-#endif
-
-#endif /* _GETOPT_H */
diff --git a/lang/tinycobol/files/patch-aa b/lang/tinycobol/files/patch-aa
index 7bc66d1f366..9e37f03927b 100644
--- a/lang/tinycobol/files/patch-aa
+++ b/lang/tinycobol/files/patch-aa
@@ -1,14 +1,6 @@
---- configure.orig Sun Oct 28 22:39:13 2001
-+++ configure Tue Jan 29 08:13:45 2002
-@@ -65,6 +65,7 @@
- # Initialize some other variables.
- subdirs=
- MFLAGS= MAKEFLAGS=
-+LDFLAGS='-L /usr/local/lib'
-
- ac_prev=
- for ac_option
-@@ -512,7 +513,7 @@
+--- configure.orig Tue Jan 29 08:30:36 2002
++++ configure Tue Feb 5 07:30:45 2002
+@@ -522,7 +522,7 @@
ac_ext=c
# CFLAGS is not in ac_cpp because -g, -O, etc. are not valid cpp options.
ac_cpp='$CPP $CPPFLAGS'
@@ -17,12 +9,21 @@
ac_link='${CC-cc} -o conftest $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS 1>&5'
if (echo "testing\c"; echo 1,2,3) | grep c >/dev/null; then
-@@ -2024,7 +2025,7 @@
+@@ -2085,7 +2085,7 @@
echo $ac_n "(cached) $ac_c" 1>&6
else
ac_save_LIBS="$LIBS"
-LIBS="-ldb $LIBS"
+LIBS="-ldb2 $LIBS"
cat > conftest.$ac_ext <<EOF
- #line 2030 "configure"
+ #line 2091 "configure"
#include "confdefs.h"
+@@ -2835,7 +2835,7 @@
+ #)
+
+ LIBS="-L/usr/lib $M_LIBS"
+-INCLUDES="-I/usr/include -I../lib -I../"
++INCLUDES="-I/usr/include -I../lib -I../ -I/usr/local/include"
+
+
+ # set default directories