aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2013-05-06 10:00:40 +0800
committerhrs <hrs@FreeBSD.org>2013-05-06 10:00:40 +0800
commit7d813d3d1216f86eb5fb23e9bb2b1016686e382a (patch)
tree03323bda08dff3e59e16e53235d609d9f8541643 /lang
parent56bfc43ff611d8bd6cd9e8de4be32b94d4cfea27 (diff)
downloadfreebsd-ports-graphics-7d813d3d1216f86eb5fb23e9bb2b1016686e382a.tar.gz
freebsd-ports-graphics-7d813d3d1216f86eb5fb23e9bb2b1016686e382a.tar.zst
freebsd-ports-graphics-7d813d3d1216f86eb5fb23e9bb2b1016686e382a.zip
Remove *_DEPENDS from ports which depend on teTeX and add USE_TEX=tetex
instead to make migration to TeXLive easier.
Diffstat (limited to 'lang')
-rw-r--r--lang/hope/Makefile4
-rw-r--r--lang/logo/Makefile2
-rw-r--r--lang/mlton/Makefile4
-rw-r--r--lang/twelf/Makefile2
4 files changed, 6 insertions, 6 deletions
diff --git a/lang/hope/Makefile b/lang/hope/Makefile
index d909f235486..a4f6bd4e9e3 100644
--- a/lang/hope/Makefile
+++ b/lang/hope/Makefile
@@ -15,8 +15,8 @@ MAINTAINER= lev@FreeBSD.org
COMMENT= Hope is lazy interpreter for HOPE applicative language
.if defined(WITH_DOCS)
-BUILD_DEPENDS+= latex:${PORTSDIR}/print/teTeX \
- latex2html:${PORTSDIR}/textproc/latex2html
+USE_TEX= tetex
+BUILD_DEPENDS+= latex2html:${PORTSDIR}/textproc/latex2html
MAKE_ARGS+= WITH_DOCS=yes
.else
NOPORTDOCS= yes
diff --git a/lang/logo/Makefile b/lang/logo/Makefile
index 75eb8e02949..c2c9b88aebf 100644
--- a/lang/logo/Makefile
+++ b/lang/logo/Makefile
@@ -21,7 +21,7 @@ USE_EMACS= yes
.if defined(WITH_FULL_DOCS)
.undef NOPORTDOCS
-BUILD_DEPENDS+= tex:${PORTSDIR}/print/teTeX-base
+USE_TEX= tetex
USE_GHOSTSCRIPT=yes
.endif
diff --git a/lang/mlton/Makefile b/lang/mlton/Makefile
index 85fedba9c67..6f085de7a9b 100644
--- a/lang/mlton/Makefile
+++ b/lang/mlton/Makefile
@@ -31,8 +31,8 @@ OPTIONS= SMLNJ "Bootstrap with SML/NJ (can take >15 hours)" off \
.if !defined(NOPORTDOCS)
BUILD_DEPENDS+= gsed:${PORTSDIR}/textproc/gsed \
- htmldoc:${PORTSDIR}/textproc/htmldoc \
- latex:${PORTSDIR}/print/teTeX
+ htmldoc:${PORTSDIR}/textproc/htmldoc
+USE_TEX= tetex
.else
INSTALL_TARGET= install-no-docs
ALL_TARGET= all-no-docs
diff --git a/lang/twelf/Makefile b/lang/twelf/Makefile
index eb864a89daf..c7b2c8599a2 100644
--- a/lang/twelf/Makefile
+++ b/lang/twelf/Makefile
@@ -26,7 +26,7 @@ RUN_DEPENDS= sml:${PORTSDIR}/lang/sml-nj
BUILD_DEPENDS= sml:${PORTSDIR}/lang/sml-nj
.endif
-BUILD_DEPENDS+= tex:${PORTSDIR}/print/teTeX
+USE_TEX= tetex
.if defined(WITH_MLTON)
MAKEFILE= mlton/Makefile