aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2014-04-08 23:15:31 +0800
committerale <ale@FreeBSD.org>2014-04-08 23:15:31 +0800
commit847c4629a77b101fb8384faf92d76783305759a3 (patch)
tree1e24ae60347718d51f29dec3ee6d7e6b8299cf16 /lang
parent075d6d66e6057fafd1fed0fb1e1099cbd338cd19 (diff)
downloadfreebsd-ports-graphics-847c4629a77b101fb8384faf92d76783305759a3.tar.gz
freebsd-ports-graphics-847c4629a77b101fb8384faf92d76783305759a3.tar.zst
freebsd-ports-graphics-847c4629a77b101fb8384faf92d76783305759a3.zip
Force users to update their options file if APACHE was selected.
Diffstat (limited to 'lang')
-rw-r--r--lang/php5/Makefile5
-rw-r--r--lang/php55/Makefile5
2 files changed, 10 insertions, 0 deletions
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index 029b1f0fd38..c1e7d63724c 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -87,6 +87,11 @@ CONFIGURE_ARGS+=--enable-fpm \
--with-fpm-group=${WWWGRP}
.endif
+.if defined(OPTIONS_FILE_SET) && ${OPTIONS_FILE_SET:MAPACHE}
+IGNORE= doesn't install the Apache module anymore:\
+ update your OPTIONS and build www/mod_php5 port instead
+.endif
+
.if defined(PKGNAMEPREFIX)
USE_PHP= yes
PHP_DEFAULT= 5.4
diff --git a/lang/php55/Makefile b/lang/php55/Makefile
index c8e6485d2ee..f909d9fac40 100644
--- a/lang/php55/Makefile
+++ b/lang/php55/Makefile
@@ -87,6 +87,11 @@ CONFIGURE_ARGS+=--enable-fpm \
--with-fpm-group=${WWWGRP}
.endif
+.if defined(OPTIONS_FILE_SET) && ${OPTIONS_FILE_SET:MAPACHE}
+IGNORE= doesn't install the Apache module anymore:\
+ update your OPTIONS and build www/mod_php55 port instead
+.endif
+
.if defined(PKGNAMEPREFIX)
USE_PHP= yes
PHP_DEFAULT= 5.5