aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2012-05-16 15:36:13 +0800
committerale <ale@FreeBSD.org>2012-05-16 15:36:13 +0800
commit98bfb3f1bd1ab1211f0ffa4a9dba280b44dbdaae (patch)
tree1bef28c5677229cd9fa338b06bc2df18615fbcd1 /lang
parent45ef2d153f6328a9bf114fc43d7048c5349735f4 (diff)
downloadfreebsd-ports-graphics-98bfb3f1bd1ab1211f0ffa4a9dba280b44dbdaae.tar.gz
freebsd-ports-graphics-98bfb3f1bd1ab1211f0ffa4a9dba280b44dbdaae.tar.zst
freebsd-ports-graphics-98bfb3f1bd1ab1211f0ffa4a9dba280b44dbdaae.zip
Update to 5.4.3 release:
- add support for embedded php library - add support for dtrace Re-organize bsd.php.mk: - add WANT_PHP_EMD - fix handling of WANT_PHP_* - remove php4 extensions From UPDATING: Suhosin patch has been disabled until the new version will be released (soon). Suhosing extension will take more time. LINKTHR option is now enabled by default, be sure to flag it if you are updating using an old saved configuration. sqlite2 extension has been permanently removed. If you want to remain at PHP 5.3, a new port (lang/php53) will be committed soon.
Diffstat (limited to 'lang')
-rw-r--r--lang/php5-extensions/Makefile14
-rw-r--r--lang/php5/Makefile48
-rw-r--r--lang/php5/Makefile.ext35
-rw-r--r--lang/php5/distinfo10
-rw-r--r--lang/php5/files/patch-Zend_zend_list.c16
-rw-r--r--lang/php5/files/patch-Zend_zend_list.h14
-rw-r--r--lang/php5/files/patch-acinclude.m49
-rw-r--r--lang/php5/files/patch-configure.in23
-rw-r--r--lang/php5/files/patch-php.ini-development18
-rw-r--r--lang/php5/files/patch-php.ini-production18
-rw-r--r--lang/php5/files/patch-sapi_cgi_Makefile.frag9
-rw-r--r--lang/php5/files/patch-sapi_cgi_config9.m456
-rw-r--r--lang/php5/files/patch-sapi_fpm_Makefile.frag17
-rw-r--r--lang/php5/files/patch-sapi_fpm_config.m442
-rw-r--r--lang/php5/pkg-plist18
15 files changed, 88 insertions, 259 deletions
diff --git a/lang/php5-extensions/Makefile b/lang/php5-extensions/Makefile
index 0ba67d430fb..0bd3d3ea086 100644
--- a/lang/php5-extensions/Makefile
+++ b/lang/php5-extensions/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= php5
-PORTVERSION= 1.6
+PORTVERSION= 1.7
CATEGORIES= lang
MASTER_SITES= # none
PKGNAMESUFFIX= -extensions
@@ -18,7 +18,7 @@ COMMENT= A "meta-port" to install PHP extensions
USE_PHP= yes
DEFAULT_PHP_VER=5
-IGNORE_WITH_PHP=4
+IGNORE_WITH_PHP=52 53
USE_PHP_BUILD= yes
NO_BUILD= yes
@@ -37,7 +37,6 @@ WITH_PHAR= yes
WITH_POSIX= yes
WITH_SESSION= yes
WITH_SIMPLEXML= yes
-WITH_SQLITE= yes
WITH_SQLITE3= yes
WITH_TOKENIZER= yes
WITH_XML= yes
@@ -54,7 +53,6 @@ OPTIONS= BCMATH "bc style precision math functions" off \
EXIF "EXIF support" off \
FILEINFO "fileinfo support" off \
FILTER "input filter support" on \
- FRIBIDI "FriBidi support" off \
FTP "FTP support" off \
GD "GD library support" off \
GETTEXT "gettext library support" off \
@@ -88,7 +86,6 @@ OPTIONS= BCMATH "bc style precision math functions" off \
SNMP "SNMP support" off \
SOAP "SOAP support" off \
SOCKETS "sockets support" off \
- SQLITE "sqlite support" on \
SQLITE3 "sqlite3 support" on \
SYBASE_CT "Sybase database support" off \
SYSVMSG "System V message support" off \
@@ -102,19 +99,18 @@ OPTIONS= BCMATH "bc style precision math functions" off \
XMLRPC "XMLRPC-EPI support" off \
XMLWRITER "XMLWriter support" on \
XSL "XSL support (Implies DOM)" off \
- YAZ "YAZ support (ANSI/NISO Z39.50)" off \
ZIP "ZIP support" off \
ZLIB "ZLIB support" off
ALL_OPTIONS= BCMATH BZ2 CALENDAR CTYPE CURL DBA \
- DOM EXIF FILEINFO FILTER FRIBIDI FTP GD GETTEXT \
+ DOM EXIF FILEINFO FILTER FTP GD GETTEXT \
GMP HASH ICONV IMAP INTERBASE JSON LDAP MBSTRING MCRYPT \
MSSQL MYSQL MYSQLI \
ODBC OPENSSL PCNTL PDF PDO PDO_SQLITE PGSQL PHAR POSIX \
PSPELL READLINE RECODE SESSION SHMOP SIMPLEXML SNMP SOAP \
- SOCKETS SQLITE SQLITE3 SYBASE_CT SYSVMSG SYSVSEM SYSVSHM \
+ SOCKETS SQLITE3 SYBASE_CT SYSVMSG SYSVSEM SYSVSHM \
TIDY TOKENIZER WDDX XML XMLREADER XMLRPC XMLWRITER XSL \
- YAZ ZIP ZLIB
+ ZIP ZLIB
.include <bsd.port.options.mk>
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index 849f5f3e0a4..f577071b133 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= php5
-PORTVERSION= 5.3.13
+PORTVERSION= 5.4.3
PORTREVISION?= 0
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP}
@@ -16,6 +16,8 @@ DISTNAME= php-${PORTVERSION}
MAINTAINER= ale@FreeBSD.org
COMMENT= PHP Scripting Language
+LICENSE= PHP301
+
LATEST_LINK= ${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX}
USE_BZIP2= yes
@@ -41,17 +43,18 @@ USE_GNOME= libxml2
OPTIONS= CLI "Build CLI version" on \
CGI "Build CGI version" on \
- FPM "Build FPM version (experimental)" off \
+ FPM "Build FPM version" off \
APACHE "Build Apache module" off \
AP2FILTER " Use Apache 2.x filter interface (experimental)" off \
+ EMBED "Build embedded library" off \
DEBUG "Enable debug" off \
- SUHOSIN "Enable Suhosin protection system" on \
- MULTIBYTE "Enable zend multibyte support" off \
+ DTRACE "Enable DTrace support" off \
IPV6 "Enable ipv6 support" on \
MAILHEAD "Enable mail header patch" off \
- LINKTHR "Link thread lib (for threaded extensions)" off
+ LINKTHR "Link thread lib (for threaded extensions)" on
+# SUHOSIN "Enable Suhosin protection system" on \
-CONFLICTS= php4-4* php5-pcre-* php5-spl-*
+CONFLICTS= php52-5* php53-5*
MAN1= php-config.1 phpize.1
@@ -62,16 +65,16 @@ PATCH_DIST_STRIP= -p1
PATCH_SITES+= ${MASTER_SITE_LOCAL}
PATCH_SITE_SUBDIR= ale
-.if !defined(WITHOUT_SUHOSIN)
-PATCHFILES+= suhosin-patch-5.3.x-0.9.10.patch.gz
-PATCH_SITES+= http://download.suhosin.org/:suhosin
-PLIST_SUB+= SUHOSIN=""
-.else
+#.if !defined(WITHOUT_SUHOSIN)
+#PATCHFILES+= suhosin-patch-5.3.x-0.9.10.patch.gz
+#PATCH_SITES+= http://download.suhosin.org/:suhosin
+#PLIST_SUB+= SUHOSIN=""
+#.else
PLIST_SUB+= SUHOSIN="@comment "
-.endif
+#.endif
.if defined(WITH_MAILHEAD)
-PATCHFILES+= php-5.3.x-mail-header.patch:mail
+PATCHFILES+= php-5.4.x-mail-header.patch:mail
PATCH_SITES+= http://choon.net/opensource/php/:mail
.endif
@@ -104,6 +107,10 @@ PLIST_SUB+= FPM=""
PLIST_SUB+= FPM="@comment "
.endif
+.if defined(WITH_APACHE) && defined(WITH_EMBED)
+IGNORE= cannot be built with multiple SAPI (apache and embedded)
+.endif
+
.if defined(WITH_APACHE)
PHP_SAPI+= mod
USE_APACHE= 20+
@@ -121,6 +128,14 @@ PLIST_SUB+= APACHE=""
PLIST_SUB+= APACHE="@comment "
.endif
+.if defined(WITH_EMBED)
+PHP_SAPI+= embed
+CONFIGURE_ARGS+=--enable-embed
+PLIST_SUB+= EMBED=""
+.else
+PLIST_SUB+= EMBED="@comment "
+.endif
+
.if !defined(WITH_REGEX_TYPE) || ${WITH_REGEX_TYPE} == "php"
CONFIGURE_ARGS+=--with-regex=php
.elif defined(WITH_REGEX_TYPE) && ${WITH_REGEX_TYPE} == "system"
@@ -148,8 +163,11 @@ CONFIGURE_ENV+= LIBS="${LIBS} ${PTHREAD_LIBS}"
CONFIGURE_ARGS+=--enable-debug
.endif
-.if defined(WITH_MULTIBYTE)
-CONFIGURE_ARGS+=--enable-zend-multibyte
+.if defined(WITH_DTRACE)
+.if ${OSVERSION} < 900000
+IGNORE= cannot be built with DTrace support on FreeBSD < 9.x
+.endif
+CONFIGURE_ARGS+=--enable-dtrace
.endif
.if defined(WITHOUT_IPV6)
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index 4e36f723883..8f3007eb391 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -44,6 +44,7 @@ OPTIONS= CDB "cdb database support" on \
DB4 "Berkeley DB4 support" off \
GDBM "GDBM database support" off \
QDBM "QDBM database support" off \
+ TOKYO "Tokyo Cabinet database support" off \
INIFILE "INI file support" on \
FLATFILE "flatfile support" on
@@ -100,7 +101,8 @@ CONFIGURE_ARGS+=--with-xpm-dir=${LOCALBASE}
OPTIONS= T1LIB "Include T1lib support" on \
TRUETYPE "Enable TrueType string function" on \
- JIS "Enable JIS-mapped Japanese font support" off
+ JIS "Enable JIS-mapped Japanese font support" off \
+ VPX "Enable VP8 codec support" off
PHP_HEADER_DIRS=libgd
.endif
@@ -318,8 +320,9 @@ USE_GNOME= libxml2
.if ${PHP_MODNAME} == "snmp"
CONFIGURE_ARGS+=--with-snmp=${LOCALBASE} \
- --with-openssl-dir=${OPENSSLBASE} \
- --enable-ucd-snmp-hack
+ --with-openssl-dir=${OPENSSLBASE}
+
+CONFIGURE_ENV+= ac_cv_buggy_snprint_value="no"
LIB_DEPENDS+= netsnmp.30:${PORTSDIR}/net-mgmt/net-snmp
LDFLAGS+= -L${OPENSSLLIB} -lcrypto -lssl
@@ -340,16 +343,6 @@ USE_PHP_BUILD= yes
CONFIGURE_ARGS+=--enable-sockets
.endif
-.if ${PHP_MODNAME} == "sqlite"
-CONFIGURE_ARGS+=--with-sqlite
-
-USE_PHP= session
-USE_PHP_BUILD= yes
-PHP_HEADER_DIRS=libsqlite/src
-
-OPTIONS= UTF8 "Enable UTF-8 support" off
-.endif
-
.if ${PHP_MODNAME} == "sqlite3"
USE_SQLITE= yes
CONFIGURE_ARGS+=--with-sqlite3=${LOCALBASE}
@@ -471,6 +464,11 @@ LIB_DEPENDS+= qdbm.14:${PORTSDIR}/databases/qdbm
CONFIGURE_ARGS+=--with-qdbm=${LOCALBASE}
. endif
+. if defined(WITH_TOKYO)
+LIB_DEPENDS+= tokyocabinet.9:${PORTSDIR}/databases/tokyocabinet
+
+CONFIGURE_ARGS+=--with-tcadb=${LOCALBASE}
+. endif
. if defined(WITHOUT_INIFILE)
CONFIGURE_ARGS+=--disable-inifile
. endif
@@ -491,6 +489,11 @@ CONFIGURE_ARGS+=--enable-gd-native-ttf
. if defined(WITH_JIS)
CONFIGURE_ARGS+=--enable-gd-jis-conv
. endif
+. if defined(WITH_VPX)
+LIB_DEPENDS+= vpx.1:${PORTSDIR}/multimedia/libvpx
+
+CONFIGURE_ARGS+=--with-vpx-dir=${LOCALBASE}
+. endif
.endif
.if ${PHP_MODNAME} == "mbstring"
@@ -573,12 +576,6 @@ USE_MYSQL= yes
. endif
.endif
-.if ${PHP_MODNAME} == "sqlite"
-. if defined(WITH_UTF8)
-CONFIGURE_ARGS+=--enable-sqlite-utf8
-. endif
-.endif
-
.if ${PHP_MODNAME} == "xml"
post-extract:
@${MKDIR} ${WRKSRC}/ext/xml
diff --git a/lang/php5/distinfo b/lang/php5/distinfo
index 29951e197c2..f33518d8490 100644
--- a/lang/php5/distinfo
+++ b/lang/php5/distinfo
@@ -1,6 +1,4 @@
-SHA256 (php-5.3.13.tar.bz2) = ef1a7235b16be449f31f73f60d5770a133b863d225d65a218546cfb7d031d99b
-SIZE (php-5.3.13.tar.bz2) = 11396389
-SHA256 (suhosin-patch-5.3.x-0.9.10.patch.gz) = 4438caeab0a10c6c94aee9f7eaa703f5799f97d4e0579f43a947bb7314e38317
-SIZE (suhosin-patch-5.3.x-0.9.10.patch.gz) = 40967
-SHA256 (php-5.3.x-mail-header.patch) = 5a677448b32d9f592703e2323a33facdb45e5c237dcca04aaea8ec3287f7db84
-SIZE (php-5.3.x-mail-header.patch) = 3325
+SHA256 (php-5.4.3.tar.bz2) = d7e0c987586b6554ee08e3b71cc2806ddd1b192451159083d861c132994bc1bd
+SIZE (php-5.4.3.tar.bz2) = 11147567
+SHA256 (php-5.4.x-mail-header.patch) = 005ae1cd8ed17c72d7b09dee9c4466e8b16d4ecba7fe11276731ed6ff9fbb344
+SIZE (php-5.4.x-mail-header.patch) = 3379
diff --git a/lang/php5/files/patch-Zend_zend_list.c b/lang/php5/files/patch-Zend_zend_list.c
index efa8862d1ce..f71b6f6ac0e 100644
--- a/lang/php5/files/patch-Zend_zend_list.c
+++ b/lang/php5/files/patch-Zend_zend_list.c
@@ -1,6 +1,6 @@
---- Zend/zend_list.c.orig 2007-01-01 10:35:46.000000000 +0100
-+++ Zend/zend_list.c 2008-01-29 11:05:14.000000000 +0100
-@@ -48,7 +48,7 @@
+--- Zend/zend_list.c.orig 2012-01-01 14:15:04.000000000 +0100
++++ Zend/zend_list.c 2012-03-02 10:29:02.000000000 +0100
+@@ -47,7 +47,7 @@
return index;
}
@@ -9,7 +9,7 @@
{
zend_rsrc_list_entry *le;
-@@ -65,7 +65,7 @@
+@@ -64,7 +64,7 @@
}
@@ -18,7 +18,7 @@
{
zend_rsrc_list_entry *le;
-@@ -78,7 +78,7 @@
+@@ -77,7 +77,7 @@
}
}
@@ -27,12 +27,12 @@
{
zend_rsrc_list_entry *le;
-@@ -350,7 +350,7 @@
+@@ -348,7 +348,7 @@
}
--char *zend_rsrc_list_get_rsrc_type(int resource TSRMLS_DC)
-+char *zend_rsrc_list_get_rsrc_type(ulong resource TSRMLS_DC)
+-const char *zend_rsrc_list_get_rsrc_type(int resource TSRMLS_DC)
++const char *zend_rsrc_list_get_rsrc_type(ulong resource TSRMLS_DC)
{
zend_rsrc_list_dtors_entry *lde;
int rsrc_type;
diff --git a/lang/php5/files/patch-Zend_zend_list.h b/lang/php5/files/patch-Zend_zend_list.h
index 308ac56b33b..cbfedf6a8a6 100644
--- a/lang/php5/files/patch-Zend_zend_list.h
+++ b/lang/php5/files/patch-Zend_zend_list.h
@@ -1,9 +1,9 @@
---- Zend/zend_list.h.orig 2007-01-01 10:35:46.000000000 +0100
-+++ Zend/zend_list.h 2008-01-29 11:05:12.000000000 +0100
+--- Zend/zend_list.h.orig 2012-01-01 14:15:04.000000000 +0100
++++ Zend/zend_list.h 2012-03-02 10:36:42.000000000 +0100
@@ -71,9 +71,9 @@
void zend_destroy_rsrc_list_dtors(void);
- ZEND_API int zend_list_insert(void *ptr, int type);
+ ZEND_API int zend_list_insert(void *ptr, int type TSRMLS_DC);
-ZEND_API int _zend_list_addref(int id TSRMLS_DC);
-ZEND_API int _zend_list_delete(int id TSRMLS_DC);
-ZEND_API void *_zend_list_find(int id, int *type TSRMLS_DC);
@@ -14,11 +14,11 @@
#define zend_list_addref(id) _zend_list_addref(id TSRMLS_CC)
#define zend_list_delete(id) _zend_list_delete(id TSRMLS_CC)
@@ -82,7 +82,7 @@
- ZEND_API int zend_register_resource(zval *rsrc_result, void *rsrc_pointer, int rsrc_type);
- ZEND_API void *zend_fetch_resource(zval **passed_id TSRMLS_DC, int default_id, char *resource_type_name, int *found_resource_type, int num_resource_types, ...);
+ ZEND_API int zend_register_resource(zval *rsrc_result, void *rsrc_pointer, int rsrc_type TSRMLS_DC);
+ ZEND_API void *zend_fetch_resource(zval **passed_id TSRMLS_DC, int default_id, const char *resource_type_name, int *found_resource_type, int num_resource_types, ...);
--ZEND_API char *zend_rsrc_list_get_rsrc_type(int resource TSRMLS_DC);
-+ZEND_API char *zend_rsrc_list_get_rsrc_type(ulong resource TSRMLS_DC);
+-ZEND_API const char *zend_rsrc_list_get_rsrc_type(int resource TSRMLS_DC);
++ZEND_API const char *zend_rsrc_list_get_rsrc_type(ulong resource TSRMLS_DC);
ZEND_API int zend_fetch_list_dtor_id(char *type_name);
extern ZEND_API int le_index_ptr; /* list entry type for index pointers */
diff --git a/lang/php5/files/patch-acinclude.m4 b/lang/php5/files/patch-acinclude.m4
index d92738cdf77..29bb5a5d78c 100644
--- a/lang/php5/files/patch-acinclude.m4
+++ b/lang/php5/files/patch-acinclude.m4
@@ -1,14 +1,5 @@
--- acinclude.m4.orig 2009-05-09 22:28:02.000000000 +0200
+++ acinclude.m4 2009-06-25 08:08:05.000000000 +0200
-@@ -194,7 +194,7 @@
- dnl
- dnl which array to append to?
- AC_DEFUN([PHP_ADD_SOURCES],[
-- PHP_ADD_SOURCES_X($1, $2, $3, ifelse($4,cli,PHP_CLI_OBJS,ifelse($4,sapi,PHP_SAPI_OBJS,PHP_GLOBAL_OBJS)))
-+ PHP_ADD_SOURCES_X($1, $2, $3, ifelse($4,cli,PHP_CLI_OBJS,ifelse($4,sapi,PHP_SAPI_OBJS,ifelse($4,cgi,PHP_CGI_OBJS,ifelse($4,fpm,PHP_FPM_OBJS,PHP_GLOBAL_OBJS)))))
- ])
-
- dnl
@@ -968,15 +968,9 @@
if test "$3" != "shared" && test "$3" != "yes" && test "$4" = "cli"; then
dnl ---------------------------------------------- CLI static module
diff --git a/lang/php5/files/patch-configure.in b/lang/php5/files/patch-configure.in
index d6e90018c51..ec117ae7629 100644
--- a/lang/php5/files/patch-configure.in
+++ b/lang/php5/files/patch-configure.in
@@ -34,31 +34,12 @@
exec_prefix=$old_exec_prefix
libdir=$old_libdir
-@@ -1373,22 +1371,19 @@
- pharcmd_install=
- fi;
-
--all_targets="$lcov_target \$(OVERALL_TARGET) \$(PHP_MODULES) \$(PHP_ZEND_EX) \$(PHP_CLI_TARGET) $pharcmd"
--install_targets="$install_modules install-build install-headers install-programs $install_pear $pharcmd_install"
-+all_targets="$lcov_target \$(OVERALL_TARGET) \$(PHP_MODULES) \$(PHP_ZEND_EX) \$(PHP_CLI_TARGET) \$(PHP_CGI_TARGET) \$(PHP_FPM_TARGET) $pharcmd"
-+install_targets="$PHP_INSTALL_CLI_TARGET $PHP_INSTALL_CGI_TARGET $install_modules install-build install-headers install-programs $install_pear $pharcmd_install"
-
- case $PHP_SAPI in
-- cli)
-- install_targets="$PHP_INSTALL_CLI_TARGET $install_targets"
-- ;;
-- *)
-- install_targets="install-sapi $PHP_INSTALL_CLI_TARGET $install_targets"
-+ apache|apache2handler|apache2filter)
-+ install_targets="install-sapi $install_targets"
- ;;
- esac
-
+@@ -1373,7 +1371,7 @@
PHP_SUBST(all_targets)
PHP_SUBST(install_targets)
-PHP_INSTALL_HEADERS([Zend/ TSRM/ include/ main/ main/streams/])
-+PHP_INSTALL_HEADERS([Zend/ TSRM/ main/ main/streams/])
++PHP_INSTALL_HEADERS([Zend/ TSRM/ main/ main/streams/ sapi/cli/cli.h])
PHP_ADD_SOURCES(TSRM, TSRM.c tsrm_strtok_r.c tsrm_virtual_cwd.c)
diff --git a/lang/php5/files/patch-php.ini-development b/lang/php5/files/patch-php.ini-development
deleted file mode 100644
index dadeb4b838b..00000000000
--- a/lang/php5/files/patch-php.ini-development
+++ /dev/null
@@ -1,18 +0,0 @@
---- php.ini-development.orig 2009-06-28 19:56:18.000000000 +0200
-+++ php.ini-development 2009-08-24 17:17:53.000000000 +0200
-@@ -335,6 +335,15 @@
-
- ; Safe Mode
- ; http://php.net/safe-mode
-+;
-+; SECURITY NOTE: The FreeBSD Security Officer strongly recommend that
-+; the PHP Safe Mode feature not be relied upon for security, since the
-+; issues Safe Mode tries to handle cannot properly be handled in PHP
-+; (primarily due to PHP's use of external libraries). While many bugs
-+; in Safe Mode has been fixed it's very likely that more issues exist
-+; which allows a user to bypass Safe Mode restrictions.
-+; For increased security we always recommend to install the Suhosin
-+; extension.
- safe_mode = Off
-
- ; By default, Safe Mode does a UID compare check when
diff --git a/lang/php5/files/patch-php.ini-production b/lang/php5/files/patch-php.ini-production
deleted file mode 100644
index 67d3480ad4a..00000000000
--- a/lang/php5/files/patch-php.ini-production
+++ /dev/null
@@ -1,18 +0,0 @@
---- php.ini-production.orig 2009-08-24 17:18:23.000000000 +0200
-+++ php.ini-production 2009-08-24 17:18:33.000000000 +0200
-@@ -335,6 +335,15 @@
-
- ; Safe Mode
- ; http://php.net/safe-mode
-+;
-+; SECURITY NOTE: The FreeBSD Security Officer strongly recommend that
-+; the PHP Safe Mode feature not be relied upon for security, since the
-+; issues Safe Mode tries to handle cannot properly be handled in PHP
-+; (primarily due to PHP's use of external libraries). While many bugs
-+; in Safe Mode has been fixed it's very likely that more issues exist
-+; which allows a user to bypass Safe Mode restrictions.
-+; For increased security we always recommend to install the Suhosin
-+; extension.
- safe_mode = Off
-
- ; By default, Safe Mode does a UID compare check when
diff --git a/lang/php5/files/patch-sapi_cgi_Makefile.frag b/lang/php5/files/patch-sapi_cgi_Makefile.frag
deleted file mode 100644
index 26a0e4b1a3b..00000000000
--- a/lang/php5/files/patch-sapi_cgi_Makefile.frag
+++ /dev/null
@@ -1,9 +0,0 @@
---- sapi/cgi/Makefile.frag.orig Wed May 3 10:09:02 2006
-+++ sapi/cgi/Makefile.frag Wed May 3 10:08:54 2006
-@@ -1,2 +1,5 @@
--$(SAPI_CGI_PATH): $(PHP_GLOBAL_OBJS) $(PHP_SAPI_OBJS)
-+$(SAPI_CGI_PATH): $(PHP_GLOBAL_OBJS) $(PHP_CGI_OBJS)
- $(BUILD_CGI)
-+
-+install-cgi: $(SAPI_CGI_PATH)
-+ @$(INSTALL_CGI)
diff --git a/lang/php5/files/patch-sapi_cgi_config9.m4 b/lang/php5/files/patch-sapi_cgi_config9.m4
deleted file mode 100644
index 7682dad4311..00000000000
--- a/lang/php5/files/patch-sapi_cgi_config9.m4
+++ /dev/null
@@ -1,56 +0,0 @@
---- sapi/cgi/config9.m4.orig 2007-10-01 14:40:54.000000000 +0200
-+++ sapi/cgi/config9.m4 2008-09-25 23:07:13.000000000 +0200
-@@ -8,7 +8,6 @@
- dnl
- dnl CGI setup
- dnl
--if test "$PHP_SAPI" = "default"; then
- AC_MSG_CHECKING(whether to build CGI binary)
- if test "$PHP_CGI" != "no"; then
- AC_MSG_RESULT(yes)
-@@ -53,8 +52,9 @@
- PHP_SUBST(SAPI_CGI_PATH)
-
- dnl Set install target and select SAPI
-- INSTALL_IT="@echo \"Installing PHP CGI binary: \$(INSTALL_ROOT)\$(bindir)/\"; \$(INSTALL) -m 0755 \$(SAPI_CGI_PATH) \$(INSTALL_ROOT)\$(bindir)/\$(program_prefix)php-cgi\$(program_suffix)\$(EXEEXT)"
-- PHP_SELECT_SAPI(cgi, program, cgi_main.c fastcgi.c,, '$(SAPI_CGI_PATH)')
-+ INSTALL_CGI="@echo \"Installing PHP CGI binary: \$(INSTALL_ROOT)\$(bindir)/\"; \$(INSTALL) -m 0755 \$(SAPI_CGI_PATH) \$(INSTALL_ROOT)\$(bindir)/\$(program_prefix)php-cgi\$(program_suffix)\$(EXEEXT)"
-+ PHP_ADD_SOURCES(sapi/cgi, cgi_main.c fastcgi.c,, cgi)
-+ PHP_ADD_SOURCES(/main, internal_functions.c,,cgi)
-
- case $host_alias in
- *aix*)
-@@ -64,17 +64,29 @@
- BUILD_CGI="\$(CC) \$(CFLAGS_CLEAN) \$(EXTRA_CFLAGS) \$(EXTRA_LDFLAGS_PROGRAM) \$(LDFLAGS) \$(NATIVE_RPATHS) \$(PHP_GLOBAL_OBJS:.lo=.o) \$(PHP_SAPI_OBJS:.lo=.o) \$(PHP_FRAMEWORKS) \$(EXTRA_LIBS) \$(ZEND_EXTRA_LIBS) -o \$(SAPI_CGI_PATH)"
- ;;
- *)
-- BUILD_CGI="\$(LIBTOOL) --mode=link \$(CC) -export-dynamic \$(CFLAGS_CLEAN) \$(EXTRA_CFLAGS) \$(EXTRA_LDFLAGS_PROGRAM) \$(LDFLAGS) \$(PHP_RPATHS) \$(PHP_GLOBAL_OBJS) \$(PHP_SAPI_OBJS) \$(EXTRA_LIBS) \$(ZEND_EXTRA_LIBS) -o \$(SAPI_CGI_PATH)"
-+ BUILD_CGI="\$(LIBTOOL) --mode=link \$(CC) -export-dynamic \$(CFLAGS_CLEAN) \$(EXTRA_CFLAGS) \$(EXTRA_LDFLAGS_PROGRAM) \$(LDFLAGS) \$(PHP_RPATHS) \$(PHP_GLOBAL_OBJS) \$(PHP_CGI_OBJS) \$(EXTRA_LIBS) \$(ZEND_EXTRA_LIBS) -o \$(SAPI_CGI_PATH)"
- ;;
- esac
-
-+ PHP_CGI_TARGET="\$(SAPI_CGI_PATH)"
-+ PHP_INSTALL_CGI_TARGET="install-cgi"
- PHP_SUBST(BUILD_CGI)
--
-- elif test "$PHP_CLI" != "no"; then
-- AC_MSG_RESULT(no)
-+ PHP_SUBST(INSTALL_CGI)
-+ PHP_SUBST(PHP_CGI_OBJS)
-+ PHP_SUBST(PHP_CGI_TARGET)
-+ PHP_SUBST(PHP_INSTALL_CGI_TARGET)
-+
-+ if test "$PHP_SAPI" = "default" ; then
-+ PHP_BUILD_PROGRAM($SAPI_CGI_PATH)
-+ fi
-+ else
-+ AC_MSG_RESULT(no)
-+ if test "$PHP_SAPI" = "default" ; then
-+ if test "$PHP_CLI" != "no" ; then
- OVERALL_TARGET=
- PHP_SAPI=cli
- else
- AC_MSG_ERROR([No SAPIs selected.])
- fi
-+ fi
- fi
diff --git a/lang/php5/files/patch-sapi_fpm_Makefile.frag b/lang/php5/files/patch-sapi_fpm_Makefile.frag
index 53da2da35f7..3d777795dd8 100644
--- a/lang/php5/files/patch-sapi_fpm_Makefile.frag
+++ b/lang/php5/files/patch-sapi_fpm_Makefile.frag
@@ -1,22 +1,5 @@
--- sapi/fpm/Makefile.frag.orig 2011-10-08 23:04:10.000000000 +0200
+++ sapi/fpm/Makefile.frag 2012-02-09 16:43:25.000000000 +0100
-@@ -4,14 +4,14 @@
- @mkdir -p $(builddir)/fpm
- @mkdir -p $(builddir)/fpm/events
-
--$(SAPI_FPM_PATH): $(builddir)/fpm $(PHP_GLOBAL_OBJS) $(PHP_SAPI_OBJS) $(SAPI_EXTRA_DEPS)
-+$(SAPI_FPM_PATH): $(builddir)/fpm $(PHP_GLOBAL_OBJS) $(PHP_FPM_OBJS) $(FPM_EXTRA_DEPS)
- $(BUILD_FPM)
-
- $(builddir)/fpm/fpm_conf.lo: $(builddir)/../../main/build-defs.h
-
- install-build: install-fpm
-
--install-fpm: install-sapi
-+install-fpm:
- @echo "Installing PHP FPM binary: $(INSTALL_ROOT)$(sbindir)/"
- @$(mkinstalldirs) $(INSTALL_ROOT)$(sbindir)
- @$(mkinstalldirs) $(INSTALL_ROOT)$(localstatedir)/log
@@ -27,6 +27,6 @@
@$(mkinstalldirs) $(INSTALL_ROOT)$(mandir)/man8
@$(INSTALL_DATA) sapi/fpm/php-fpm.8 $(INSTALL_ROOT)$(mandir)/man8/php-fpm$(program_suffix).8
diff --git a/lang/php5/files/patch-sapi_fpm_config.m4 b/lang/php5/files/patch-sapi_fpm_config.m4
index 859db721d66..a9db5afbe0a 100644
--- a/lang/php5/files/patch-sapi_fpm_config.m4
+++ b/lang/php5/files/patch-sapi_fpm_config.m4
@@ -18,45 +18,3 @@
AC_DEFINE([HAVE_LQ_SO_LISTENQ], 1, [do we have SO_LISTENQxxx?])
fi
fi
-@@ -423,7 +423,9 @@
-
- PHP_FPM_CFLAGS="-I$abs_srcdir/sapi/fpm"
-
-- INSTALL_IT=":"
-+ if test "$PHP_SAPI" = "default"; then
-+ PHP_SAPI="fpm"
-+ fi
- PHP_FPM_FILES="fpm/fastcgi.c \
- fpm/fpm.c \
- fpm/fpm_children.c \
-@@ -449,7 +451,8 @@
- fpm/zlog.c \
- "
-
-- PHP_SELECT_SAPI(fpm, program, $PHP_FPM_FILES $PHP_FPM_TRACE_FILES, $PHP_FPM_CFLAGS, '$(SAPI_FPM_PATH)')
-+ PHP_ADD_SOURCES(sapi/fpm, $PHP_FPM_FILES $PHP_FPM_TRACE_FILES, $PHP_FPM_CFLAGS, fpm)
-+ PHP_ADD_SOURCES(/main, internal_functions.c,,fpm)
-
- case $host_alias in
- *aix*)
-@@ -459,11 +462,19 @@
- BUILD_FPM="\$(CC) \$(CFLAGS_CLEAN) \$(EXTRA_CFLAGS) \$(EXTRA_LDFLAGS_PROGRAM) \$(LDFLAGS) \$(NATIVE_RPATHS) \$(PHP_GLOBAL_OBJS:.lo=.o) \$(PHP_SAPI_OBJS:.lo=.o) \$(PHP_FRAMEWORKS) \$(EXTRA_LIBS) \$(SAPI_EXTRA_LIBS) \$(ZEND_EXTRA_LIBS) -o \$(SAPI_FPM_PATH)"
- ;;
- *)
-- BUILD_FPM="\$(LIBTOOL) --mode=link \$(CC) -export-dynamic \$(CFLAGS_CLEAN) \$(EXTRA_CFLAGS) \$(EXTRA_LDFLAGS_PROGRAM) \$(LDFLAGS) \$(PHP_RPATHS) \$(PHP_GLOBAL_OBJS) \$(PHP_SAPI_OBJS) \$(EXTRA_LIBS) \$(SAPI_EXTRA_LIBS) \$(ZEND_EXTRA_LIBS) -o \$(SAPI_FPM_PATH)"
-+ BUILD_FPM="\$(LIBTOOL) --mode=link \$(CC) -export-dynamic \$(CFLAGS_CLEAN) \$(EXTRA_CFLAGS) \$(EXTRA_LDFLAGS_PROGRAM) \$(LDFLAGS) \$(PHP_RPATHS) \$(PHP_GLOBAL_OBJS) \$(PHP_FPM_OBJS) \$(EXTRA_LIBS) \$(ZEND_EXTRA_LIBS) -o \$(SAPI_FPM_PATH)"
- ;;
- esac
-
-+ PHP_FPM_TARGET="\$(SAPI_FPM_PATH)"
-+ PHP_INSTALL_FPM_TARGET="install-fpm"
- PHP_SUBST(BUILD_FPM)
-+ PHP_SUBST(PHP_FPM_OBJS)
-+ PHP_SUBST(PHP_FPM_TARGET)
-+ PHP_SUBST(PHP_INSTALL_FPM_TARGET)
-+ if test "$PHP_SAPI" = "fpm" ; then
-+ PHP_BUILD_PROGRAM($SAPI_FPM_PATH)
-+ fi
- else
- AC_MSG_RESULT(no)
- fi
diff --git a/lang/php5/pkg-plist b/lang/php5/pkg-plist
index 26bbd01e52c..c80024b757e 100644
--- a/lang/php5/pkg-plist
+++ b/lang/php5/pkg-plist
@@ -10,7 +10,6 @@ etc/php.ini-production
%%FPM%%etc/php-fpm.conf.default
%%FPM%%@exec cp -n %D/%F %B/php-fpm.conf
include/php/TSRM/TSRM.h
-include/php/TSRM/acconfig.h
include/php/TSRM/readdir.h
include/php/TSRM/tsrm_config.h
include/php/TSRM/tsrm_config.w32.h
@@ -19,7 +18,6 @@ include/php/TSRM/tsrm_nw.h
include/php/TSRM/tsrm_strtok_r.h
include/php/TSRM/tsrm_virtual_cwd.h
include/php/TSRM/tsrm_win32.h
-include/php/Zend/acconfig.h
include/php/Zend/zend.h
include/php/Zend/zend_API.h
include/php/Zend/zend_alloc.h
@@ -31,12 +29,12 @@ include/php/Zend/zend_config.h
include/php/Zend/zend_config.nw.h
include/php/Zend/zend_config.w32.h
include/php/Zend/zend_constants.h
+include/php/Zend/zend_dtrace.h
include/php/Zend/zend_dynamic_array.h
include/php/Zend/zend_errors.h
include/php/Zend/zend_exceptions.h
include/php/Zend/zend_execute.h
include/php/Zend/zend_extensions.h
-include/php/Zend/zend_fast_cache.h
include/php/Zend/zend_float.h
include/php/Zend/zend_gc.h
include/php/Zend/zend_globals.h
@@ -65,9 +63,11 @@ include/php/Zend/zend_objects_API.h
include/php/Zend/zend_operators.h
include/php/Zend/zend_ptr_stack.h
include/php/Zend/zend_qsort.h
+include/php/Zend/zend_signal.h
include/php/Zend/zend_stack.h
include/php/Zend/zend_static_allocator.h
include/php/Zend/zend_stream.h
+include/php/Zend/zend_string.h
include/php/Zend/zend_strtod.h
include/php/Zend/zend_ts_hash.h
include/php/Zend/zend_types.h
@@ -90,16 +90,19 @@ include/php/ext/ereg/regex/utils.h
include/php/ext/libxml/php_libxml.h
include/php/ext/mysqlnd/config-win.h
include/php/ext/mysqlnd/mysqlnd.h
+include/php/ext/mysqlnd/mysqlnd_alloc.h
include/php/ext/mysqlnd/mysqlnd_block_alloc.h
include/php/ext/mysqlnd/mysqlnd_charset.h
include/php/ext/mysqlnd/mysqlnd_debug.h
include/php/ext/mysqlnd/mysqlnd_enum_n_def.h
+include/php/ext/mysqlnd/mysqlnd_ext_plugin.h
include/php/ext/mysqlnd/mysqlnd_libmysql_compat.h
include/php/ext/mysqlnd/mysqlnd_net.h
include/php/ext/mysqlnd/mysqlnd_portability.h
include/php/ext/mysqlnd/mysqlnd_priv.h
include/php/ext/mysqlnd/mysqlnd_result.h
include/php/ext/mysqlnd/mysqlnd_result_meta.h
+include/php/ext/mysqlnd/mysqlnd_reverse_api.h
include/php/ext/mysqlnd/mysqlnd_statistics.h
include/php/ext/mysqlnd/mysqlnd_structs.h
include/php/ext/mysqlnd/mysqlnd_wireprotocol.h
@@ -135,6 +138,7 @@ include/php/ext/standard/flock_compat.h
include/php/ext/standard/fsock.h
include/php/ext/standard/head.h
include/php/ext/standard/html.h
+include/php/ext/standard/html_tables.h
include/php/ext/standard/info.h
include/php/ext/standard/md5.h
include/php/ext/standard/microtime.h
@@ -185,7 +189,6 @@ include/php/main/build-defs.h
include/php/main/fopen_wrappers.h
include/php/main/logos.h
include/php/main/php.h
-include/php/main/php3_compat.h
include/php/main/php_compat.h
include/php/main/php_config.h
include/php/main/php_content_types.h
@@ -206,7 +209,6 @@ include/php/main/php_ticks.h
include/php/main/php_variables.h
include/php/main/php_version.h
include/php/main/rfc1867.h
-include/php/main/safe_mode.h
include/php/main/snprintf.h
include/php/main/spprintf.h
include/php/main/streams/php_stream_context.h
@@ -217,11 +219,14 @@ include/php/main/streams/php_streams_int.h
include/php/main/streams/php_stream_transport.h
include/php/main/streams/php_stream_userspace.h
include/php/main/streams/php_stream_plain_wrapper.h
+include/php/sapi/cli/cli.h
+%%EMBED%%include/php/sapi/embed/php_embed.h
%%SUHOSIN%%include/php/main/suhosin_globals.h
%%SUHOSIN%%include/php/main/suhosin_logo.h
%%SUHOSIN%%include/php/main/suhosin_patch.h
include/php/main/win32_internal_function_disabled.h
include/php/main/win95nt.h
+%%EMBED%%lib/libphp5.so
lib/php/build/Makefile.global
lib/php/build/acinclude.m4
lib/php/build/config.guess
@@ -251,6 +256,9 @@ lib/php/build/shtool
@dirrmtry include/php/ext
@dirrm include/php/main/streams
@dirrm include/php/main
+@dirrm include/php/sapi/cli
+%%EMBED%%@dirrm include/php/sapi/embed
+@dirrm include/php/sapi
@dirrmtry include/php
@dirrm lib/php/build
@dirrmtry lib/php